LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 03-22-2009, 10:55 AM   #1
ljones0
Member
 
Registered: Dec 2007
Posts: 70

Rep: Reputation: 16
Slamd64 (64 Bit slackware) and ATI driver problems


Hello all !

I'm trying to install ATI's propietary drivers into my install of slamd64 (64-bit slackware) 12.2 but I'm having no joy at doing so. Here's my system spec;

* 4gb ram
* motherboard - asus m3a78em
* cpu - AMD Phenom II x4 940
* graphics - ATI radeon HD 3200 (onboard graphics)

Slamd64 version is 12.2 on a 2.6.27.7 kernel.

Unfortunatly every time I try to install *any* of ATI's drivers from here ( http://support.amd.com/us/gpudownload/Pages/index.aspx ) from the command line, the install fails. Attempting to use X afterwards results in a major system-lock up, no response from mouse nor keyboard only way out is reset button!

Right at the end of the installation of ATI's drivers I get some strange text on the screen, which looks a little like this :

Code:
n_US/LC_ADDRESS
        7f1e95a3d000-7f1e95a3000 r--p 0000000 08:01 40566
   /usr/lib64/locale/en_US/LC_TELEPHONE
                                      7f1e95a3000-7f1e95a3f000 r--p 000000
000 08:01 40570
5a3f000-7f1e95a40000 r---p 000000 08:01 40573              /usr/lib
64/locale/en_US/LC_IDENTIFICATION
                          7f1e95a40000-7f1e95a4200 rw-p 7f1e95a40000 00:00 /lib64/ld-2.7.so
The whole screen is filled with that sort of text, and all messed up too. At the bottom it says:

Code:
./at-installer.sh: line 39:  11447 Aborted                       ./setup.data/bin/${ARCH_DIR}/setup 2>/dev/null
                                             Removing temporary directory: fglrx-install.hxzQfq3
                               root@darkstar:~#
I can verify it isn't a corrupt download, as I've downloaded 9.2, 9.1 and 8-12 multiple times now and installed and I always get the same result - I get the same problem from 9.2, 9.1 and 8-12 drivers, even after a clean install each time. Does anyone know why this should happen and why the system locks up?

Is there a different way or any instructions on installing the ATI 9.2 for slamd64/12.2 ?

I can get X to give me a VESA based display if I use xorgconfig manually, but this won't work for 3D!

Also I found that xorgsetup dosen't work after installing the ati drivers.

ljones

Last edited by ljones0; 03-22-2009 at 11:19 AM.
 
Old 03-22-2009, 01:03 PM   #2
lumak
Member
 
Registered: Aug 2008
Location: Phoenix
Distribution: Arch
Posts: 799
Blog Entries: 32

Rep: Reputation: 109Reputation: 109
X11's default Radeon driver should be good enough for ATI.

Slamd64 is not officially Slackware and this particular subforum is for the Main Distrobution. Slamd64 does not have a forum at LQ and you should try to access Slamd64's main forum at http://forums.slamd64.com/.

Personally though, I've had trouble installing ATI drivers my self on linux in general... But mine was an unsupported laptop card made by gateway for one of their laptops.

I'm not sure exactly how to use the radeon driver offered by X11... BUT I believe if you search your /etc/X11/xorg.conf file you just have to find the section

Code:
Section "Device"
  Identifier "Some Value"
  Driver "vesa"
EndSection
and change vesa to radeon.


You may be able to find some useful information in this thread

http://www.linuxquestions.org/questi...in-x11-402003/

Good Luck.
 
Old 04-07-2009, 07:53 AM   #3
dcsmith300
LQ Newbie
 
Registered: Oct 2008
Location: San Antonio, TX
Distribution: Slackware
Posts: 15

Rep: Reputation: 3
I've had the exact same problem and the "radeon" driver that ships with the distro does not work either. I spent many hours trying to get the ati drivers to work and then got Pi$$ed and went out and bought an Nvidia card.
Problem solved.....
 
Old 04-07-2009, 10:03 AM   #4
kukibl
Member
 
Registered: Jun 2008
Distribution: Slackware64
Posts: 68

Rep: Reputation: 20
I don't use Slamd64, but I have the same graphic card on my laptop - Radeon 3200 HD.

Fglrx driver compiles and installs just fine, but it freezes my system everytime I log out or reboot/shutdown. The same is for "ati" and "radeon" Xorg drivers. I am not sure if it is available for Slamd64, but on Slackware 12.2 "radeonhd" driver works just fine for me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with the ATI driver from AMD (SLACKWARE 11) brevleq Linux - Hardware 3 05-25-2007 09:19 AM
LXer: ATI - 32 and 64-bit Linux driver - 8.28.8 LXer Syndicated Linux News 0 08-19-2006 02:54 PM
Problems installing Video and Audio Linux Driver ASUS P5GL-MX in Slamd64 mmarkvillanueva Slackware 5 03-18-2006 11:38 PM
Which 64-bit Linux is an alternative to Slamd64/Slackware? mmarkvillanueva Slackware 23 11-17-2005 05:03 PM
Ati driver a bit unstable but no different than nvidia..ati benchmark inside. spade Slackware 1 10-06-2004 12:13 AM


All times are GMT -5. The time now is 11:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration