-   Slackware (
-   -   Slamd64 (64 Bit slackware) and ATI driver problems (

ljones0 03-22-2009 10:55 AM

Slamd64 (64 Bit slackware) and ATI driver problems
Hello all :) !

I'm trying to install ATI's propietary drivers into my install of slamd64 (64-bit slackware) 12.2 but I'm having no joy at doing so. Here's my system spec;

* 4gb ram
* motherboard - asus m3a78em
* cpu - AMD Phenom II x4 940
* graphics - ATI radeon HD 3200 (onboard graphics)

Slamd64 version is 12.2 on a kernel.

Unfortunatly every time I try to install *any* of ATI's drivers from here ( ) from the command line, the install fails. Attempting to use X afterwards results in a major system-lock up, no response from mouse nor keyboard only way out is reset button!

Right at the end of the installation of ATI's drivers I get some strange text on the screen, which looks a little like this :


        7f1e95a3d000-7f1e95a3000 r--p 0000000 08:01 40566
                                      7f1e95a3000-7f1e95a3f000 r--p 000000
000 08:01 40570
5a3f000-7f1e95a40000 r---p 000000 08:01 40573              /usr/lib
                          7f1e95a40000-7f1e95a4200 rw-p 7f1e95a40000 00:00 /lib64/

The whole screen is filled with that sort of text, and all messed up too. At the bottom it says:


./ line 39:  11447 Aborted                      ./${ARCH_DIR}/setup 2>/dev/null
                                            Removing temporary directory: fglrx-install.hxzQfq3

I can verify it isn't a corrupt download, as I've downloaded 9.2, 9.1 and 8-12 multiple times now and installed and I always get the same result - I get the same problem from 9.2, 9.1 and 8-12 drivers, even after a clean install each time. Does anyone know why this should happen and why the system locks up?

Is there a different way or any instructions on installing the ATI 9.2 for slamd64/12.2 ?

I can get X to give me a VESA based display if I use xorgconfig manually, but this won't work for 3D!

Also I found that xorgsetup dosen't work after installing the ati drivers.


lumak 03-22-2009 01:03 PM

X11's default Radeon driver should be good enough for ATI.

Slamd64 is not officially Slackware and this particular subforum is for the Main Distrobution. Slamd64 does not have a forum at LQ and you should try to access Slamd64's main forum at

Personally though, I've had trouble installing ATI drivers my self on linux in general... But mine was an unsupported laptop card made by gateway for one of their laptops.

I'm not sure exactly how to use the radeon driver offered by X11... BUT I believe if you search your /etc/X11/xorg.conf file you just have to find the section


Section "Device"
  Identifier "Some Value"
  Driver "vesa"

and change vesa to radeon.

You may be able to find some useful information in this thread

Good Luck.

dcsmith300 04-07-2009 07:53 AM

I've had the exact same problem and the "radeon" driver that ships with the distro does not work either. I spent many hours trying to get the ati drivers to work and then got Pi$$ed and went out and bought an Nvidia card.
Problem solved.....

kukibl 04-07-2009 10:03 AM

I don't use Slamd64, but I have the same graphic card on my laptop - Radeon 3200 HD.

Fglrx driver compiles and installs just fine, but it freezes my system everytime I log out or reboot/shutdown. The same is for "ati" and "radeon" Xorg drivers. I am not sure if it is available for Slamd64, but on Slackware 12.2 "radeonhd" driver works just fine for me.

All times are GMT -5. The time now is 10:06 PM.