-   Slackware (
-   -   Slackware64, trying to compile wine with SBo (

suid0 05-24-2009 03:34 PM

Slackware64, trying to compile wine with SBo
Hello folks,

I'm trying to compile wine but I see an error message.
I tried first to change ARCH variable but didn't work. Any ideas?

checking build system type... x86_64-slackware-linux-gnu
checking host system type... x86_64-slackware-linux-gnu
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for cpp... cpp
checking whether gcc -m32 works... no
configure: error: Cannot build a 32-bit program, you need to install 32-bit development libraries.

It looks like wine uses 32bit libs. Is there any way to workaround this?


chess 05-24-2009 03:39 PM

As far as I know, WINE requires the 32 bit libraries. This has been discussed in several other threads. Slackware64-current is capable of using such 32 bit libraries, but currently it does not ship with them. Since Slackware64-current is still in development, that may or may not change. If not, the community will surely step up to provide an easy way to add them after the fact.

lumak 05-24-2009 03:51 PM

It may be possible to find a slamd64 you can explodpkg into a temp directory then this on the binaryfiles

objdump -x binaryfile | grep NEEDED
You could then find the slamd64 packages for the dependencies and build the 32 bit portions you are missing.... Sounds like a lot of work though...

samac 05-24-2009 04:49 PM

I had the same problem so I just used the package that I compiled on my Slackware 12.2 partition and installed it with the 32bit compatibility packages from slamd64 (aaa-elflibs, xlibs and gcc). It will work with just the first two but it is faster with the third.

I am going to try with BlueWhite64's packages tomorrow, though as BW64 uses a different directory structure I will have to do a bit of exploding, renaming and makepkg'ing.

The above test wasn't successful, but it could be something I did wrong.


Bruce Hill 05-27-2009 08:19 AM

I'm sure you've seen this thread, especially this post:

slackass 05-27-2009 09:23 AM

I tried "some" of the BW64 pkgs but none of the worked.

Many of these pkgs do tho:

So far:
All of Eric's pkgs have worked for me.

samac 05-27-2009 09:48 AM

This is solved, see this thread


All times are GMT -5. The time now is 12:32 AM.