-   Slackware (
-   -   Slackware64 Setup does not see gpt partitions created with parted on raid5 (

Alkisx 10-07-2009 09:18 AM

Slackware64 Setup does not see gpt partitions created with parted on raid5
Trying to install Slackware64

I have a 3 terrabytes raid 5 (hardware raid, 4 disks + 1 spare).

2.7 of them will be used as one partition for storage (/home).

cfdisk cannot create such a large partition, so I tried parted.I created all the partitions after doing mklabel gpt. All partitions created successfull. Also checked twice with the print command inside parted.

Running then setup, I get a message that there are no partitions for the setup to proceed. But there are.

Any help?

AigarsABCD 10-07-2009 12:34 PM

What exactly is the error message you receive in cfdisk?
Because 2.7 TB is not a "large" partition for it and there should not be any problems with that.
I have successfully created 8 TB partitions with cfdisk.
And I think the limit is only for filesystem itself (1 000 000 TB for ext4).

What does "fdisk -l" show?

EDIT: Sorry, did not see the "GPT" thing at first. Could anyone explain it also to me, what this GPT acctually is?
Once I tried to install Slackware on an Intel Macintosh and got an error message "cfdisk do not support GPT" or something like that. I used "cfdisk -z" and it worked - partitioned and installed fine.

Alkisx 10-07-2009 04:57 PM

Thank you for your reply,

I've seen by others that cfdisk does not support partitions over 2 TB.

I first did a cfdisk /dev/sda, created my partitions write table, and then exit.

After running again cfdisk on the raid, I saw that only the first partition (which was 50Gb) was there, and there was another one of about 500 gbytes. all the rest was just unpartitioned space.

deleted all and created again. Same thing though.

Then I decided to use parted. Without doing mklabel gpt on the raid, it could not create partitions over 2TB. But with gpt did it quite well.

Anyway since I had my partitions ready, I don't get it why slackware could not see the partitions.

GPT is the GUID Partition Table. It is a more flexible partitioning scheme than the old well known MBR. You can find more information by searching the web.

As of the cfdisk -z I don't know, I try it.

But does anyone know why slack could not see gpt partitions?

Alkisx 10-08-2009 03:44 AM

Anyone? I can't be the only one in this world having this problem

Alkisx 10-08-2009 06:15 AM

As I did some search, I found that the kernel that is booting on the slackware (huge.s) dvd does not support gpt, and that I have to reconfigure it by setting the


which is commented on the config file on the dvd's huge.s kernel

Is it possible to recreated the kernel image that way?
I don't know because in the past I used to recompile kernels but on an installed slackware. Since I am only booting from the dvd I don't know if is possible.

What I am thinking is:

recompile the huge.s with the above option set, and burning again a dvd with that kernel only changed and booting from it.

Can I recompile that kernel by booting only from dvd?

granth 10-08-2009 12:30 PM

What are your reasons for using GPT instead of MBR?


If you are booting a GPT partition, you will need to switch to Grub. Slack's default is Lilo.

I don't think you can compile a kernel from the bootable DVD. You will need to compile the replacement kernel on a Linux system with gcc installed. Replace the kernel in slackware64-13.0/kernels/huge.s/ and burn a new DVD. I've never done this, but it doesn't look that difficult. However, I hope you have a really good reason for using GPT before doing this. ;)

Alkisx 10-08-2009 02:34 PM

As I said before, the reason is that I want to create a partition bigger than 2GB.

With MBR this is not possible.

As I thought, the only solution is to recompile the huge.s in a system with slackware installed. This is what I will do.

Thank you all for your help:)

granth 10-08-2009 02:53 PM

If that is your only reason for using GPT, you should consider LVM instead.

I have a CentOS box which has a 2.4TB hardware Raid-5 partition. No problems there, and I'm sure it would work just fine in Slackware.


fdisk -l /dev/VolGroup01/LogVol00

Disk /dev/VolGroup01/LogVol00: 2663.9 GB, 2663919910912 bytes
255 heads, 63 sectors/track, 323869 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Disk /dev/VolGroup01/LogVol00 doesn't contain a valid partition table

After reading more about GPT, I think Slackware should include GPT/EFI support in the huge and generic kernels. I'm not a big fan of LVM, and considering the rate at which hard drives are growing in size, Slackware needs this feature.

granth 10-08-2009 03:51 PM

Another thought - Is it possible for you to install Slackware to a MBR-based partition and add a large /home partition later?

This would allow you to install with the regular DVD and easily compile a custom kernel with GPT/EFI enabled. Then you could create, format, and mount your (GPT) home partition.

Alkisx 10-13-2009 10:02 AM

I don't know if I can combine mbr+gpt in ONE device (/dev/sda).
I don't think it can be done.

Anyway, I decided to to make a smaller partition with 2tb, and the rest of it have it as backup as another partition.

After finished installation, I realized that MBR does not have limit of 2TB for a partition, but it has limit for a total of about 2.2Tb on all the partitions of one device.

So using MBR is not an option at all anymore for me.

You can see this thread

Which I started after (thinking) that I had installed successfull slackware on my server.

I said on the end That I tried to make a new dvd by replacing the huge.s kernel with a modified one including EFI for gpt, but with no success.

granth 10-13-2009 12:59 PM


I don't know if I can combine mbr+gpt in ONE device (/dev/sda).
I don't think it can be done.
You're probably right.

You could add two smaller disks (raid1 mirror), and use them as the root disk (MBR). Once Slackware is installed, you can rebuild your kernel, partition and format your GPT array, and then mount it. Of course, this probably isn't your ideal solution, as it would cost more money, and suck more power. However, keeping OS and DATA on different arrays isn't a bad thing to do... :) It may be your only option.

All times are GMT -5. The time now is 03:20 PM.