-   Slackware (
-   -   Slackware64 Issue with Nouveau and Framebuffer (

jkirchner 10-24-2012 05:31 PM

Slackware64 Issue with Nouveau and Framebuffer
I just installed Slackware64 on my desktop. I tried for the first boot and it stops at:

fb: conflicting fb hw usage nouveau fb vs vesa

I have tried rebooting and am trying to just get this booted but I cannot seem to get it right at the Lilo prompt. I try hitting <tab> and then I tried enter Slackware append nomodeset and other tries. They do not work. I am stuck.

I do have the nVidia blob downloaded and know I need to do that, just cannot figure out how to get Slack to boot and get past the message above.

I appreciate the tips :) I had no issues with 13.37....

Didier Spaier 10-24-2012 05:35 PM

Try to append "vga=normal" (without the quotes) to lilo's command line then if it works edit lilo.conf accordingly.

"momdeset" disable KMS (kernel mode setting) but do not prevent the vesa frame buffer driver to be loaded.

jkirchner 10-24-2012 05:36 PM

Thanks, will go try now. Thanks Didier.

[EDIT]Nope, did not work, it booted to loading the devtemp fs and just stopped. I still think it is graphics holding it back, just not sure. My laptop with ATI installed and was up in less than 40 minutes, updates and all :)

[EDIT 2] Yes, it worked. Silly me. I entered vga=normal nomodeset and all booted. Blacklisted Nouveau using /extra and then installed nVidia and all is well again in my Slack-world. whew...

Thanks for the help again, Didier. I have added more notes to my journal of Slackware knowledge.

All times are GMT -5. The time now is 04:57 PM.