-   Slackware (
-   -   Slackware64 -current, SlackBuild's gksu problems run-helper... (

linus72 07-14-2010 04:08 PM

Slackware64 -current, SlackBuild's gksu problems run-helper...
error message

"failed to run * as user root, the gksu-run-helper program is not found or is not executable"
Tried googling and checking threads at LQ
didnt find a solution or another instance running slackware64 current..

everything built fine, tried and everythings executable...

I also have Alien's multilib installed, with only firefox and flashplugin as 32bit, everything else 64bit.

I can't open any apps as root by normal user

Any ideas?

samac 07-15-2010 05:09 AM

Is your user a member of the group "wheel"?


linus72 07-15-2010 06:12 AM

hello samac
thanks for answering

yes, user is member of wheel group

user is member of these groups

main group users

heres sudoers which may be wrong, though no errors doing visudo
the sudoers is a experiment so its messy...


# sudoers file.
# This file MUST be edited with the 'visudo' command as root.
# See the sudoers man page for the details on how to write a sudoers file.

# Host alias specification

# User alias specification

# Cmnd alias specification

# Defaults specification

# Runas alias specification

# User privilege specification
root        ALL=(ALL) ALL

# Uncomment to allow people in group wheel to run all commands
# %wheel        ALL=(ALL)        ALL

# Same thing without a password
 %wheel        ALL=(ALL)        NOPASSWD: ALL

# Samples
 %users  ALL=/sbin/mount /cdrom,/sbin/umount /cdrom
 %users  localhost=/sbin/shutdown -h now

guest    ALL=(ALL) ALL
guest ALL=NOPASSWD: /usr/bin/Terminal
guest ALL=NOPASSWD: /usr/bin/pcmanfm
guest ALL=NOPASSWD: /usr/bin/sudo, /usr/bin/hag-exit-fluxbox, /sbin/shutdown -r now, /sbin/shutdown -h now, /usr/sbin/create-slxsave-xfs-gui, /usr/bin/killall, /usr/bin/Terminal, /usr/bin/pcmanfm

also, entering "gksu" in term as user gives no error and works fine
but any command like "gksu lxterminal"
results in the error...

Keith Hedger 07-15-2010 07:53 AM

Gksu has been radically changed and now uses a different system to escalate privileges and has changed the way way it reads its arguments and ( in my opinion ) doesn't work at all except for very simple arguments ie "gksu gedit" works fine but "gksu gedit --new-window" causes gksu to fall over it is now all but useless ( you now also have to give the ROOT password rather than your admin password like before )

linus72 07-15-2010 07:57 AM

hello Keith Hedger
I got around some of gksu's problems in all my slackware/arch installs by porting debians
"su-to-root" script to slackware/arch
the command being instead of "gksu /usr/bin/pcmanfm"
to "su-to-root -X -c /usr/bin/pcmanfm"
and you gotta have a .su-to-rootrc in users home
which just says

However, none of it works on the 64bit slack....

Keith Hedger 07-15-2010 08:24 AM

Actually I have now changed my scripts to use zenity to ask for a password and use sudo -S ie:


TEST=$(echo XXX|sudo -S ls 2> /dev/null)
if [ "X$TEST" = "X" ];then
        PASS=$(zenity --entry --hide-text --text="Please enter your admin password" --title="Authorization")
echo $PASS|sudo -S gnome-terminal -x vim "$1"

which opens a selected file in vim as root in a new gnome terminal
( the test part is just to see if i need to pop up a dialog to ask for the password )

All times are GMT -5. The time now is 01:05 AM.