-   Slackware (
-   -   slackware64-current mesa changes Sep 25 (radeon-dpm working!) (

lanir 09-25-2013 10:01 AM

slackware64-current mesa changes Sep 25 (radeon-dpm working!)

Just wanted to comment somewhere that the update recompiling mesa with "--enable-osmesa" made my day. The open source radeon driver now works when booting with "radeon.dpm=1" on 3.11 and 3.12 kernels. Anyone else reading this and wanting to try it please check the article below for instructions, as it requires downloading a compatible firmware.

TobiSGD 09-25-2013 10:06 AM

radeon.dpm=1 is working for me quite some time with the 3.11 kernels, I am curios to know, what did not work for you?
Regarding the firmware, with the September 13 update of kernel-firmware-20130912git-noarch-1.txz the needed firmware is already available on -current systems.

lanir 09-25-2013 11:23 AM

The behavior I had been seeing was X would start, I'd get a black background (not what I had it set to), the mouse pointer would appear and be movable for a couple seconds and then it would lock up. No X11 log. Just locked.

I booted this morning using 3.12-rc2 (newly compiled so that's another possible change but everything up to 3.12-rc1 hadn't worked). I'll try a few boot cycles this evening and make sure it's not an intermittent thing.

lanir 09-26-2013 01:20 AM

Okay... Apparently that wasn't right. It booted that once and worked then went back to locking up. If I run X manually I can can move the pointer around however I want with a bare X11 but the moment I open a window it locks up. I think I may just have hardware issues. At least I assume that radeon-dpm is supposed to work with an AMD A10-4600M and 7730M discrete graphics.

lanir 10-16-2013 07:52 PM

Things appear to be working now after several reboots. No graphical issues. The last change and what I think actually did it was going for an EFI boot setup. This also had the effect of making the fglrx catalyst driver display a higher res terminal, which gave me the general clue that it was time to retry radeon.dpm and see if I could make it work. It did.

All times are GMT -5. The time now is 03:18 PM.