-   Slackware (
-   -   Slackware64 -current KJots not responding (

rkfb 08-23-2012 03:36 PM

Slackware64 -current KJots not responding
I've had an issue with KJots not responding at all in a Slackware64 -current installation (from an iso dated 21.08.2012).

I click 'New Book' in KJots and nothing happens. There are no books listed at all on opening and I can't seem to create one. This happens from within Kontact as well as opening KJots as a standalone.

Googling led me to a bug listed here

See the last post by Rod J.

Basically you need to open 'Akonadi Configuration' (this is in System Settings > Personal Information or type Akonadi in to the KDE Menu search box) click on 'Local Notes' and 'Modify' and you will see there is an extra '/' between share and notes. Delete this down to just one OK it and then restart Kontact or KJots and all should be well - you don't have to reboot the system, I'm sure he doesn't mean that anyway.

You should now have full functionality with 'Local Notes' and 'Notes' already listed as books.

Z038 05-23-2013 09:00 AM

I realize your post is 9 months old, Robert, but I want to thank you for it. It solved the kjots problem I encountered upon upgrading from 13.37 to 14.0.

The Kjots notes repository storage method and location changed with the new version of KDE that shipped in 14.0. When I first opened Kjots after the upgrade, all my notes were missing. By searching the web, I found suggestions to open a terminal, navigate to ~./kde/share/apps/kjots and run kjotsmigrator --interactive to convert the old style kjots books to the new local notes style. But it hung without ever completing each time I tried it. It also created a new "local notes" entry in the Akonadi configuration menu each time I ran kjotsmigrator, although I didn't realize it at first. Then I found your post and found all the 'local notes' entries in the Akonadi config menu. Each one had the double slash in the path.

I removed the extra / from the last 'local notes' entry, deleted all the redundant 'local notes' entries, then ran 'kjotsmigrator --interactive', and it completed successfully.

Thanks again for your useful post.

rkfb 06-27-2014 02:34 PM

Thanks for your kind words, it's nice to know my post helped, as I have been myself so many times by this community.

...sorry to the mods here, 13 months to reply.

All times are GMT -5. The time now is 08:45 AM.