-   Slackware (
-   -   Slackware64-current, KDE4.2.3: Pipe key not working in Konsole (

gargamel 05-22-2009 03:36 AM

Slackware64-current, KDE4.2.3: Pipe key not working in Konsole
Hi all,

I have managed to upgrade from Slackware 12.2 (32-bit) to Slackware64-current. Almost everything is fine, and KDE 4 is soooo nice, apart from one little snag: The pipe key (the key with which one types |) is not working everywhere.

I have a German Logitech Wave keyboard, which is compatible with Microsoft Natural keyboards. Selecting the corresponding driver during setup and in KDE, plus activation keyboard layouts in KDE, it works just fine almost everywhere, just not in Konsole and Xterm.

I can type | in a virtual terminal on the command line, and almost everywhere in KDE. I can even type the character in the setup dialog of Konsole. And apart from this, all international keys () seem to work and are to be found where I expect them.

Not sure, if it's a bug, or a misconfiguration. And if it's a bug, I don't know, if it is a KDE or a Slackware64-current issue. So I am asking first here, before bothering any busy developers.

What could I look for? Or where should I report/post this?



EDIT: Just noticed, that Tilde ~ is also not functional. As you can see, it works in Konqueror, however. ;)
EDIT: Correction, Tilde ~ does work, just have to type it twice, while keeping the ALT-GR key pressed down.

samac 05-22-2009 03:49 AM

The pipe key is working here in Konsole with a UK keyboard layout.


gargamel 05-22-2009 04:05 AM

Tried en_GB keyboard layout in KDE, and had above 3, and --- ta taah --- pipe, type as left-shift plus \ (the two keys far down on the bottom left corner of the keyboard; not sure, if that is where they are supposed to be, though...).

Back to German keyboard layout, no success again, in Konsole (everwhere else it works).

Any ideas, what the cause of this might be?


gargamel 05-22-2009 04:18 AM

Weird: Even in the test input/output fields of the Konsole setup, where one can switch between Linux/Solaris/Xfree4, the behaviour is correct. I type | into the input field and get | as output. What the hack is preventing Konsole from behaving just this way, when not in testing mode? This is getting mysterious...


gargamel 05-22-2009 06:21 AM

When I start KDE from the CLI as root, I get | in Konsole as expected.
Starting KDE as a normal user, it doesn't work.

I have also meanwhile de-/re-installed kdebase (containing Konsole), and deleted several hidden directories with configuration data for my desktop user, but up to now nothing helped.

I guess, when root can get | and normal user cannot, it has something to do with privileges. But what?

And, BTW: su root doesn't help. Only when I start KDE as root I get | from the usual key combination.


gargamel 05-22-2009 07:11 AM


First I created a new user. Logging in with the new account and starting KDE from the CLI I found, my keyboard was perfectly working, even without having to active "Keyboard Layout" in KDE (I guess the Slackware installer and the NVIDIA graphics driver did a real good job, here, creating my /etc/xorg.conf without any need for manual modification). Now, as it worked for a new user, I wanted to become such a new user. ;)

I deleted or renamed all hidden directories, deleted the user account, re-created it and made the new user the owner of the old /home/user directory. Guess what? It works now...

I still don't know what was actually wrong, though...

Seems it was one of these cases...


All times are GMT -5. The time now is 10:45 AM.