-   Slackware (
-   -   Slackware64-current : can't have lilo updating the boot loader after kernel upgrade (

Didier Spaier 07-21-2009 05:32 AM

[SOLVED] Slackware64-current: lilo not updating the boot loader after kernel upgrade
Hi everybody,

I am running slackware64-current on a Lenovo Thinkpad T61 (model 6457-4xg to be accurate), with a customized kernel.

My disk layout is as follows:


Disque /dev/sda: 160.0 Go, 160041885696 octets
255 têtes, 63 secteurs/piste, 19457 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Identifiant de disque : 0x43c69dc0

Périphérique Amorce  Début        Fin      Blocs    Id  Système
/dev/sda1              1        850    6821888  27  Inconnu
La partition 1 ne se termine pas sur une frontière de
/dev/sda2            850        3492    21224688    7  HPFS/NTFS
/dev/sda3            3492      19457  128240280    5  Etendue
/dev/sda5  *        3492        5536    16412728+  83  Linux
/dev/sda6            5536        5925    3129808+  82  Linux swap
/dev/sda7            5925      19457  108697648+  83  Linux

Please note that I made /dev/sda5 bootable and installed the bootloader on it to keep the MBR as shipped.

So far, so good, I have a dual boot Windows / Linux.

But now this is what happens when I run lilo to install the a kernel

bash-3.1# lilo -b /dev/sda5 -M /dev/sda ext  -v
LILO version 22.8, Copyright (C) 1992-1998 Werner Almesberger
Development beyond version 21 Copyright (C) 1999-2006 John Coffman
Released 19-Feb-2007 and compiled at 12:48:48 on Feb 27 2009.

/boot/boot.0800 exists - no /dev/sda backup copy made.
The Master Boot Record of  /dev/sda  has been updated.

Please note that no image are included and in fact when I reboot I still get the old kernel.

Here is my lilo.conf:

lba32 # Allow booting past 1024th cylinder with a recent BIOS
append=" vt.default_utf8=1"
boot = /dev/root
bitmap = /boot/slack.bmp
bmp-colors = 255,0,255,0,255,0
bmp-table = 60,6,1,16
bmp-timer = 65,27,0,255
timeout = 1200
vga = 773
other = /dev/sda2
label = Windows
table = /dev/sda
image = /boot/vmlinuz-
root = /dev/root
label = Linux-

I should be wrong but where ???

Any help appreciated

Alien Bob 07-21-2009 05:55 AM

What happens if you change the two "/dev/root" instances to "/dev/sda5" ? You should not use /dev/root in lilo.conf anyway.


niels.horn 07-21-2009 05:59 AM

The '-M' option of lilo you are using tells it to overwrite the mbr (/dev/sda).
I don't think setting the 'bootable' flag makes any difference (my drive has no bootable flag set at all)

Didier Spaier 07-21-2009 08:00 AM

Eric, thanks for the advice -- lilo seems able to follow the symlink /dev/root though (liloconfig wrote it too)

Nils, thanks for the reminder.

I ended up being successful with following command:
lilo -b /dev/sda5 -P ignore

lilo still complain about inconsistency in the partition table but it works:

bash-3.1# uname -a
Linux darkstar #1 SMP PREEMPT Tue Jul 21 00:13:41 CEST 2009 x86_64 Intel(R) Core(TM)2 Duo CPU    T7500  @ 2.20GHz GenuineIntel GNU/Linux

I guess I should have RTFM a little better :scratch:

All times are GMT -5. The time now is 03:26 PM.