-   Slackware (
-   -   Slackware64 -current and KDE (

mlangdn 05-29-2009 07:27 AM

Slackware64 -current and KDE
I've been using Slackware64 -current for a few days now as my main production machine. Its fast and stable and has given me no known problems as of yet. I have a couple of annoyances though, which just may be my own fault.

I can't find File Manager Superuser - is it gone?

The next thing is that in System Settings, there is no box to start Administrator Mode. I could always start a KDE session as root, but I don't want to do that.

I usually change the default run level to four, and set up my self to login automatically. I do this so that my wife does not have to login and startx to use the computer. It usually runs all the time, but sometimes a power failure or storm comes along that requires a re-boot or shutdown. My wife just wants it to start and run. :)

The K kicker has no Run option, but Alt + F2 works.

I realize the Slackware Team has nothing to do with KDE itself - I'm just wondering if I'm looking in the wrong places.

ponce 05-29-2009 07:37 AM

opening a filemanager as the root user is never recommended, but...
from a terminal

kdesu dolphin
you can create a launcher for that ;)

you still have to enter the root password, but I think it's the same in the previous kde administrator mode.

slackass 05-29-2009 07:51 AM

You can also do:
kdesu konqueror

settings>show navigation panel

mlangdn 05-29-2009 07:59 AM

That worked, except that Dolphin was incredibly slow in starting. And, I had forgotten about kdesu. So I tried kdesu kate, and it popped right up. I can edit system files with kate. Now to find out how to get into Admin mode from a normal user to change the login behavior.

pwc101 05-29-2009 08:06 AM


Originally Posted by mlangdn (Post 3556477)
Now to find out how to get into Admin mode from a normal user to change the login behavior.

kdesu kcontrol?

mlangdn 05-29-2009 08:41 AM

kcontrol not found.

pwc101 05-29-2009 08:45 AM

My bad; that's for KDE3. KDE4 apparently uses systemsettings. Try:

kdesu systemsettings

mlangdn 05-29-2009 08:57 AM

That worked!

All times are GMT -5. The time now is 06:52 PM.