LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-20-2016, 11:25 PM   #1
gordydawg
Member
 
Registered: Sep 2013
Distribution: slackware
Posts: 41

Rep: Reputation: Disabled
Slackware64-current 5/20/2016 - Syslinux booting and ext4 formatting


Just saw the 5/20/2016 updates to -64Current, I updated a local tree and burned a disk and tried a fresh install similar to prior installs on another machine using gpt style partioning and syslinux as the boot loader of choice (I like to start fresh on testing).

Two things came up, formating partitions in ext4 in normal (without block checking) took way longer than expected. And Syslinux did not boot up properly but gave this error message. Syslinux is currently at version 4.02 (whoops, it's 4.06)

Error: No configuration file found
boot:
NO DEFAULT or UI configuration directive found!

Like I never installed the config file. I checked and confirmed that sgdisk was ran after paritioning,ran extlinux to install it in the /boot/extlinux directory and before setup to get a gptmbr.bin installed in the proper /dev/sdx

Along with getting the boot syntax correct in /boot/extlinux/extlinux.conf file.

Unless I bogged my disk, I'm wondering if others have run into this.

Last edited by gordydawg; 05-21-2016 at 01:24 AM.
 
Old 05-21-2016, 12:47 AM   #2
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 8,996

Rep: Reputation: Disabled
Why Syslinux 4.0.2? This is obsolete and Slackware ships Syslinux 4.0.6 (and could safely be upgraded to 4.0.7 IMHO). The behavior you see *could* be due to a bug fixed long ago (4.0.2 is almost 6 years old).

Last edited by Didier Spaier; 05-21-2016 at 12:51 AM.
 
Old 05-21-2016, 01:25 AM   #3
gordydawg
Member
 
Registered: Sep 2013
Distribution: slackware
Posts: 41

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Didier Spaier View Post
Why Syslinux 4.0.2? This is obsolete and Slackware ships Syslinux 4.0.6 (and could safely be upgraded to 4.0.7 IMHO). The behavior you see *could* be due to a bug fixed long ago (4.0.2 is almost 6 years old).
Whoops, I mistyped the version number. Syslinux version in the error message is 4.0.6.
 
Old 05-21-2016, 06:08 AM   #4
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 8,996

Rep: Reputation: Disabled
I would run an e2fsck.

Last edited by Didier Spaier; 05-21-2016 at 06:09 AM.
 
Old 05-21-2016, 07:16 AM   #5
kjhambrick
Senior Member
 
Registered: Jul 2005
Location: Round Rock, TX
Distribution: Slackware64 14.2 + Multilib
Posts: 1,483

Rep: Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918
Hmmm ... Last night's update included e2fsprogs-1.43-x86_64-1.txz

Maybe a hint there ?

There was a .conf.new file:

Code:
# grep '\.new$' /var/log/packages/e2fsprogs-1.43-x86_64-1

etc/mke2fs.conf.new
Programs updated were:

Code:
# grep 'bin/' /var/log/packages/e2fsprogs-1.43-x86_64-1

sbin/
sbin/badblocks
sbin/debugfs
sbin/dumpe2fs
sbin/e2freefrag
sbin/e2fsck
sbin/e2image
sbin/e2undo
sbin/e4crypt
sbin/e4defrag
sbin/filefrag
sbin/fsck-e2fsprogs
sbin/fsck.ext2
sbin/fsck.ext3
sbin/fsck.ext4
sbin/fsck.ext4dev
sbin/fuse2fs
sbin/logsave
sbin/mke2fs
sbin/mklost+found
sbin/resize2fs
sbin/tune2fs
usr/bin/
usr/bin/chattr
usr/bin/compile_et
usr/bin/lsattr
usr/bin/mk_cmds
 
1 members found this post helpful.
Old 05-21-2016, 08:55 AM   #6
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 559

Rep: Reputation: 154Reputation: 154
Quote:
Originally Posted by kjhambrick View Post
Hmmm ... Last night's update included e2fsprogs-1.43-x86_64-1.txz

There was a .conf.new file:

Code:
# grep '\.new$' /var/log/packages/e2fsprogs-1.43-x86_64-1

etc/mke2fs.conf.new
To support that: diff shows only changes for ext4
Code:
--- mke2fs.conf 2015-10-23 21:39:46.000000000 +0100
+++ mke2fs.conf.new     2016-05-20 17:56:57.000000000 +0100
@@ -11,12 +11,11 @@
                features = has_journal
        }
        ext4 = {
-               features = has_journal,extent,huge_file,flex_bg,uninit_bg,dir_nlink,extra_isize
-               auto_64-bit_support = 1
+               features = has_journal,extent,huge_file,flex_bg,64bit,dir_nlink,extra_isize
                inode_size = 256
        }
        ext4dev = {
-               features = has_journal,extent,huge_file,flex_bg,uninit_bg,dir_nlink,extra_isize
+               features = has_journal,extent,huge_file,flex_bg,inline_data,64bit,dir_nlink,extra_isize
                inode_size = 256
                options = test_fs=1
        }
 
1 members found this post helpful.
Old 05-21-2016, 10:38 AM   #7
gordydawg
Member
 
Registered: Sep 2013
Distribution: slackware
Posts: 41

Original Poster
Rep: Reputation: Disabled
Sorry for the delay.

I tried e2fsck on that HD and got Bad magic number in Superblock

I even did a disk wipe and tried a reinstall of the new 64bit current (05/20/2016) with MBR partioning this time around, same e2fsck result.

HD drive disk or did the new e2fsprogs with it's larger inode_size cause problems?


I realize it's likely my HD, but I vaguely recall something like this would crop up for FreeBSD users attempting to read ext2 formatted drives as the newer versions of ext2 used larger inode sizes. For that, you simply reformatted with a -I option (inode size) set to 128. And all was well for that case.
 
1 members found this post helpful.
Old 05-21-2016, 10:47 AM   #8
DarkVision
Member
 
Registered: Jul 2007
Posts: 189

Rep: Reputation: Disabled
Quote:
Originally Posted by brobr View Post
To support that: diff shows only changes for ext4
Exactly these changes do break install of grub in -current because of ext4 is now using 64bit by default. Old version of grub cannot handle that. Maybe there is a similar issue with Syslinux?

I just did a reinstall of -current but before running setup to start the install i removed the 64bit option from mke2fs.conf:
Code:
sed -i "s:,64bit::g" /etc/mke2fs.conf
This way setup will format the ext4 partitions without 64bit like the previous version of e2fsprogs did. This fixed my issues with the old version of grub shipped with slackware-current.

Maybe you can try to install slackware with this "hack" just to see if syslinux then works?

P.S.Found this old post where the 64bit option on ext4 filesystems seem to be a problem for syslinux. Since syslinux 4.0.7 is much older then this post i think syslinux might also be affected by the upgrade of e2fsprogs.

Last edited by DarkVision; 05-21-2016 at 11:48 AM.
 
2 members found this post helpful.
Old 05-21-2016, 12:14 PM   #9
gordydawg
Member
 
Registered: Sep 2013
Distribution: slackware
Posts: 41

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by DarkVision View Post
Exactly these changes do break install of grub in -current because of ext4 is now using 64bit by default. Old version of grub cannot handle that. Maybe there is a similar issue with Syslinux?

I just did a reinstall of -current but before running setup to start the install i removed the 64bit option from mke2fs.conf:
Code:
sed -i "s:,64bit::g" /etc/mke2fs.conf
This way setup will format the ext4 partitions without 64bit like the previous version of e2fsprogs did. This fixed my issues with the old version of grub shipped with slackware-current.

Maybe you can try to install slackware with this "hack" just to see if syslinux then works?

P.S.Found this old post where the 64bit option on ext4 filesystems seem to be a problem for syslinux. Since syslinux 4.0.7 is much older then this post i think syslinux might also be affected by the upgrade of e2fsprogs.
Pushing the sed hack into mke2fs.conf before running setup in -64Current worked! Syslinux runs like it should. Thank you Darkvision.

It appears the new 64bit option in e2fsprogs broke those boot loaders looking for either smaller inode sizes or stored as 32 bit blocks.


Interestingly, when lilo chain loading from another disk into a disk with -64current installed with MBR partitioning (and lilo installed in root), I had to do the same sed hack during installation for it to boot up properly.

Last edited by gordydawg; 05-21-2016 at 12:24 PM.
 
1 members found this post helpful.
Old 05-21-2016, 12:27 PM   #10
DarkVision
Member
 
Registered: Jul 2007
Posts: 189

Rep: Reputation: Disabled
Quote:
Originally Posted by gordydawg View Post
Pushing the sed hack into mke2fs.conf before running setup in -64Current worked! Syslinux runs like it should. Thank you Darkvision.

It appears the new 64bit option in e2fsprogs broke those boot loaders looking for either smaller inode sizes or stored as 32 bit blocks.
Yes, maybe it is an option to revert the 64bit options/changes from mke2fs.conf in -current. If not needed the ext4 filesystem will then created with 32bit and if the filesystem is >16TB mke2fs will automatically enable 64bit. If someone want 64bit even on smaller partitions he can use the -O 64bit switch for mke2fs.

Quote:
default_features
This relation specifies set of features which should be
enabled or disabled after applying the features listed in the
base_features and features relations. It may be overridden by
the -O command-line option to mke2fs(8).

auto_64-bit_support
This relation is a boolean which specifies whether mke2fs(8)
should automatically add the 64bit feature if the number of
blocks for the file system requires this feature to be
enabled. The resize_inode feature is also automatically
disabled since it doesn't support 64-bit block numbers.

Last edited by DarkVision; 05-21-2016 at 12:30 PM.
 
3 members found this post helpful.
Old 05-25-2016, 07:41 AM   #11
gordydawg
Member
 
Registered: Sep 2013
Distribution: slackware
Posts: 41

Original Poster
Rep: Reputation: Disabled
Latest Slack64-current 5/25/2016 changelog

a/e2fsprogs-1.43-x86_64-2.txz: Rebuilt.
Do not use 64-bit by default on ext4, since some bootloaders cannot handle
it yet. But use "auto_64-bit_support = 1", which will enable 64-bit if the
number of blocks for the file system requires the feature to be enabled.

Marking thread solved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
formatting xp to ext4 pjsr Linux - Newbie 4 10-05-2015 01:52 PM
wrong fs type after formatting ext4 to fat32 imayneed Linux - Newbie 5 08-24-2012 11:36 AM
Formatting external drives in ext4 Cultist Linux - Hardware 1 12-19-2010 07:51 PM
Convert ext4 FS to ext3 without formatting HDD n03x3c Linux - General 3 12-04-2009 05:47 AM
Formatting drive to ext4 simonb1975uk Slackware 2 01-08-2009 11:10 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration