-   Slackware (
-   -   Slackware64 14 gcc compile error (

tuxbg 11-22-2012 10:55 AM

Slackware64 14 gcc compile error
1 Attachment(s)
Ok ive got this error when i try to compile gcc.Where is the problem
Error is on attachment

Didier Spaier 11-22-2012 11:14 AM

Please give us a bit of context, as:
did you do try to compile it manually (then which command exactly did you type, from where, as root or regular user?)
or did you re-use a Slackware's SlackBuild?
which version are you trying to compile?

tuxbg 11-22-2012 11:15 AM

I use this
simply sh gcc.Slackbuild

knudfl 11-22-2012 11:29 AM

# 3 . GCC 4.7.1 :

Please use the Slackbuild, including patches, etc.

But why build 4.7.1 ? It's included : slackware/d/gcc*


tuxbg 11-22-2012 11:35 AM

I'll try and report back

tuxbg 11-22-2012 11:40 AM

Is there any way to make 'make check' on Slackbuilds to find missing packages ?

Didier Spaier 11-22-2012 11:44 AM

No need for that. Provided you made a full install, you don't miss anything.

tuxbg 11-22-2012 11:51 AM

I have a minimal installation of Slackware and when it start to build gcc i noticed that i miss a texinfo package :)

tuxbg 11-22-2012 12:03 PM

1 Attachment(s)
The same old situation that is the new error

Didier Spaier 11-22-2012 12:19 PM


Originally Posted by tuxbg (Post 4834937)
I have a minimal installation of Slackware and when it start to build gcc i noticed that i miss a texinfo package :)

So make a full install, not a minimal one, especially if you want to compile something.

Plus, where does gcc-51e51ef2ffb509e999889519876a0198 come from ? did you pull it from git? If yes, do not expect the Slackbuild shipped with Slackware to work "out of the box".

tuxbg 11-22-2012 12:44 PM

This is from gcc.Slackbuild > TMP=${TMP:-"/gcc-$(mcookie)"}
Is a chroot env a option ?

tuxbg 11-22-2012 01:18 PM

With a chroot env i've got a same error

knudfl 11-22-2012 02:23 PM

Why do you want to recompile gcc ? ?

This is a lot easier : # installpkg gcc-4.7.1-<arch>-1.txz gcc-g++-4.7.1-<arch>-1.txz

.. Then you will also find out what else is missing. ( gmp etc.).


Didier Spaier 11-22-2012 02:24 PM

Are you running the SlackBuild script as root?

Also, out of curiosity, why do you want to compile gcc, which is included in Slackware as knudfi already pointed out?

EDIT Too late, again...

tuxbg 11-22-2012 02:49 PM

Yes i run the script as root.
I wont to compile gcc just for the test i dont know exactly why:)

All times are GMT -5. The time now is 12:47 AM.