LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-18-2017, 06:23 AM   #1
inukaze
Member
 
Registered: Feb 2011
Location: Venezuela - Caracas
Distribution: Slackware64 14.2, Slackware 14.2, Gentoo, Devuan, gNewSense, GoboLinux, Leeenux, Porteus
Posts: 135

Rep: Reputation: 10
Question Slackware64 14.2 : vlc right now don't load


Hi there group, yesterday i had upgrade my packages system from slkpkg, but right now, vlc, don't load.

Code:
$ vlc
VLC media player 3.0.0-git Vetinari (revision 2.2.0-git-12716-gbec643e)
[00000000017ad168] core libvlc: Ejecutar vlc con la interfaz predeterminada. Use cvlc para usar vlc sin interfaz.
This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.
i try to reinstall some packages :
Code:
slpkg -s slonly --deps --reinstall vlc #don't work
slpkg -s slack --reinstall libxcb # don't work yet
slpkg -s slonly --reinstall libxkbcommon libinput # still don't work yet
 
Old 07-18-2017, 06:55 AM   #2
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 9,431

Rep: Reputation: Disabled
Get a bundle of vlc + deps from Eric Hameleers:
http://slackware.uk/people/alien/slackbuilds/vlc/
see also:
http://slackware.uk/people/alien/sla...D_PACKAGES.TXT

Last edited by Didier Spaier; 07-18-2017 at 07:00 AM.
 
Old 07-18-2017, 07:37 AM   #3
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 8,083

Rep: Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881Reputation: 6881
Try installing libwacom as well. The libinput may depend on it. I do not know where you are getting the packages but at least my own libinput package for Slackware64 14.2 requires libwacom.
 
Old 07-18-2017, 11:16 PM   #4
inukaze
Member
 
Registered: Feb 2011
Location: Venezuela - Caracas
Distribution: Slackware64 14.2, Slackware 14.2, Gentoo, Devuan, gNewSense, GoboLinux, Leeenux, Porteus
Posts: 135

Original Poster
Rep: Reputation: 10
Thumbs up Thank you

Quote:
Originally Posted by Alien Bob View Post
Try installing libwacom as well. The libinput may depend on it. I do not know where you are getting the packages but at least my own libinput package for Slackware64 14.2 requires libwacom.
i just installed libwacom and now VLC is working again

Code:
[ inukaze | 18-07-2017 | 12:13 am ]
[~]$ su -c "slpkg -s slonly libwacom" root
Contrasea: 
Reading package lists... Done
Resolving dependencies... Done

The following packages will be automatically installed or upgraded 
with new version:

+==============================================================================
| Package                 New Version        Arch    Build  Repos          Size
+==============================================================================
Installing:
  libwacom                0.25               x86_64  1      slonly         52 K

Installing summary
===============================================================================
Total 1 package.
1 package will be installed, 0 will be upgraded and 0 will be reinstalled.
Need to get 52 Kb of archives.
After this process, 590 Kb of additional disk space will be used.

Would you like to continue [y/N]? y

[1/1][ Download ] --> libwacom-0.25-x86_64-1_slonly.txz

--2017-07-19 00:14:06--  https://slackonly.com/pub/packages/14.2-x86_64/libraries/libwacom/libwacom-0.25-x86_64-1_slonly.txz
Resolviendo slackonly.com (slackonly.com)... 45.58.49.216, 2602:ffc5::ffc6:f752
Conectando con slackonly.com (slackonly.com)[45.58.49.216]:443... conectado.
Peticin HTTP enviada, esperando respuesta... 200 OK
Longitud: 50632 (49K)
Grabando a: /tmp/slpkg/packages/libwacom-0.25-x86_64-1_slonly.txz

libwacom-0.25-x86_64-1_slon 100%[=========================================>]  49,45K   140KB/s    in 0,4s    

2017-07-19 00:14:08 (140 KB/s) - /tmp/slpkg/packages/libwacom-0.25-x86_64-1_slonly.txz guardado [50632/50632]


+==============================================================================
| MD5SUM check for libwacom-0.25-x86_64-1_slonly.txz [ PASSED ]
+==============================================================================

[ installing ] --> libwacom-0.25-x86_64-1_slonly.txz

+==============================================================================
| Installing new package /tmp/slpkg/packages/libwacom-0.25-x86_64-1_slonly.txz
+==============================================================================

Verifying package libwacom-0.25-x86_64-1_slonly.txz.
Installing package libwacom-0.25-x86_64-1_slonly.txz:
PACKAGE DESCRIPTION:
# libwacom (Library to identify Wacom tablets and their features)
#
# Manages the libraries, configuration, and diagnostic tools for  Wacom
# tablets running under Linux. It also maintains updated  Linux  kernel
# drivers and Xorg/XFree86 XInput drivers.
#
# Home Page: https://sourceforge.net/projects/linuxwacom/
#
Executing install script for libwacom-0.25-x86_64-1_slonly.txz.
Package libwacom-0.25-x86_64-1_slonly.txz installed.


Completed!

+==============================================================================
| Total 1 package installed and 0 package upgraded
+==============================================================================
| Package libwacom-0.25 installed successfully
+==============================================================================


[ inukaze | 18-07-2017 | 12:14 am ]
[~]$ vlc
VLC media player 3.0.0-git Vetinari (revision 2.2.0-git-12716-gbec643e)
[000000000210c168] core libvlc: Ejecutar vlc con la interfaz predeterminada. Use cvlc para usar vlc sin interfaz.
[00000000021cb878] core playlist: playlist is empty
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant build vlc under slackware64 current USUARIONUEVO Slackware 5 11-23-2016 09:21 AM
[SOLVED] Followup - Slackware64 14.2 + MultiLib + Nvidia Blob + VLC Pixellation kjhambrick Slackware 4 08-12-2016 11:27 AM
alienBOB's vlc.Slackbuild script fails on libavcodec.pc on Slackware64 14.0 multilib. indubitableness Slackware 19 08-20-2013 07:37 AM
[SOLVED] VLC/BibleTime Hang in Slackware64 13.1 tpreitzel Slackware 5 06-05-2010 07:09 PM
Slackware64 RC 1 and VLC 1.1.0-pre3. cwizardone Slackware 6 05-16-2010 11:02 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration