LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-18-2017, 01:26 AM   #1
inukaze
Member
 
Registered: Feb 2011
Location: Venezuela - Caracas
Distribution: Slackware64 14.2, Slackware 14.2, Gentoo, Devuan, gNewSense, GoboLinux, Leeenux, Porteus
Posts: 84

Rep: Reputation: 5
Question Slackware64 14.2 : SMPlayer dont load anymore and other dunnos


Hi there using Slackware64 14.2. Some strange happend
Yesterday i saw videos on SMPlayer

But right now i try to use SMPlayer and simple don't load the GUI
i try from Terminal, and i get the follow :

Code:
$ smplayer
Debug: global_init
Debug: global_init: config file: '/home/inukaze/.config/smplayer/smplayer.ini'
Debug: Preferences::load
Debug: AssStyles::load
Debug: Translator::loadCatalog: can't load qt_es_VE from /usr/share/smplayer/translations
Debug: Translator::loadCatalog: successfully loaded qt_es_VE from /usr/lib64/qt/translations
Debug: Translator::loadCatalog: successfully loaded smplayer_es_VE from /usr/share/smplayer/translations
SMPlayer v. 16.6.0 ejecutándose en Linux
Debug: SMPlayer v. 16.6.0 ejecutándose en Linux
Debug: Compiled with Qt v. 4.8.7, using 4.8.7
Debug:  * application path: "/usr/bin" 
Debug:  * data path: "/usr/share/smplayer" 
Debug:  * translation path: "/usr/share/smplayer/translations" 
Debug:  * doc path: "/usr/doc/smplayer-16.6.0" 
Debug:  * themes path: "/usr/share/smplayer/themes" 
Debug:  * shortcuts path: "/usr/share/smplayer/shortcuts" 
Debug:  * config path: "/home/inukaze/.config/smplayer" 
Debug:  * ini path: "/home/inukaze/.config/smplayer" 
Debug:  * file for subtitles' styles: "/home/inukaze/.config/smplayer/styles.ass" 
Debug:  * current path: "/usr/share/smplayer/translations" 
Debug: SMPlayer::processArgs: arguments: 1
Debug: SMPlayer::processArgs: 0 = smplayer
Debug: SMPlayer::processArgs: files_to_play: count: 0
Warning: QtLockedFile::lock(): file is not opened
Warning: QtLockedFile::lock(): file is not opened
Someone know what is wrong or i can debug and find the problem to fix it ?

2 - Another thing is the GTK3 Applications, like Firefox, looks very ugly. which packages i must install to fix the look & feel of GTK3 Applications ?

3 - Xfce Thunar, show a "Filesystem" (is Network://) and ever is empty. This is for Samba and/or NFS ? or well how i remove it from Thunar ?

4 - It's possible install and use : v86d + uvesafb + plymouth on Slackware64 14.2 ?
 
Old 06-18-2017, 05:47 AM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 8,276

Rep: Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829
Your log snippet has debug messages & warnings, but no errors. I'd like to see an error. Maybe run it in an xterm without the -debug and see what it says.

2 & 3. Google is your friend. I think firefox looks ok. There's all sorts of themes if you want a different look.

4. Check slackbuilds.org. The answer is probably "Yes, but have you the stamina to make it happen?"
 
Old 06-18-2017, 10:12 AM   #3
Paulo2
Member
 
Registered: Aug 2012
Distribution: Slackware64-current (started with 13.37(32))
Posts: 323

Rep: Reputation: 86
Like business_kid said, Google it
https://www.google.com.br/search?q=W...GMaDmQHNu6jABw
It seems that some lock file is preventing SMPlayer to run.

About the ugly GTK3 applications, I think they use the default Adwaita theme.
I don't like Adwaita and I tried a lot of GTK3 themes in -current, but none of them look better.
It seems that transition GTK2-3 will be difficult with the new -stable release.
 
Old 06-18-2017, 01:46 PM   #4
inukaze
Member
 
Registered: Feb 2011
Location: Venezuela - Caracas
Distribution: Slackware64 14.2, Slackware 14.2, Gentoo, Devuan, gNewSense, GoboLinux, Leeenux, Porteus
Posts: 84

Original Poster
Rep: Reputation: 5
Thanks for the SMPlayer the solution is very simple just

Code:
rm -rf /tmp/qtsingleapp-smplay*
The problem with my Slackware64 14.2 is GTK3 , all GTK3 looks like the "Context Menu" (Sub-Menu) on this Screenshot
Firefox 54 (GTK3) -> https://s25.postimg.org/j9jht9pwv/Firefox54.png

With GTK2 i don't have that problem.
Firefox 52 (GTK2) -> https://s25.postimg.org/rqj046ulr/Firefox52_GTK2.png

In GTK3 don't matter why Theme i try to Apply, all themes looks like the same incluided the Default "Adwaita" Theme. the problem is not the theme, looks like i need the "Engine" of GTK3 for Slackware64 14.2 for make it looks like the theme is.

Because i has checked , i know on slackbuilds dont exist a package for v86d, uvesa and/or plymouth under 14.2, and because of that i make the question on first place.

i found the Package for manual compilation for v86d

Code:
slpkg -F klibc
slpkg -s sbo klibc
wget -c https://slackbuilds.org/slackbuilds/14.0/system/v86d.tar.gz
tar xfvz v86d.tar.gz
cd v86d
wget -c http://harrier.slackbuilds.org/misc/v86d-90a8b750fd.tar.xz
su -c "sh v86d.SlackBuild" root
su -c "installpkg /tmp/v86d-90a8b750fd-x86_64-1_Sbo.tgz" root
su -c "ldconfig"
hwinfo :
Code:
slpkg -s sbo hwinfo
Well i still searching how to Plymouth under Slackware64 14.2

i got a new issue, when i turn off, and turn on again
Slackware can't autogenerate the file

$HOME/.serverauth.<ramdom number over 1000>

i don't know why :v .

for the "serverauth"
Code:
su
rm -rf .serverauth.* .Xauthority*
exit
touch .Xauthority
exit

Last edited by inukaze; 06-19-2017 at 01:58 PM. Reason: Partially Solve
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Partitions resized; PC dont boot anymore; how to solve? floppy_stuttgart Linux - Newbie 11 03-31-2016 12:58 AM
[SOLVED] x265 video playback with Slackware64 14.1 and SMPlayer ahc_fan Slackware 19 01-08-2016 12:04 PM
startx doesn't work - because i dont have the graphic card anymore s0p3rsa1yan Slackware 4 02-05-2009 07:54 PM
2.6.3 doesn't even LOAD anymore kev^ Slackware 4 03-09-2004 01:42 PM
I dont want the MAC GUI in redhat anymore Laxin22 Linux - Newbie 1 02-17-2002 01:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration