LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-19-2017, 04:50 PM   #1
inukaze
Member
 
Registered: Feb 2011
Location: Venezuela - Caracas
Distribution: Slackware64 14.2, Slackware 14.2, Gentoo, Devuan, gNewSense, GoboLinux, Leeenux, Porteus
Posts: 80

Rep: Reputation: 4
Question Slackware64 14.2 : Don't enter automatically on X


Hi there i had a new issue with my Slackware64 14.2

Each time i reboot my system, the system can't start the graphical session, i use "lxdm" (lxdm-binary) like session manager ever stuck showing the follow :

Code:
Staring up x11 session manager
Staring up x11 session manager
Staring up x11 session manager
Staring up x11 session manager
Staring up x11 session manager
Staring up x11 session manager
Staring up x11 session manager
Staring up x11 session manager
Staring up x11 session manager
INIT: Id "x1" respawning too fast: Disabled For 5 minutes
The strange is, if i press enter, and login like root and use
Code:
Xorg
This start the lxdm

or if i login with my user and use "startx" i can start my "xfce session", i try using Xorg directly with my user, but just leave me in a Black Screen with an intermittent cursor on the left top of screen.

Someone can help me, please ?
I forgot where is the file i change the session managers like "kdm, gdm, xdm, lxdm, mdm, lightdm"

i had installed lxdm
Code:
[~]#$ locate lxdm lxdm-binary | grep sbin
/usr/sbin/lxdm
/usr/sbin/lxdm-binary
my /etc/inittab
Code:
#
# inittab	This file describes how the INIT process should set up
#		the system in a certain run-level.
#
# Version:	@(#)inittab		2.04	17/05/93	MvS
#                                       2.10    02/10/95        PV
#                                       3.00    02/06/1999      PV
#                                       4.00    04/10/2002      PV
#                                      13.37    2011-03-25      PJV
#
# Author:	Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
# Modified by:	Patrick J. Volkerding, <volkerdi@slackware.com>
#

# These are the default runlevels in Slackware:
#   0 = halt
#   1 = single user mode
#   2 = unused (but configured the same as runlevel 3)
#   3 = multiuser mode (default Slackware runlevel)
#   4 = X11 with KDM/GDM/XDM (session managers)
#   5 = unused (but configured the same as runlevel 3)
#   6 = reboot

# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:

# System initialization (runs when system boots).
si:S:sysinit:/etc/rc.d/rc.S

# Script to run when going single user (runlevel 1).
su:1S:wait:/etc/rc.d/rc.K

# Script to run when going multi user.
rc:2345:wait:/etc/rc.d/rc.M

# What to do at the "Three Finger Salute".
ca::ctrlaltdel:/sbin/shutdown -t5 -r now

# Runlevel 0 halts the system.
l0:0:wait:/etc/rc.d/rc.0

# Runlevel 6 reboots the system.
l6:6:wait:/etc/rc.d/rc.6

# What to do when power fails.
pf::powerfail:/sbin/genpowerfail start

# If power is back, cancel the running shutdown.
pg::powerokwait:/sbin/genpowerfail stop

# These are the standard console login getties in multiuser mode:
c1:12345:respawn:/sbin/agetty --noclear 38400 tty1 linux
c2:12345:respawn:/sbin/agetty 38400 tty2 linux
c3:12345:respawn:/sbin/agetty 38400 tty3 linux
c4:12345:respawn:/sbin/agetty 38400 tty4 linux
c5:12345:respawn:/sbin/agetty 38400 tty5 linux
c6:12345:respawn:/sbin/agetty 38400 tty6 linux

# Local serial lines:
#s1:12345:respawn:/sbin/agetty -L ttyS0 9600 vt100
#s2:12345:respawn:/sbin/agetty -L ttyS1 9600 vt100

# Dialup lines:
#d1:12345:respawn:/sbin/agetty -mt60 38400,19200,9600,2400,1200 ttyS0 vt100
#d2:12345:respawn:/sbin/agetty -mt60 38400,19200,9600,2400,1200 ttyS1 vt100

# Runlevel 4 also starts /etc/rc.d/rc.4 to run a display manager for X.
# Display managers are preferred in this order:  gdm, kdm, xdm
x1:4:respawn:/etc/rc.d/rc.4

# End of /etc/inittab
my /etc/rc.d/rc.4
Code:
#! /bin/sh
#
# rc.4		This file is executed by init(8) when the system is being
#		initialized for run level 4 (XDM)
#
# Version:	@(#)/etc/rc.d/rc.4	2.00	02/17/93
#
# Author:	Fred N. van Kempen, <waltje@uwalt.nl.mugnet.org>
# At least 47% rewritten by:  Patrick J. Volkerding <volkerdi@slackware.com>
#

# Tell the viewers what's going to happen...
echo "Starting up X11 session manager..."

# Inukaze : LXDM
if [ -x /usr/sbin/lxdm ]; then
  exec /usr/sbin/lxdm -nodaemon
fi

# Try to use GNOME's gdm session manager.  This comes first because if
# gdm is on the machine then the user probably installed it and wants
# to use it by default:
if [ -x /usr/bin/gdm ]; then
  exec /usr/bin/gdm -nodaemon
fi

# Someone thought that gdm looked prettier in /usr/sbin,
# so look there, too:
if [ -x /usr/sbin/gdm ]; then
  exec /usr/sbin/gdm -nodaemon
fi

# Not there?  OK, try to use KDE's kdm session manager:
if [ -x /opt/kde/bin/kdm ]; then
  exec /opt/kde/bin/kdm -nodaemon
elif [ -x /usr/bin/kdm ]; then
  exec /usr/bin/kdm -nodaemon
fi

# Look for SDDM as well:
if [ -x /usr/bin/sddm ]; then
  exec /usr/bin/sddm
fi

# If all you have is XDM, I guess it will have to do:
if [ -x /usr/bin/xdm ]; then
  exec /usr/bin/xdm -nodaemon
elif [ -x /usr/X11R6/bin/xdm ]; then
  exec /usr/X11R6/bin/xdm -nodaemon
fi

# error
echo
echo "Hey, you don't have KDM, GDM, or XDM.  Can't use runlevel 4 without"
echo "one of those installed."
sleep 30

# All done.
my /etc/X11/xorg.conf
Code:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 304.135  (root@Inukaze)  mar feb 21 02:02:03 VET 2017

# Inukaze config for Nvidia-Cards
# Debian, put in /etc/X11/xorg.conf 
# Manjaro mwhd put in /etc/X11/mhwd.d/nvidia.conf

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Module"
    Load           "ddc"  # ddc probing of monitor
    Load           "dbe"
    Load           "vbe"
    Load           "bitmap"
    Load           "dri"
    Load           "dri2"
    Load           "extmod"
    Load           "glx"
    Load           "bitmap" # bitmap-fonts
    Load           "int10"
    Load           "type1"
    Load           "freetype"
    Load           "record"
    Load           "synaptics"
EndSection

Section "ServerFlags"
    Option         "DontZap" "False"
    Option         "DontZoom" "True"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputClass"
    Identifier         "Keyboard Defaults"
    MatchIsKeyboard    "yes"
    Option         "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Toshiba Matsushita Display Technology Co., Ltd LCD-MONITOR"
    HorizSync       30.0 - 82.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS" "TRUE"
EndSection

Section "Device"

#	Driver		"vesa"
#	Option		"AddARGBGLXVisuals"		"True"
#	Option		"DRI"				"True"
#	Option		"XAANoOffscreenPixmaps"		"True"
#
# Disabled - Overclocking - Can Damage Hardware :
#	Option		"Coolbits"			"1"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 6200 TurboCache(TM)"
    Option         "DPMS" "True"
    Option         "NoLogo" "True"
    Option         "AllowGLXWithComposite" "True"
    Option         "TripleBuffer" "True"
    Option         "RenderAccel" "True"
    Option         "HWCursor" "True"
    Option         "CursorShadow" "True"
    Option         "NvAGP" "3"
    Option         "NoPowerConnectorCheck" "True"
    Option         "UseEdidFreqs" "True"
    Option         "backingstore" "True"
    Option         "DPI" "87"
    Option         "MigrationHeuristic" "greedy"
# Dejar que la GPU establezca su propio nivel de rendimiento basado en la temperatura
    Option         "RegistryDwords" "PerfLevelSrc=0x3333"
# PowerMizer en su máximo nivel de rendimiento:
EndSection

Section "Screen"

#	Not Used Options
#	Option         "AddARGBVisuals"			"True"
#	Option         "nvidia-auto-select +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "AddARGBGLXVisuals" "True"
    Option         "DPMS"
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "CRT: 1024x768_60 +0+0, TV: 1024x768 +0+0; CRT: 800x600_60 +0+0, TV: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "DRI" "Enable"
    Option         "RandR" "Enable"
    Option         "RENDER" "Enable"
    Option         "Composite" "Enable"
EndSection
Well i don't understand what's the problem, the files works from February to yesterday.

Last edited by inukaze; 06-19-2017 at 05:13 PM.
 
Old 06-19-2017, 05:17 PM   #2
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2 on Lenovo Thinkpad W520
Posts: 7,575

Rep: Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505
The file is /etc/rc.d/rc.4

Please provide output of following commands:

Code:
cat /etc/rc.d/rc.4
ls -1 /usr/share/xsessions
cat /var/log/lxdm*
Alternatively you can provide the output of the 'cat' commands as attachments. The manes of attached files should have the .txt extension.

Last edited by Didier Spaier; 06-19-2017 at 05:20 PM.
 
Old 06-19-2017, 05:35 PM   #3
BW-userx
Senior Member
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Void Linux / Slackware 14.2
Posts: 4,636

Rep: Reputation: 857Reputation: 857Reputation: 857Reputation: 857Reputation: 857Reputation: 857Reputation: 857
haha I just had that same thing by pasting one too many lines in rc.4 I copied
/etc/rc.d/rc.4 _at_the_top_ above the gdm lines:
long with this
Code:
echo "Starting up X11 session manager..."
  # Regardless of the comments below, let's check for lxdm first:
  if [ -x /usr/sbin/lxdm ]; then
    exec /usr/sbin/lxdm
  fi
that is what is should look like, Lucky I had dual boot to use, I just booted in to my other linux then mounted slack then went in and reedit that rc.4 file, I think you can use the boot usb or dvd to boot using that kernel maybe or get a live usb linux boot it then mount that hard drive then go in and edit that rc.4 file properly .

Code:
userx%slackwhere ⚡ slack-mirror ⚡> whereis lxdm
lxdm: /usr/sbin/lxdm /etc/lxdm /usr/share/lxdm
I maybe wrong for yours

Last edited by BW-userx; 06-19-2017 at 05:46 PM.
 
Old 06-19-2017, 06:55 PM   #4
inukaze
Member
 
Registered: Feb 2011
Location: Venezuela - Caracas
Distribution: Slackware64 14.2, Slackware 14.2, Gentoo, Devuan, gNewSense, GoboLinux, Leeenux, Porteus
Posts: 80

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by Didier Spaier View Post
The file is /etc/rc.d/rc.4

Please provide output of following commands:

Code:
cat /etc/rc.d/rc.4
ls -1 /usr/share/xsessions
cat /var/log/lxdm*
Alternatively you can provide the output of the 'cat' commands as attachments. The manes of attached files should have the .txt extension.
Code:
$ cat /etc/rc.d/rc.4
#! /bin/sh
#
# rc.4		This file is executed by init(8) when the system is being
#		initialized for run level 4 (XDM)
#
# Version:	@(#)/etc/rc.d/rc.4	2.00	02/17/93
#
# Author:	Fred N. van Kempen, <waltje@uwalt.nl.mugnet.org>
# At least 47% rewritten by:  Patrick J. Volkerding <volkerdi@slackware.com>
#

# Tell the viewers what's going to happen...
echo "Starting up X11 session manager..."

# Inukaze : LXDM, Slim
if [ -x /usr/sbin/lxdm ]; then
  exec /usr/sbin/lxdm -nodaemon
fi

if [ -x /usr/bin/slim ]; then
  exec /usr/bin/slim
fi
# Slim, LXDM : Inukaze

# Try to use GNOME's gdm session manager.  This comes first because if
# gdm is on the machine then the user probably installed it and wants
# to use it by default:
if [ -x /usr/bin/gdm ]; then
  exec /usr/bin/gdm -nodaemon
fi

# Someone thought that gdm looked prettier in /usr/sbin,
# so look there, too:
if [ -x /usr/sbin/gdm ]; then
  exec /usr/sbin/gdm -nodaemon
fi

# Not there?  OK, try to use KDE's kdm session manager:
if [ -x /opt/kde/bin/kdm ]; then
  exec /opt/kde/bin/kdm -nodaemon
elif [ -x /usr/bin/kdm ]; then
  exec /usr/bin/kdm -nodaemon
fi

# Look for SDDM as well:
if [ -x /usr/bin/sddm ]; then
  exec /usr/bin/sddm
fi

# If all you have is XDM, I guess it will have to do:
if [ -x /usr/bin/xdm ]; then
  exec /usr/bin/xdm -nodaemon
elif [ -x /usr/X11R6/bin/xdm ]; then
  exec /usr/X11R6/bin/xdm -nodaemon
fi

# error
echo
echo "Hey, you don't have KDM, GDM, or XDM.  Can't use runlevel 4 without"
echo "one of those installed."
sleep 30

# All done.
Code:
$ ls -1 /usr/share/xsessions
openbox-gnome.desktop
openbox-kde.desktop
openbox-session.desktop
xfce.desktop
Code:
su
cat /var/log/lxdm.log*
** Message: find greeter (nil)

** Message: find idle (nil)

** Message: 1497917212: add xserver watch

Invalid MIT-MAGIC-COOKIE-1 key(EE) 
Fatal server error:
(EE) Server is already active for display 0
	If this server is no longer running, remove /tmp/.X0-lock
	and start again.
(EE) 
(EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
(EE) 
Invalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 key** Message: find greeter (nil)

** Message: find idle (nil)

** Message: 1497917207: add xserver watch

Invalid MIT-MAGIC-COOKIE-1 key(EE) 
Fatal server error:
(EE) Server is already active for display 0
	If this server is no longer running, remove /tmp/.X0-lock
	and start again.
(EE) 
(EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
(EE) 
Invalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 key** Message: 1497917212: start xserver in 100 retry
** Message: exit cb

** Message: free session

Last edited by inukaze; 06-19-2017 at 07:08 PM.
 
Old 06-19-2017, 07:36 PM   #5
inukaze
Member
 
Registered: Feb 2011
Location: Venezuela - Caracas
Distribution: Slackware64 14.2, Slackware 14.2, Gentoo, Devuan, gNewSense, GoboLinux, Leeenux, Porteus
Posts: 80

Original Poster
Rep: Reputation: 4
I need the /tmp , must be empty when i restart the system
and the problem looks like the "lxdm" try to start without Xorg

Because when i try to run Xorg, and press "Ctrl+Alt+BackSpace" to restart Graphical System
the LXDM can start.

but if i login like root and try to use
Code:
/etc/rc.d/rc4
happen the same, can't start and show 9 times the message "Staring up x11 session manager" and below the message "INIT: Id "x1" respawning too fast: Disabled For 5 minutes"

How i can put Xorg must be initiate first and after try to run the lxdm display manager ???
 
Old 06-20-2017, 01:21 AM   #6
inukaze
Member
 
Registered: Feb 2011
Location: Venezuela - Caracas
Distribution: Slackware64 14.2, Slackware 14.2, Gentoo, Devuan, gNewSense, GoboLinux, Leeenux, Porteus
Posts: 80

Original Poster
Rep: Reputation: 4
I Solved with a workaround

Code:
su -c "joe /etc/rc.d/rc.4" root
The content of my file /etc/rc.d/rc.4
Code:
#! /bin/sh
#
# rc.4		This file is executed by init(8) when the system is being
#		initialized for run level 4 (XDM)
#
# Version:	@(#)/etc/rc.d/rc.4	2.00	02/17/93
#
# Author:	Fred N. van Kempen, <waltje@uwalt.nl.mugnet.org>
# At least 47% rewritten by:  Patrick J. Volkerding <volkerdi@slackware.com>
#

# Tell the viewers what's going to happen...
echo "Starting up X11 session manager..."

# Inukaze : LXDM, Slim
if [ -x /usr/sbin/lxdm-binary ]; then
	. /etc/profile.d/lang.sh # i extract this line from /usr/sbin/lxdm
	export LANG              # i extract this line from /usr/sbin/lxdm
	if [ -d /tmp ]; then
		rm -rf /tmp/.[^.]*
	fi
	exec /usr/sbin/lxdm-binary
fi

if [ -x /usr/bin/slim ]; then
  exec /usr/bin/slim
fi
# Slim, LXDM : Inukaze

# Try to use GNOME's gdm session manager.  This comes first because if
# gdm is on the machine then the user probably installed it and wants
# to use it by default:
if [ -x /usr/bin/gdm ]; then
  exec /usr/bin/gdm -nodaemon
fi

# Someone thought that gdm looked prettier in /usr/sbin,
# so look there, too:
if [ -x /usr/sbin/gdm ]; then
  exec /usr/sbin/gdm -nodaemon
fi

# Not there?  OK, try to use KDE's kdm session manager:
if [ -x /opt/kde/bin/kdm ]; then
  exec /opt/kde/bin/kdm -nodaemon
elif [ -x /usr/bin/kdm ]; then
  exec /usr/bin/kdm -nodaemon
fi

# Look for SDDM as well:
if [ -x /usr/bin/sddm ]; then
  exec /usr/bin/sddm
fi

# If all you have is XDM, I guess it will have to do:
if [ -x /usr/bin/xdm ]; then
  exec /usr/bin/xdm -nodaemon
elif [ -x /usr/X11R6/bin/xdm ]; then
  exec /usr/X11R6/bin/xdm -nodaemon
fi

# error
echo
echo "Hey, you don't have KDM, GDM, or XDM.  Can't use runlevel 4 without"
echo "one of those installed."
sleep 30

# All done.
Its very simple, i notice the /usr/sbin/lxdm, is just a miniscript i put the content
inside the rc.4 file, detect if the /tmp directory exists, then delete all hidden files
start the lxdm-binary. i really don't know why Xorg have this bug with lxdm.

Well first the system make 2 trys until the 3 time of try, can start lxdm normally

Is a workaround very simple and works for me
 
Old 06-20-2017, 04:31 AM   #7
GazL
Senior Member
 
Registered: May 2008
Posts: 4,377
Blog Entries: 7

Rep: Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825Reputation: 1825
rc.M removes stale Xorg lockfiles from /tmp when the system boots. If you're getting a "Already running" error right after a reboot then it's likely it's exactly what it says. Somehow you're starting the thing twice. You need to look at the changes you've made and find out where. Just deleting the lock file is not a solution, and getting rid of every hidden file in /tmp is a really bad idea.

Note: lxdm starts Xorg for itself. You shouldn't be starting Xorg prior to lxdm.
 
Old 06-20-2017, 04:38 AM   #8
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2 on Lenovo Thinkpad W520
Posts: 7,575

Rep: Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505
Quote:
Originally Posted by GazL View Post
Note: lxdm starts Xorg for itself. You shouldn't be starting Xorg prior to lxdm.
Confirmation:
Code:
didier[~]$ pstree |grep -A4 lxdm
     |-lxdm-binary-+-Xorg---{Xorg}
     |             `-fvwm-+-FvwmButtons
     |                    |-FvwmEvent
     |                    |-FvwmIconMan
     |                    `-FvwmPager
 
1 members found this post helpful.
Old 06-20-2017, 08:21 AM   #9
BW-userx
Senior Member
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Void Linux / Slackware 14.2
Posts: 4,636

Rep: Reputation: 857Reputation: 857Reputation: 857Reputation: 857Reputation: 857Reputation: 857Reputation: 857
have you also modded your lxdm.conf so make sure it logs out completely whenever one logs out of a session?

Code:
userx%slackwhere ⚡ ~ ⚡> sudo cat /etc/lxdm/lxdm.conf

[server]
## arg used to start xserver, not fully function
# arg=/usr/bin/X -background vt1
# uncomment this if you really want xserver listen to tcp
# tcp_listen=1
# uncoment this if you want reset the xserver after logout
reset=1
 
Old 06-20-2017, 03:56 PM   #10
inukaze
Member
 
Registered: Feb 2011
Location: Venezuela - Caracas
Distribution: Slackware64 14.2, Slackware 14.2, Gentoo, Devuan, gNewSense, GoboLinux, Leeenux, Porteus
Posts: 80

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by BW-userx View Post
have you also modded your lxdm.conf so make sure it logs out completely whenever one logs out of a session?

Code:
userx%slackwhere ⚡ ~ ⚡> sudo cat /etc/lxdm/lxdm.conf

[server]
## arg used to start xserver, not fully function
# arg=/usr/bin/X -background vt1
# uncomment this if you really want xserver listen to tcp
# tcp_listen=1
# uncoment this if you want reset the xserver after logout
reset=1
Code:
$ sudo cat /etc/lxdm/lxdm.conf
bash: sudo: command not found
The unique modifications i done on the /etc/lxdm/lxdm.conf
are : autologin, timeout, and gtk-theme. the rest, the file is not altered.

Code:
$ su -c "cat /etc/lxdm/lxdm.conf" root
Password: 
[base]
## uncomment and set autologin username to enable autologin
autologin=inukaze

## uncomment and set timeout to enable timeout autologin,
## the value should >=5
timeout=60

## default session or desktop used when no systemwide config
session=/usr/bin/startxfce4

## uncomment and set to set numlock on your keyboard
# numlock=0

## set this if you don't want to put xauth file at ~/.Xauthority
# xauth_path=/tmp

# not ask password for users who have empty password
# skip_password=1

## greeter used to welcome the user
greeter=/usr/libexec/lxdm-greeter-gtk

[server]
## arg used to start xserver, not fully function
# arg=/usr/bin/X -background vt1
# uncomment this if you really want xserver listen to tcp
# tcp_listen=1
# uncoment this if you want reset the xserver after logou
# reset=1

[display]
## gtk theme used by greeter
gtk_theme=oxygen-gtk

## background of the greeter

## if show bottom pane
bottom_pane=1

## if show language select control
lang=1

## if show keyboard layout select control
#keyboard=1

## the theme of greeter
theme=Industrial

[input]

[userlist]
## if disable the user list control at greeter
disable=0

## whitelist user
white=

## blacklist user
black=

Last edited by inukaze; 06-20-2017 at 03:59 PM.
 
Old 06-20-2017, 04:01 PM   #11
inukaze
Member
 
Registered: Feb 2011
Location: Venezuela - Caracas
Distribution: Slackware64 14.2, Slackware 14.2, Gentoo, Devuan, gNewSense, GoboLinux, Leeenux, Porteus
Posts: 80

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by Didier Spaier View Post
Confirmation:
Code:
didier[~]$ pstree |grep -A4 lxdm
     |-lxdm-binary-+-Xorg---{Xorg}
     |             `-fvwm-+-FvwmButtons
     |                    |-FvwmEvent
     |                    |-FvwmIconMan
     |                    `-FvwmPager
Code:
[ inukaze | 20-06-2017 | 05:00 pm ]
[~]$ pstree |grep -A4 lxdm
     |-lxdm-binary-+-Xorg
     |             `-sh---xfce4-session-+-nm-applet-+-{dconf worker}
     |                                  |           |-{gdbus}
     |                                  |           `-{gmain}
     |                                  |-pasystray-+-{gdbus}
 
Old 06-20-2017, 04:12 PM   #12
inukaze
Member
 
Registered: Feb 2011
Location: Venezuela - Caracas
Distribution: Slackware64 14.2, Slackware 14.2, Gentoo, Devuan, gNewSense, GoboLinux, Leeenux, Porteus
Posts: 80

Original Poster
Rep: Reputation: 4
Question

Quote:
Originally Posted by GazL View Post
rc.M removes stale Xorg lockfiles from /tmp when the system boots. If you're getting a "Already running" error right after a reboot then it's likely it's exactly what it says. Somehow you're starting the thing twice. You need to look at the changes you've made and find out where. Just deleting the lock file is not a solution, and getting rid of every hidden file in /tmp is a really bad idea.

Note: lxdm starts Xorg for itself. You shouldn't be starting Xorg prior to lxdm.
I not had made modifications, except i had wrote in this forum
just start : Ssh, Samba, Vsftp, Ntpd, CDEmu, VirtualBox , during boot.

the lxdm just start that strange behaviour 2 days ago, but i don't know why
if i use another like "kdm" or "slim" works normally, sadly i can't install "mdm" i really like that much more, but from the distros GNU/Linux take "systemd" like standard its impossible to use it

Why is really bad idea purge the hidden files on the temporal folder ???
 
Old 06-20-2017, 04:21 PM   #13
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2 on Lenovo Thinkpad W520
Posts: 7,575

Rep: Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505
Quote:
Originally Posted by inukaze View Post
Why is really bad idea purge the hidden files on the temporal folder ???
Because some of theses files are needed e.g. to store authorizations for the session's duration.

You just found an example yourself: doing so you are running two X sessions at the same time for the same user. You shouldn't do that.

Instead and as suggested by BW-userx just uncomment in /etc/lxdm/lxdm.conf:
Code:
reset=1
 
Old 06-20-2017, 09:17 PM   #14
inukaze
Member
 
Registered: Feb 2011
Location: Venezuela - Caracas
Distribution: Slackware64 14.2, Slackware 14.2, Gentoo, Devuan, gNewSense, GoboLinux, Leeenux, Porteus
Posts: 80

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by Didier Spaier View Post
Because some of theses files are needed e.g. to store authorizations for the session's duration.

You just found an example yourself: doing so you are running two X sessions at the same time for the same user. You shouldn't do that.

Instead and as suggested by BW-userx just uncomment in /etc/lxdm/lxdm.conf:
Code:
reset=1
Well i dont know why the follow software ever try execute twice then.

Xorg
xfce4-terminal (when i click : Menu -> Terminal Emulator )
xfce4-appfinder -c (when i press ALT+F2 on xfce4 desktop)

Ok i had modify the /etc/rc.d/rc4 and remove the purge of hidden files
and uncomment the "reset" option inside the lxdm.conf file

Right now i am busy downloading file, when i finish i reset to test what happend now
with Xorg & Lxdm
 
Old 06-20-2017, 11:44 PM   #15
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2 on Lenovo Thinkpad W520
Posts: 7,575

Rep: Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505
Quote:
Originally Posted by inukaze View Post
Well i dont know why the follow software ever try execute twice then.

Xorg
xfce4-terminal (when i click : Menu -> Terminal Emulator )
xfce4-appfinder -c (when i press ALT+F2 on xfce4 desktop)
Xorg is a server, and you need only one.

xfce4-terminal and xfce4-appginder are clients and you can execute as many clients as you want at the same time, see this article for instance. and more specifically this other one and especially the picture on the right.

I see that you are running a lot of Linux distributions: they all implement the same protocols, based on the same concepts, so it helps to understand the underlying concepts. Other examples: the X session manager not to be confused with a X display manager.

Last edited by Didier Spaier; 06-20-2017 at 11:56 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I Enter password automatically for an Script? hack3rcon Linux - Newbie 9 05-19-2015 01:04 PM
How to enter data automatically on terminal? (script BASH) MattFly Programming 4 04-27-2015 07:08 AM
su and sudo don't say what password to enter MTK358 Linux - Software 7 02-11-2011 01:47 PM
How to enter automatically to gnome or gdm? pepealayo Linux - Newbie 1 07-05-2007 10:02 AM
KDE 3.2: Kopete automatically launching when I enter X scuzzman Linux - Newbie 6 07-20-2004 10:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration