LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware64 14.2 and Intel UHD 620 graphics. X: open /dev/dri/card0: No such file or directory (https://www.linuxquestions.org/questions/slackware-14/slackware64-14-2-and-intel-uhd-620-graphics-x-open-dev-dri-card0-no-such-file-or-directory-4175671620/)

someone named bert 03-19-2020 06:20 AM

Slackware64 14.2 and Intel UHD 620 graphics. X: open /dev/dri/card0: No such file or directory
 
1 Attachment(s)
Hi,
I have a ThinkPad E490 laptop with an i5-8265U, which means UHD 620 intel graphics (it doesn't have a second GPU).
After installing, the graphics didn't really work, I had a lot of flickering. (I think 4.4 just doesn't support this GPU.)
  1. I tried using the kernel from current and rebuilding X11 from the SlackBuild in slackware64-current/source/x/. This led to stable graphics, but with software rendering: X said something like 'the entry point into the 915 driver does not work'. (Maybe I should have recompiled more of the graphics stack, mesa/libdrm/libevdev/??)
  2. I built a 4.14 kernel with the config from 14.2 and `yes ""|make oldconfig`, also recompiled X11, and this time also libevdev, libdrm, mesa.
    (I used the x11.SlackBuild from 14.2 with the UPGRADE_PACKAGES=always option. Before that I also restored all the /x/ packages from 14.2 in case the SlackBuild wouldn't create all of them. Is there something else from the graphics stack that I maybe need to recompile?)
    Now I'm getting another error preventing hardware rendering (attaching whole Xorg.0.log):
    Code:

    (EE) open /dev/dri/card0: No such file or directory

Thanks for reading this far. What do you think would be my next option?

someone named bert 03-19-2020 06:27 AM

Ways forward I see are
  1. Find some part of the graphics stack that I missed and recompile that too for the 4.14 kernel.
  2. There is some option in the 4.14 config to enable 'experimental intel graphics support', it didn't really seem to apply to my case but I might try it.
  3. Try what I did with 4.14 with a newer 4.x kernel.
  4. Retry the current-kernel route, this time recompiling more of the graphics stack.
  5. Go to current altogether.

ricky_cardo 03-19-2020 12:16 PM

Are you in a situation where you can use current?
I have a similar GPU and current works well for me,
If I think back Kernel 4.9 and above seems to be a working Kernel / Intel 620.

-You can likely use the kernel config and version from current on 14.2.

Loomx 03-19-2020 01:07 PM

Code:

an i5-8265U, which means UHD 620 intel graphics
I have the same hardware, and there have been long-standing issues with the UHD 620, e.g. see this thread: https://bbs.archlinux.org/viewtopic.php?id=250765

The kernel from -current is good now I think.
I would revert back to the stock packages for X and all the related bits (mesa, etc), then download and install (using `installpkg' not `upgradepkg') the huge kernel and modules from current and boot from that.

bassmadrigal 03-19-2020 05:51 PM

I think your best and easiest option would be to upgrade to -current.

However, if you really want to keep on 14.2, at a minimum I would upgrade to the latest 5.4.x kernel (personally, I would compile it on your system using the config from -current rather than install the packages from -current, just to make sure there's no issues). As for the rest of the software, you'd probably also need to upgrade mesa and all the required dependencies in addition to Xorg. I have tried this in the past. In the lead up to 14.2's release, I was able to upgrade 14.1 to modern packages (at the time) and add better support for my GPU at the time. I tried the same on 14.2 a few months ago, but ran into issues and ended up not having the time to diagnose it properly and reverted to stock 14.2 packages. With more time, I imagine the issues I ran into could be resolved (and if I end up getting quarantined, I might try it again).


All times are GMT -5. The time now is 01:24 AM.