-   Slackware (
-   -   Slackware64 14.1 won't boot... (

irgunII 02-04-2014 02:27 AM

Slackware64 14.1 won't boot...
Hi all,

It took a while fiddling with it first using parted magik and then gdisk with the Slackware DVD, but finally got it actually installed.

For a little more than an hour, I got online, downloaded a couple things, and even built Krusader (I hate Dolphin and pretty much any other file manager compared to it!) and got it up and running.

Opened Krusader and could even see the other hdd (I installed 14.1 64 on sdb and 14.0 x86 is on sda).

Needed though to go to 14.0 to check e-mail and other stuff for a little while. Did that and decided to reboot into sdb so I could do some more stuff with it.

The problem is, no matter what settings I make in the BIOS, it *always* boots to my sda (Slackware 14.0).

It's a UEFI MOBO and after getting 14.1 installed and where it told me to remove the dvd media and hit ctrl-alt-del to reboot, it booted just fine the first time (I had to go into the BIOS then also and make adjustments, but hadn't changed anything since until trying to boot back into 14.1 again the second time).

In sda on 14.0, I can see and have even copied some files to, the 14.1 hdd.

Is the GRUB on 14.1 somehow screwing up? Is there something I can look at and change on it? I prefer lilo, but understand the elilo thing I guess, just not what to edit to make it work again...if that's the problem.

Any ideas?

Richard Cranium 02-04-2014 04:29 AM

Well, it *is* grub so you can interactively look at your boot environment when it comes up. Press the letter "c" when the grub menu shows up and type in "help" to see what commands are available.

irgunII 02-04-2014 05:41 AM

Sorry, I wasn't more grub comes up at all, nothing except the normal screen for me to be able to boot into the 14.0 drive. It's like the system has no clue another hdd is even there anymore.

Drakeo 02-04-2014 06:25 AM

really sounds like to me you may have changed your bios with out noticing. and you may have changed your drive order. that said you can always put the install disk in and read the instructions to boot to the drive and partition on your computer. this will get you started looking.

I use the grub2 in 14.1 and had no real problems with it.

irgunII 02-04-2014 07:53 AM

Believe it or not, I tried the install disk thing...that didn't work either. I think though that that's for a 'lilo' installation. I used the grub2 that starts up automatically. I changed nothing during the install from what happens to anyone installing 14.1 64.

I already tried the different startup attempts by changing the hdd's...also no go. The system simply doesn't seem to think there's a second hdd anymore. I spent an hour changing things right and left in the BIOS trying to get the second hdd to boot, but the system goes straight to the 14.0 hdd like it's the only hdd on the planet.

Maybe the second hdd lost the 'boot flag'? I'll fire up parted magik and see.

Well...didn't see anything 'wrong' with parted magik. Gonna try to reinstall and leave all the partitions unformated except the /boot one that is for this eufi or uefi crap. Man, what a pita.

burgler09 02-04-2014 09:01 AM

Well, I personally hate Grub.. but anyway that happened to me kind of when I had Gentoo and was switching to Slackware. I wasn't running a dual boot but I did repartition, reformat and it still wanted to boot to Gentoo. I think it had to do with it being on the mbr and not getting updated.

This probably will not help you, but what I did was throw in a trusty windows cd and do what it does best.. wipe out everything. I then proceeded to go back to Slackware and use my trusty lilo and my bootloader worked without a problem.

AlleyTrotter 02-04-2014 10:29 AM

Do you have an efi partition?
If so please post the contents of

It should contain a stanza for each of your installations, something like

        append="root=/dev/sda2 vga=normal ro"

That is the a generic one for 14.1 on my system.
You would need to construct an additional stanza for each boot option (ie 14.0 or 14.1)
If you are not UEFI booting I can't help

irgunII 02-04-2014 12:30 PM

Something I just noticed...I've been trying all this time since my last post, to simply start from fresh and re-install Slackware 14.1 64. When I use cgdisk or gdisk, it *seems* to do what it's supposed to do, but when I get to the 'setup' section, at the point where it should write an elilo or lilo it always wants to do a 'lilo'.

I've done this re-install and re-partitioning at least 10 times now and it ends up the same. Only *once*, before my original post, did it ask to do an 'elilo', that's when it booted just fine, but when I rebooted to 14.0 to do stuff and then rebooted to get back into 14.1, it (14.1) couldn't be seen by the BIOS or anything else for that matter. Somewhere in between logging out of 14.1 it lost the booting partition(?) and/or the elilo thing went for a walk without permission and never came back.

I've just now re-burned the 14.1 ISO and will try again to install it.

IIRR, here's the steps I take in (c)gdisk when partitioning:

o = setup a gpt partition. wipes out all partitions that may already be there.

n - new partition, and partition 1 as 100MB and set as ef00 (efi)
n - partition 2 is 25GB and set at 8300 (linux)
n - partition 3 is 123GB and set at 8300 (linux)
n - partition 4 is 935MB and set at 8200 (linux swap)

w - write partition table, enter 'yes' to confirm it will overwrite anything on there previous.

Back to root prompt and enter 'setup' and start the normal routine of installation following all the instructions onscreen 99% as 'just hit enter' to use what it suggests.

Wish me luck folks, and thanks for all the assistance and ideas.

irgunII 02-04-2014 02:11 PM

Well, I tried again, three times and it still won't do the elilo thing. I'm about to give up. I'd really like to try 14.1 as an x86-64 with a few apps I use just to see if it's an improvement over the x386 side (BOINC setiathome, for instance).

Sure wish I knew what the heck happened that one time to make the install see the /boot as the first partition and make an elilo entry for it.

mostlyharmless 02-04-2014 02:59 PM


Eh, which one?

If it's a problem motherboard, inquiring googlers will want to know, so it might be helpful to post the model etc.; if it's one someone has, it might be helpful to compare notes on the exact settings and BIOS revision. I'm running 14.1 on UEFI boot on on ASUS RIVE.

irgunII 02-04-2014 04:32 PM


Originally Posted by mostlyharmless (Post 5111448)
Eh, which one?

If it's a problem motherboard, inquiring googlers will want to know, so it might be helpful to post the model etc.; if it's one someone has, it might be helpful to compare notes on the exact settings and BIOS revision. I'm running 14.1 on UEFI boot on on ASUS RIVE.

It's an ASUS M5A97 LE R2.0 with the original BIOS (I've no M$ OS to upgrade the BIOS if there is an upgrade).

I'm still not sure though how it could be the BIOS if it worked once and not since, especially when I didn't change anything in it until it *didn't* boot anymore after the first time.

I'm also not too sure what kind of question to put to google for this, but I'll go to the ASUS website and see if there's anything there about it and/or if there's an update for the BIOS that I might be able to somehow put on the system even if all it has is an linux OS.

mostlyharmless 02-04-2014 05:01 PM


I'm also not too sure what kind of question to put to google for this...
Yeah, what I meant was other people can avoid this board if indeed it is the problem. Some ASUS boards allow bios upgrades from the bios, no OS required; mine does, not sure about yours.

Edit: looks like your model does too.

metaschima 02-04-2014 05:03 PM

I think the problem may be that the UEFI will only boot registered entries. You register an entry using 'efibootmgr', and this is done when installing elilo. It is sometimes possible that the UEFI will refuse to register entries for some reason, in which case it has a default location that will boot at '/EFI/boot/bootx64.efi', so you could try copying elilo.efi to that name along with the elilo.conf in the same directory and the kernel.

The UEFI can be updated from the settings screen using one of the function keys, just look for the word "flash" maybe EZ-flash or something like that. I strongly recommend NOT updating the UEFI from Windoze, even if you had it. The only other option I would consider would be from a DOS boot disk, but all UEFI have a flashing utility built-in AFAIK.

Sometimes the manufacturer will only provide a Windoze binary to update the BIOS. It's really just a zip or maybe rar archive, so use either 7zip or unzip to unzip it, the UEFI firmware will be extracted and you can use it with the onboard flash utility.

v8dave 02-04-2014 05:05 PM


Originally Posted by irgunII (Post 5111514)
It's an ASUS M5A97 LE R2.0 with the original BIOS (I've no M$ OS to upgrade the BIOS if there is an upgrade).

MSDOS boot images for usb are easy to get on the net so bios upgrades should not be a problem.

I have a new uefi system, a Shuttle SZ87R6, and it has refused attempts by the slackware64-14.1 installer to setup grub or elilo for a uefi boot. Fortunately it has all worked with a manually installed elilo setup. I think the problem was that the initial grub bootloader did not work and then the installer could not overwrite it with the elilo bootloader. You might also have a bios that only accept specific names for the efi boot file, it might have to be 'bootmgfw.efi' or similar.

Try rEFInd by rod smith, it might get you back into the slackware 14.1 system. His site also has a lot of info on the uefi boot process and loader software.

granth 02-04-2014 05:30 PM


It's an ASUS M5A97 LE R2.0 with the original BIOS (I've no M$ OS to upgrade the BIOS if there is an upgrade).
I have the same board. You should upgrade the firmware via the EFI menu. RTFM. Format a usb drive with vfat. Drop the image on, and select the upgrade option from the EFI menu. That should be your first step.

Secondly, there's a section which lets you configure the boot sequence. One of the options allows you to toggle Legacy BIOS and EFI bootloaders. I recommend turning off Legacy BIOS boot support.

All times are GMT -5. The time now is 08:15 AM.