-   Slackware (
-   -   Slackware64 14.0 and wine (

Iotar 12-28-2012 11:16 PM

Slackware64 14.0 and wine
Hello. I have Slackware64 14.0. I tried to install wine and have a problem with fonts:
Wine cannot find the FreeType font library. To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.

I installed compat-32 libs (including freetype) from this:

Can anybody help me? Thanks in advance.

samac 12-29-2012 05:49 AM

Perhaps you need to install fontforge. I also find that winetricks and playonlinux are useful. They are all available on sbopkg.


Iotar 12-29-2012 12:12 PM

samac, thank you for tip, but it's not working.

number22 12-29-2012 07:48 PM

I am still using 13.37 64bit multilib, and installed frontforge and other packages (corefonts,freetype etc) from slackbuild repository , I have problem with Alien's wine.SlackBuild, need compile for new version 1.5.20 (latest version so far).

After update some minors packages, OSMessa, and OSS 2.4 build from slackbuild, used to have problem with 32bit wine which hog sound card, lot of statics noise when other 64 bit programs try to using sound card at same time, building 64bits version wine to use 64 bit alsa driver solved this problem.

I put wine source files at /tmp/wine-1.5.20, read winehq for more info building shared 32 and 64bit wine, you may need new version gecko and/or mono.

cd /tmp

mkdir wine64

cd wine64

../wine-1.5.20/configure --prefix=/usr --sysconfdir=/etc --libdir=/usr/lib64 --mandir=/usr/man --docdir=/usr/doc/wine-1.5.20 --enable-win64

make (build wine64 version first)

cd /tmp

mkdir wine32

cd wine32

../wine-1.5.20/configure --prefix=/usr --sysconfdir=/etc --libdir=/usr/lib --mandir=/usr/man --docdir=/usr/doc/wine-1.5.20 --with-wine64=../wine64

make (2nd time make wine32 version)

mkdir /tmp/pkg-wine (make a new package location)

make DESTDIR=/tmp/pkg-wine install (install 32bit version first, still at /tmp/wine32)

cd ../wine64

make DESTDIR=/tmp/pkg-wine install (install 64bit version 2nd from /tmp/wine64)

cd /tmp/pkg-wine

makepkg /tmp/wine-1.5.20-x86_64-1mybuild.tgz (answer yes to questions)

cd /tmp

upgradepkg wine-1.5.20-x86_64-1mybuild.tgz

or installpkg wine-1.5.20-x86_64-1mybuild.tgz

good luck.

dlachausse 12-30-2012 04:37 PM

There are actually precompiled binary packages for Wine that I've always had really good luck with. There's a link to them on the website.

Iotar 01-02-2013 03:31 PM

Sorry please. I installed absolutely all packages from 14.0 multilib folder and webcorefonts from sbo and problem solved. Thank you all.

All times are GMT -5. The time now is 10:05 AM.