-   Slackware (
-   -   Slackware10 little questions... (

theonebeyond 09-01-2004 05:30 AM

Slackware10 little questions...
Hi all!

I tried out a lot of distributions... mostly working with SuSe in the past... now I switched to Slackware 10.0 for testing... and I love it!!!

But there are some little things that won't work the way I would like them working... and I have been surfing this forum for a while ... but there are stil lsome little things I need help with!

1) I can't access my windows (NTFS) partition as a user ... don't know muc habout this stuff,... other distributions worked from the beginning, so I never got in tuch with that. It seems like a permissions-problem to me. This is what "ls -l "looks like

dr-x------ 1 root root 8.0K date time windows/

When I simply try to "chmod 555 windwos" or "chmod +r windows" I only get a message

chmod: changing permissions of "windows/": Read-only file system

and an errorcode "1"

And from /etc/fstab is that:

/dev/hda1 /windows ntfs ro 1 0

So... I think I have to change something in /etc/fstab ... but, as I said ... I don't know anything for sure :-)

My Second question is:
2) Is there something like YaST or similar in Slackware? Because there are some litttle things I could tune in YaST within seconds... and of course I do not know where and how to do this without it.
For example.... where can I turn on ACPI in some way? How can I change the mouse I am using, to get the wheel working? ... In SuSE I knew how to do this... thanks to YaST ... but how is it going on Slackware.... ?

On to the next:
3) If I place the .bashrc or .exrc in my home... they should overwrite the ones from the system... but in fact they are totally unrecognized ... nothnig happens! NOTHING ... wherther in my personal nor in the root's home they have any effect...

Do I have to turn that on or something like this???

I put some stuff in /etc/profile.d/ ... but that seems to be not exactly what I want... because this won't work for root ....

Last one:
4) Now, the last one is juts some bonus-stuff... I know,... this is not very important ... but I don't like to curses-look of Lilo ... is there a simple way to turn on a graphical Lilo? And may an splashscreen instead of vga-consolse at bootup?

Ok now, I hope it's ok, that I posted all in one thread ... if not, please let me know... I'll fix that.
Away from that I hope some of you guys can help me.... since this forum helped me a lot today and I just could not find out this stuff myself... :-)

Gretings, Sascha

heema 09-01-2004 05:53 AM

check out this site it will help you out

lodder 09-01-2004 06:32 AM

if you defind ntfs in your fstab open it up add these options fo your: nfts disk usersnumask=000

example: /dev/hdc1 /win ntfs ro,users,umask=000 1 0

then all users can open your ntfs drive

justin_p 09-01-2004 06:43 AM

Dude, sorry nothing like YaST in Slack. You have to tune the config files on your own. But the advantages to slack are enormous. You get the packages as their maintainers/developers intended. The system stays out of your way. Another good reference site is Moving on to your mouse... go to the cli and type: su. Enter the root password. type: pico /etc/X11/xorg.conf. Go to the section in their called "Input pointer Device (or something like that). At the end of the Options Section you see a line #End of Section. Go just above this line and type: Option "ZaxisMapping" "4 5". Also make sure that your mouse is set to IMPS/2 instead of just PS/2. Search in these slack forums for answers to your questions. Good luck

theonebeyond 09-01-2004 06:58 AM

Hey guys!

WOW! This is what I call support! Hell, you guys really helped me!!!

By now I have my Mouse up and running (just trying to make the touchpad work too....) and I can access my NTFS-Partition!

I'm trying on the graphical Lilo at the moment ... and then ... I don't know how to deal with the un-working .bashrc ...

@justin_p ... I think it's very good, that Slack has nothing like yast ... I get deeper in touch with Linux itself through it... I think thats better ...

Thanks a lot guys! Thanks over and over!!!

Greeting, Sascha

suslik 09-01-2004 09:23 AM

It seems like your only important problem left is .bashrc. Not sure how this is a problem though, cause on my Slack 10, ~/.bashrc is working as it should. (I have some aliases and vars set in it)

Maybe your stuff gets overridden somewhere... what is it that you are trying to put in it?

theonebeyond 09-01-2004 12:18 PM


I've got some aliasses in there ... like

alias 'c'='clear' or alias 'll'='ls -lh'

And so on...

When I realized, that there is a problem, I put my alisses into /etc/profile.d/ ... that works ,.. almost... but it does not work for root

The .exrc I can't get to work, too ... don't know why.

Greetings, Sascha

suslik 09-01-2004 02:50 PM


from "man bash"
When bash is invoked as an interactive login shell, or as a non-interactive shell with the --login option, it first reads and executes commands from the file /etc/profile, if that file exists. After reading that file, it looks for ~/.bash_profile, ~/.bash_login, and ~/.profile, in that order, and reads and executes commands from the first one that exists and is readable. The --noprofile option may be used when the shell is started to inhibit this behavior.

When a login shell exits, bash reads and executes commands from the file ~/.bash_logout, if it exists.

When an interactive shell that is not a login shell is started, bash reads and executes commands from ~/.bashrc, if that file exists. This may be inhibited by using the --norc option. The --rcfile file option will force bash to read and execute commands from file instead of ~/.bashrc.

theonebeyond 09-02-2004 01:19 AM


I completely forgot the .bash_profile etc... now, that works for me.

But this all is ... errr ... I don't know .. .confusing?
Because... .bashrc won't work for any user... don't know why ... so I have to use .bash_profile ... but suddenly .bashrc works for root .... damn!

Well,... I got what I wanted to far.... and I can't tell you how thankful I am!
You guy really did some for me! ... there are some other things I have to figure out... but that will be another thread !


Greetings, Sascha

All times are GMT -5. The time now is 11:22 PM.