-   Slackware (
-   -   Slackware10.2 &dma (

unifiedquarks 12-12-2005 12:07 PM

Slackware10.2 &dma

I installed slackware 10.2 (with the 2.4.31) to the hp Nx6125 laptop. isntallation was very slow. while the starup I see that the DMA is turned of. so the disk write and read are very slow. but every things were working properly. I tried "hdparm -d1 /dev/..." and some other options but they didnnt work.

I tried the kernel 2.6.13, from the slackware cd (test2.6) the dma was ok, but any other things were not working. I checked with lsmod and no modules were loaded.

then I compiled a new kernel 2.6.14, every things was ok except the dma. so it is stilll wery slow.

while compiling which options do I have checked to enable dma??

dugan 12-12-2005 12:39 PM

No offence, but...

What output did you see when you were running the default kernel and you tried to use hdparm?

What output did you see when you were running the 2.6.13 kernel and you tried to use hdparm? What stopped working? Did you really mean that lsmod showed no modules? If so, had you installed the 2.6.13 kernel modules in addition to the kernel image?

Finally, What output did you see when you were running the 2.6.14 kernel and you tried to use hdparm?

You've given us very little to go on, but I'll guess that the driver for your HD controller isn't compiled into (or loaded for) any of the three kernels above. Use lspci to find out what HD controller you do have, and you should be able to take it from there.

unifiedquarks 12-12-2005 01:22 PM

you are right, I am sorry.

I complied 2.6.14 again. I checked some ati support at ata device section. and now dma is working. the output of hdparm /dev/hda is:

multcount = 16 (on)
IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 256 (on)
geometry = 16383/255/63, sectors = 78140160, start = 0

and the output hdparm -tT is:

Timing cached reads: 88 MB in 2.03 seconds = 43.30 MB/sec
Timing buffered disk reads: 10 MB in 3.18 seconds = 3.14 MB/sec

but it is very slow again!
the output of hdparm -tT when I used the kernel 2.6.13 (directly copied from slackware inst. cd, and there is no module directory in /lib/modules for this kernel):

Timing cached reads: 2626 MB in 2.55 seconds = 1030 MB/sec
Timing buffered disk reads: 96.71 MB in 3.08 seconds = 31.4 MB/sec

so the disk is capable for such high reads.

how can I incease the speed.

dugan 12-14-2005 01:46 AM

You will find the 2.6.13 kernel modules in the same /testing directory you found the 2.6.13 kernel image.

Some suggested hdparm settings might include setting the drive's multsect to its maximum possible value, turning on 32-bit access, enabling write caching, and the "u1" option. See Speeding up Linux using hdparm for a really good article on this.

Finally, there's now a slightly more recent and much more productive thread on the exact problem you're having. I would recommend continuing the discussion there.

All times are GMT -5. The time now is 09:18 AM.