-   Slackware (
-   -   Slackware x86_64 '-current' FireFox & Thunderbird issues with linking (

onebuck 01-21-2010 09:28 PM

Slackware x86_64 '-current' FireFox & Thunderbird issues with linking

I'm preparing a laptop for Slackware 13.x or whatever the new release will be.

I've installed '-current' x86_64 arch. Boy, is this baby fast on this laptop. I thought 13 was fast but oh well another thread.

My issue now is that with '-current' is that ThunderBird links won't open in FF. I click on a link in TB and noting happens. I searched and found '"Browser" problems in Thunderbird 3'.

In this thread, post #9;

Originally Posted by Laodiceans (Post 3797079)
I had the same problem in two different machines. On one the file pref.js had this entry:


user_pref("network.protocol-handler.external.ftp", "/usr/bin/firefox");
user_pref("network.protocol-handler.external.http", "/usr/bin/firefox");

and worked fine.

And on another I had this:


user_pref("network.protocol-handler.external.ftp", );

This last one never open the links. To work or delete the both lines or put the path "/usr/bin/firefox" after the comma.

I modified the 'prefs.js' file. Of course it was done while app was not running. Still no joy.

Further searches showed the same thing with most users bumping back to older versions. There's got to be fix and I refuse to give up to a computer let alone a DE. :)

I want my FF & TB to work together.


TSquaredF 01-21-2010 10:16 PM

Hi, onebuck. I originally gave up on trying to get TB3 to work in Slack13.0. The instructions I had said that it had to be compiled in 13.0; that is what I did & I could never get a link to open in FF, regardless of what I tried. Since then, I, too have installed -current &, when I first clicked a link, it opened a dialog that let me choose the browser to open when a link was clicked. I pointed it at FF & everything has been fine since. I must have held my mouth right, however, 'cause I have no idea why it worked the last time & not the first.
BTW, during my original search for a solution, I found an extension named ThunderBrowse, which opens links in TB on a left click & in FF on a middle click. Really nice for a quick look at a link in an email.

samac 01-22-2010 06:41 AM

How odd I was sent a link in an email the other day and it opened perfectly. I am running Slackware64-current (multi-lib), Firefox 3.5.7, Thunderbird 3.0 the link I was sent is

You're right, WHOOSH fast.


TSquaredF 01-22-2010 10:21 AM

Just a few minutes ago, I clicked a link to an "https" site. The dialog box jumped up again, asking which program TB should send that type of file to. There was also a comment at the bottom of the box to the effect that "This can be changed in TBs preferences." If you go to the preferences menu item, then click on "Attachments", you will find an entire list of files that need to open in other programs & you will have the ability to choose those programs. One could hope that once those are filled in, it will work, but I have no idea why you (& myself the first time) did not get the dialog box.

Laodiceans 01-22-2010 10:54 AM

It worked fine for me.
In one computer I edited the pref.js and in the other when the thunderbird ask me what application I want to use, I choose /usr/bin/firefox and choose to use always that application for that.

mlangdn 01-22-2010 12:18 PM

Thanks, TSquaredF!
That finally got FF to open links from Thunderbird. I had been all over the preferences menu trying to find a solution, and your solution worked perfectly. I had tried all the prefs.js and about:config options, and they were actually already in place in both locations. But going into attachments finally got it right.

onebuck 01-22-2010 03:38 PM


I've been fighting with this on & off most of the day. I finally just 'removepkg mozilla-thunderbird-3.0-x86_64-1'. Then removed '~.thunderbird'. Then from the Slackware64 dvd, 'installpkg mozilla-thunderbird-3.0-x86_64-1'.

Of course I had to create my accounts again but at least I can link from within the email again.

I battled with trying to setup 'prefs.js' but decided to try the above. Works for now.


All times are GMT -5. The time now is 06:51 PM.