-   Slackware (
-   -   slackware won't boot after upgrade to 3.7.1 kernel (

cgorac 12-21-2012 03:47 PM

slackware won't boot after upgrade to 3.7.1 kernel
Just noticed latest update in ChangeLog, and upgraded my Slackware64 -current system. After upgrade completed, I created init ramdisk as always, and ran lilo. However, now busybox is reporting on boot that it is unable to mount /dev/sda1 on /mnt (reporting "Invalid argument" as reason). I booted from my install DVD, and tried to chang to huge kernel (also, of course, removing init ramdisk line from my lilo.conf), however machine is now crashing on boot (I can see "panic" under "mount_block_root" in the trace). Machine is also getting very, very hot (it's Lenovo ThinkPad W520 laptop). So, any suggestions here?

guanx 12-21-2012 04:03 PM

Could you take a photo of your screen? Need not be too clear. Should be enough if the messages could be recognized.

cgorac 12-21-2012 04:05 PM

OK, I fixed this one. I've used script to generate mkinitrd command line, and then just changed kernel number. When I generated it through invoking:
mkinitrd -c -k 3.7.1 -m ext4 -f ext4 -r /dev/sda1
directly, it worked fine. Of course, is also now printing proper command, once new kernel booted.

bormant 12-22-2012 06:46 AM has "-k" option, so

# /usr/share/mkinitrd/ -k 3.7.1 | bash
# lilo

All times are GMT -5. The time now is 06:18 AM.