LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-28-2009, 10:18 PM   #1
nerdman978
Member
 
Registered: Apr 2007
Distribution: Windows, Ubuntu 8.04, starting Slackware
Posts: 45

Rep: Reputation: 15
slackware wireless drivers on an eee pc 901


I've been having a really hard time get wireless to work with slackware on my Eee PC 901.

I've tried multiple drivers from Ralink, and after much google searching, I haven't seen anyone get wireless to work successfully on a 901 (although there is a project going for the 701 model, which uses a different wireless card). I've also tried using the windows drivers and ndiswrapper.

Has anyone successfully set up the wireless yet on the Eee 901?
If so, any tips would be great, I like slackware and would love to run it on my eee pc (and I'm really sick of eeebuntu and all that crap).
 
Old 03-01-2009, 12:35 AM   #2
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,154
Blog Entries: 3

Rep: Reputation: 340Reputation: 340Reputation: 340Reputation: 340
Enabling Bluetooth
Slackware has it built in the stock kernel and all the modules are there. You just need to configure it.

If you're using a commercial desktop GNU/Linux distribution, chances are you already have the Bluetooth kernel drivers compiled as modules and ready to load upon detection of a Bluetooth hub and a Bluetooth peripheral device. In that case, all you need is a Bluetooth hub, software to detect and manage devices, and some Bluetooth-enabled peripheral hardware to wirelessly connect to your computer.

If you're a do-it-yourselfer or if your distro doesn't have Bluetooth support compiled by default, you'll have to go into the kernel configuration and add them by hand. Bluetooth has its own kernel modules within the Networking subsection of the Device Driver heading in the Linux kernel menu. You'll want to enable each of the protocols within the Bluetooth subsystem support menu. If you build them as modules, you'll have to load them by hand using modprobe, or load them at boot time automatically according to your distribution's specific method. For the least amount of hassle, just build Bluetooth support into your kernel, recompile it, install it, and adjust your boot loader configuration if necessary. this program for slackware 12.2 will get you going. after installing click the little icon on the bottom right. and follow the instructions. this is from slackware extra

Last edited by Drakeo; 03-01-2009 at 12:38 AM.
 
Old 03-01-2009, 03:05 AM   #3
mcnalu
Member
 
Registered: Dec 2006
Location: Glasgow, UK
Distribution: Slackware 13.37 and 13.1
Posts: 398

Rep: Reputation: 64
I've set up slack 12.1 on my eee pc 1000h, which has much in common with the 901. Here's one post I made:

http://www.linuxquestions.org/questi...ighlight=1000h

You can find other posts about it by searching on 1000h in this forum.

For both wireless and ethernet I downloaded the drivers and then edited rc.inet1.conf - though you might try wicd. The wireless is sometimes quite troublesome. I know of one wireless network which it refuses to connect to and another where it refuses to work with dhcp.

Here are some links I found about the networking hardware

http://www.pclinuxos.com/index.php?o...;topic=50360.0

Here's some info on getting the wireless working:
http://www.linuxquestions.org/questi...t-work-676924/

And for the LAN:
http://twinturbo.org/asus/attansic-a...e-and-install/

Getting other hardware to work was more challenging - sound in particular. Let me know if you want more info on that.

Last edited by mcnalu; 03-01-2009 at 03:08 AM. Reason: fixed broken links
 
Old 03-01-2009, 10:28 AM   #4
the3dfxdude
Member
 
Registered: May 2007
Posts: 519

Rep: Reputation: 191Reputation: 191
Use linux kernel 2.6.29-rc. It has the Ralink driver in the staging section. It works, for unencrypted networks, and probably some WEP and WPA. I have not gotten it to work with 802.1X. So I am patiently waiting for rt2800pci.
 
Old 03-04-2009, 06:50 PM   #5
nerdman978
Member
 
Registered: Apr 2007
Distribution: Windows, Ubuntu 8.04, starting Slackware
Posts: 45

Original Poster
Rep: Reputation: 15
still no luck after those suggestions. any more?
 
Old 03-05-2009, 12:04 AM   #6
the3dfxdude
Member
 
Registered: May 2007
Posts: 519

Rep: Reputation: 191Reputation: 191
What's wrong with rt2860sta for you? It works except in exotic configurations.
 
Old 03-05-2009, 03:25 PM   #7
mcnalu
Member
 
Registered: Dec 2006
Location: Glasgow, UK
Distribution: Slackware 13.37 and 13.1
Posts: 398

Rep: Reputation: 64
rt2860sta works for me on my 1000h, bar a few niggles.

Here's what my rc.inet1.conf looks like for WPA with PSK:

Code:
IFNAME[4]="ra0"
#IPADDR[4]="192.168.1.104"
#NETMASK[4]="255.255.255.0"
USE_DHCP[4]="yes"
DHCP_HOSTNAME[4]="notveryimportant"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
#setting this stops a problem in rc.inet1 when testing
#for a connection.
DHCP_TIMEOUT[4]="5"
WLAN_ESSID[4]=YOURSSID
WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=VERYLONGHEXKEY"
#if you must use WEP, then it's simple
#WLAN_ESSID[4]=YOURSSID
#WLAN_KEY[4]="s:yourtextkey"
You can use wpa_passphrase as root to generate VERYLONGHEXKEY from your SSID and your text WPA key.
 
Old 03-05-2009, 04:26 PM   #8
nerdman978
Member
 
Registered: Apr 2007
Distribution: Windows, Ubuntu 8.04, starting Slackware
Posts: 45

Original Poster
Rep: Reputation: 15
Alright here's what I've done so far.

I installed this driver:
http://www.ralinktech.com.tw/data/dr....8.0.0.tar.bz2

with the config.mk options:
HAS_WPA_SUPPLICANT=y
HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y

after verifying that the module worked (lsmod, and there was rt2860sta)
I checked iwconfig, and there was ra0.

now here's where everything goes awry
first I did ifconfig ra0 up (this way I can change iwconfig without getting any errors)
then I ran iwconfig ra0 mode Managed, but this didn't change the mode
then I tried iwconfig ra0 essid <myessid>, but this didn't change my essid.

so I gave up on iwconfig. then I tried wicd, which seemed to work until it gets to "validating authentication" and which point it just keep going until failing without an error message.

then I tried wpa_supplicant, which also failed.
Quote:
network={
scan_ssid=1
ssid="TenczarFamily"
proto=WPA
key_mgmt=WPA-PSK
pairwise=TKIP
group=TKIP
psk=LONGKEY...
}

does this driver not support WPA or encryption (I haven't tried taking the encryption off my network, as that is definitely not a permanent option for me).
UPDATE: unencrypted networks don't work either. what gives?

Last edited by nerdman978; 03-05-2009 at 04:50 PM.
 
Old 03-06-2009, 06:09 AM   #9
mcnalu
Member
 
Registered: Dec 2006
Location: Glasgow, UK
Distribution: Slackware 13.37 and 13.1
Posts: 398

Rep: Reputation: 64
nerdman - did you see my post above?

Yes, it definitely does support WPA and the config I indicated above shows you how I got it working (I think supplicant didn't work for me either).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Good live, bad install: fluxflux eee 2008 09 on Eee 901 Mecharuva Linux - Laptop and Netbook 1 11-28-2008 10:18 PM
LXer: ASUS Eee PC 901 LXer Syndicated Linux News 0 08-28-2008 03:50 AM
Asus Eee 901 linux problem sinewofcrab Linux - Newbie 4 08-13-2008 09:06 PM
LXer: Should you buy an Asus Eee 901 PC? LXer Syndicated Linux News 0 06-23-2008 04:50 AM
LXer: New Asus Eee PC 901 with Atom due late June, but where is the Eee 1000H? LXer Syndicated Linux News 0 06-20-2008 05:20 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration