-   Slackware (
-   -   Slackware + Wicd (

sparker 09-12-2007 05:50 PM

Slackware + Wicd
Does anyone have Wicd working in Slackware 12.0? I have put all the files that come with it in their correct places and the Wicd item appears under the menu in KDE but clicking it does not open the application.

I have tried to activate the system tray icon but to no avail. Do I need to be disabling something or does it just not function properly in Slackware?

cavalier 09-12-2007 06:12 PM

Have you tried running the executable from a terminal window? It might give you info about missing libraries or the like...

sparker 09-12-2007 09:10 PM

Okay I get this:

bash-3.1# ./
Traceback (most recent call last):
  File "./", line 5, in <module>
    import gtk
ImportError: No module named gtk

I installed everything with slack so it had gtk in it. This program is written in python.

Any ideas?

nawcom 02-25-2008 06:44 PM

let me know if you still need help. sounds like you didnt start up the wicd daemon "/opt/wicd/" at boot time. if you use slackware you will also have to replace the with a modified one, for wicd is setup to use dhclient, while slackware uses dhcpcd to update the resol.conf realtime. oh wells, email me if you still need the help.

XGizzmo 02-25-2008 08:31 PM


Originally Posted by sparker (Post 2890237)
Okay I
I installed everything with slack so it had gtk in it.

You need pygtk and maybe dbus-python
Everything you need can be found at

rworkman 02-25-2008 10:05 PM


Did you get my mail about this? I saw your modified with dhcpcd in it, and I'd like to discuss it further with you. Please contact me -- rworkman AT

sparker 02-25-2008 11:15 PM

Wow, old thread. I have stopped using a network manager completely and just stick to a simple shell script. But, thanks for the offer to help anyways.

rworkman 02-25-2008 11:26 PM

I wish I'd seen this thread back in September.
You just might want to give it a try with nawcom's modified script - it's working well here, and I think that's going to part of a larger changeset going upstream to the wicd devs.

sparker 02-26-2008 10:38 AM

I'll probably set it up on my laptop, since I do move around quite a bit. It might be simpler than adding to my script.

em21701 02-26-2008 03:23 PM

I have a similar problem with wicd, I started the daemon manually to make sure it works before adding it to the boot sequence when I try to start wicd from the command line I get :

Missing GTK and Aborting

I installed pygtk and dbus-python prior to compiling wicd, all of which I downloaded from I should already have GTK installed from the Slack install correct? What am I missing?


sparker 02-26-2008 09:02 PM

Did you do a full install? Otherwise, the only thing I can think of is you might need to upgrade to a newer version of gtk.

em21701 02-27-2008 06:02 AM

This is a brand new full installation of Slack 12. Installed a few days ago, downloaded about a week ago.

sparker 02-27-2008 04:50 PM

Do you start the wicd service? /etc/rc.d/rc.wicd start

I have it working fine and the only thing I did was upgrade gtk from current, but that was for a different purpose.

em21701 02-27-2008 04:54 PM

Yes I did start the service, I should have mentioned that. Does slack 12 ship with an older version of GTK? Why wouldn't wicd throw a build error if the GTK version was too old?

truthfatal 02-27-2008 06:19 PM

I just built this yesterday and have no problem with it in a relatively stock Slack 12...

All times are GMT -5. The time now is 07:26 PM.