-   Slackware (
-   -   Slackware startx not working (

spaghettios 08-09-2012 06:47 AM

Slackware startx not working
Google hasn't returned anything relevant for this.

Fresh install of Slackware 13.37, when i enter startx the prompt basically does nothing, it doesn't return an error message at all it just goes to another prompt line.


root@darkstar:~# startx

Am i missing something?

I've tried it as root, as well as created a new user to try it. Both no joy.
Any ideas?

cynwulf 08-09-2012 06:48 AM

Firstly, why are you attempting to startx as root?

spaghettios 08-09-2012 06:53 AM

Because i tried as user. It should work as root as well. That is not the issue.

cynwulf 08-09-2012 07:00 AM

Do startx again as a normal user

$ startx
Post some outputs

$ cat ~/.xsession-errors

$ grep 'WW\|EE' /var/log/Xorg.0.log

spaghettios 08-09-2012 07:22 AM


Originally Posted by caravel (Post 4749822)
Post some outputs

$ cat ~/.xsession-errors

$ grep 'WW\|EE' /var/log/Xorg.0.log

hmmm in both of those it just returns No such file or directory


cat: /home/rp/.xsession-errors: No such file or directory
grep: /var/log/Xorg.0.log

I definitely had all of the XWindows stuff selected on install, the only thing left out was the foreign languages pack.

wigry 08-09-2012 08:29 AM

There is specific Slackware are in this forum. As Slack is quite special distro, this newbie section is not the best place to find solutions.

however you can go to /var/log/packages and see there, what packages are installed? how many "xorg-server-*" packages are there? You really need to install basically everything under x and selectively under xap (or all if HD space permits). The language packages you are referring to are probably the KDE ones.

sycamorex 08-09-2012 08:50 AM

Please do not startx as root.

Was it a full install?

It shouldn't happen on a fresh install, but make sure there's a desktop environment / window manager selected in xwmconfig.

spaghettios 08-09-2012 12:36 PM

OK thanks for your input everyone, this definitely shouldn't happen with a fresh install so i must have done something wrong in setup, will start over again. I just wanted to check like i wasn't missing something obvious. Will post to slackers forum in future.


Tinkster 08-09-2012 07:47 PM

Moved: This thread is more suitable in <SLACKWARE> and has been moved accordingly to help your thread/question get the exposure it deserves.

ReaperX7 08-09-2012 08:53 PM

You actually can start an X session in root, but beware that as root your system is more vulnerable, so try not to mess around as a root user unless absolutely needed. Root is for system administration, not normal work. If you do need root access just use the "sudo" or "su" tools to run things as with root privileges or as root through user.

You probably have an installation that may or may not have everything installed from the installation disk if that's the route you went. You could try to navigate to /etc/slackpkg and see if the "mirrors" file is editable with the text editor "nano", uncomment a choice file server, save the file and the run slackpkg with upgrade-all and install-new to see if it can remote install and repair your system.

TommyC7 08-09-2012 09:16 PM

Check if your user(s) are in the correct groups?

dxtrpn 08-09-2012 09:44 PM

For fun, you could've tried booting into runlevel 4 [via /etc/inittab]... my guess is X was not installed.

TommyC7 08-09-2012 09:50 PM

Wouldn't make sense, [X] contains xinit which is what what contains /usr/bin/startx. He didn't get "startx: No such file or directory", but it is likely he hasn't done a full install, or isn't a part of the necessary groups since startx generally works out of the box.

ReaperX7 08-09-2012 09:51 PM

The groups for the user(s) should include the "video" group in order to access x11 correctly, which is normally a default, however he ran startx as root which has full permissions systemwide.

Running slackpkg or even pkgtool to check the packages should at least see if packages were or weren't installed.

Tinkster 08-09-2012 11:00 PM

If X wasn't installed a "startx" would yield:
bash: startx: command not found


All times are GMT -5. The time now is 04:49 AM.