LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-02-2010, 09:36 AM   #16
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Debian
Posts: 8,577
Blog Entries: 31

Rep: Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197

Firstly /etc/rc.d/rc.ntpd status is not reliable; it checks for the existence of the PID file, not that an ntpd process is running.

Secondly how is ntpq working now? The ntpd -d output you posted ended with a panic_stop after not very long -- a lot less than the day mentioned in the OP.

If ntpq is working OK now (as your last post suggests), let's see if there are any illuminating messages from ntpd -d around the time it stops.
 
Old 07-02-2010, 09:39 AM   #17
tennis_slacker
Member
 
Registered: Apr 2008
Location: Idaho
Distribution: Slackware
Posts: 92

Original Poster
Rep: Reputation: 17
I'm beginning to wonder now ...

Is the hardware clock maintained by the cmos battery???

Maybe I need a new battery???
 
Old 07-02-2010, 09:41 AM   #18
michaelk
Moderator
 
Registered: Aug 2002
Posts: 20,446

Rep: Reputation: 3560Reputation: 3560Reputation: 3560Reputation: 3560Reputation: 3560Reputation: 3560Reputation: 3560Reputation: 3560Reputation: 3560Reputation: 3560Reputation: 3560
Yes, the hardware clock is powered by the CMOS battery when the computer is off.
 
Old 07-02-2010, 09:51 AM   #19
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Debian
Posts: 8,577
Blog Entries: 31

Rep: Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197
Quote:
Originally Posted by tennis_slacker View Post
Is the hardware clock maintained by the cmos battery???
Yes but the hardware clock is used only to keep time while the computer is not running. In the OP you wrote "If I restart ntpd everything works perfectly for a day. Then the synchronization stops". Presumably that is for a day when ntpd is running, that implies the computer is running. Please clarify.
 
Old 07-02-2010, 09:52 AM   #20
tennis_slacker
Member
 
Registered: Apr 2008
Location: Idaho
Distribution: Slackware
Posts: 92

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by catkin View Post
Firstly /etc/rc.d/rc.ntpd status is not reliable; it checks for the existence of the PID file, not that an ntpd process is running.
I've learned this now. What's the best way to check that it is running?

Quote:
Originally Posted by catkin View Post
Secondly how is ntpq working now? The ntpd -d output you posted ended with a panic_stop after not very long -- a lot less than the day mentioned in the OP.
You obviously are much more knowledgable than I. I just assummed that since ntpq -p works and the clock is syncing that everything is running and working.

Quote:
Originally Posted by catkin View Post
If ntpq is working OK now (as your last post suggests), let's see if there are any illuminating messages from ntpd -d around the time it stops.
I'll try to check every hour or so to see when something starts drifting. Thanks.
 
Old 07-02-2010, 09:53 AM   #21
tennis_slacker
Member
 
Registered: Apr 2008
Location: Idaho
Distribution: Slackware
Posts: 92

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by catkin View Post
Yes but the hardware clock is used only to keep time while the computer is not running. In the OP you wrote "If I restart ntpd everything works perfectly for a day. Then the synchronization stops". Presumably that is for a day when ntpd is running, that implies the computer is running. Please clarify.
This is my server machine so it is running 24/7.
 
Old 07-02-2010, 09:56 AM   #22
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 3,719

Rep: Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067Reputation: 2067
Quote:
Originally Posted by tennis_slacker View Post
Oops. Sorry. Here's the output from ntpd -d:

Code:
addto_syslog: line 31 column 19 syntax error, unexpected T_EOC, expecting T_Ipv4_flag or T_Ipv6_flag or T_String
addto_syslog: syntax error in /etc/ntp.conf line 31, column 19
Finished Parsing!!
So what's wrong with line 31 of /etc/ntp.conf?
 
Old 07-02-2010, 10:02 AM   #23
tennis_slacker
Member
 
Registered: Apr 2008
Location: Idaho
Distribution: Slackware
Posts: 92

Original Poster
Rep: Reputation: 17
I don't know, I saw that. I initially thought I somehow screwed something up in the file (because I was making changes trying to get ntp to work) so I reinstalled ntp to get a fresh config file, but still got the same error message. I never touched line 31 it's the default config line:

Code:
multicastclient                 # listen on default 224.0.1.1
Looks fine to me, I don't know.
 
Old 07-02-2010, 11:53 AM   #24
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Debian
Posts: 8,577
Blog Entries: 31

Rep: Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197
Quote:
Originally Posted by tennis_slacker View Post
You obviously are much more knowledgable than I. I just assummed that since ntpq -p works and the clock is syncing that everything is running and working.
Not so! I have no idea what the "panic_stop" message truly signifies but it doesn't sound good! That's why I asked in ntpq was still working OK (and should have asked if ps -ef | grep ntpd | grep -v grep showed the daemon process still running)
 
Old 07-02-2010, 12:07 PM   #25
GazL
LQ Guru
 
Registered: May 2008
Distribution: CRUX
Posts: 5,548
Blog Entries: 14

Rep: Reputation: 3395Reputation: 3395Reputation: 3395Reputation: 3395Reputation: 3395Reputation: 3395Reputation: 3395Reputation: 3395Reputation: 3395Reputation: 3395Reputation: 3395
Mine gave that same syntax error too on the default ntp.conf.
I borrowed this one which I think came from gentoo's wiki:
Code:
# /etc/ntp.conf

restrict default kod nomodify notrap nopeer noquery
restrict -6 default kod nomodify notrap nopeer noquery
restrict 127.0.0.1
restrict -6 ::1

# Timeserver(s) to (ab)use
server  ntp.virginmedia.com
server  ntp2c.mcc.ac.uk  

# Backup Timeserver (local clock)
server  127.127.1.0     # local clock
fudge   127.127.1.0 stratum 10

driftfile /etc/ntp/drift
Also, in the past I've found adding the '-x' option to the command in rc.ntpd has improved reliability on my box. It seems counter intuitive, but allowing the larger skew did help. Might be worth trying if nothing else works for you.
 
Old 07-02-2010, 12:29 PM   #26
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Debian
Posts: 8,577
Blog Entries: 31

Rep: Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197Reputation: 1197
Quote:
Originally Posted by tennis_slacker View Post
Code:
multicastclient                 # listen on default 224.0.1.1
According to http://www.eecis.udel.edu/~mills/ntp...ulticastclient there must be an address after multicastclient.

On my Slackware 13.1 system, the as-installed /etc/ntp.conf has the same line (multicastclient # listen on default 224.0.1.1) but it is on line 24 ???

Code:
c@CW9:~$ ls -l /var/log/packages/ntp-4.2.6p1-i486-1
-rw-r--r-- 1 root root 14176 2010-06-01 21:59 /var/log/packages/ntp-4.2.6p1-i486-1
c@CW9:~$ /usr/sbin/ntpd --version
ntpd - NTP daemon program - Ver. 4.2.6p1
 
Old 07-02-2010, 06:02 PM   #27
tennis_slacker
Member
 
Registered: Apr 2008
Location: Idaho
Distribution: Slackware
Posts: 92

Original Poster
Rep: Reputation: 17
Ok, the system clock is beginning to get out-of-sync from the hwclock and the correct time. The hwclock is still correct:

Code:
# hwclock -r
Fri 02 Jul 2010 04:57:08 PM MDT  -0.683321 seconds
# date
Fri Jul  2 15:34:02 MDT 2010
Code:
# ps -ef | grep ntpd | grep -v grep
root     17050     1  0 08:26 ?        00:00:00 /usr/sbin/ntpd -g -p /var/run/ntpd.pid
Code:
# ntpq -p
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
 LOCAL(0)        .LOCL.          10 l   7h   64    0    0.000    0.000   0.000
+mighty.poclabs. 38.117.195.101   4 u  919 1024  377   68.488    1.523   2.497
 pool-test.ntp.o 66.220.9.122     2 u   42 1024  377   36.782  4986753 4986751
*clock-b.develoo 164.67.62.212    2 u  927 1024  377   44.729   -1.176   0.602
+69.50.219.51    192.43.244.18    2 u  997 1024  377   57.931    0.852   0.444
 
Old 07-02-2010, 06:08 PM   #28
tennis_slacker
Member
 
Registered: Apr 2008
Location: Idaho
Distribution: Slackware
Posts: 92

Original Poster
Rep: Reputation: 17
Strange stuff going on, the hwclock is now off and the time is now off and ntpq seems to not be using a time server.

Code:
# ps -ef | grep ntpd | grep -v grep
root     17050     1  0 08:26 ?        00:00:00 /usr/sbin/ntpd -g -p /var/run/ntpd.pid
Code:
# hwclock -r
Fri 02 Jul 2010 05:13:02 PM MDT  -0.417046 seconds
# date
Fri Jul  2 15:43:03 MDT 2010
Code:
# ntpq -p
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
*LOCAL(0)        .LOCL.          10 l   23   64    7    0.000    0.000   0.001
 mighty.poclabs. 38.117.195.101   4 u  204 1024  377   68.488    1.523 1884813
 pool-test.ntp.o 66.220.9.122     2 u  371 1024  377   36.782  4986753 4986751
 clock-b.develoo 164.67.62.212    2 u  184 1024  377   45.297  4986750 4986751
 69.50.219.51    192.43.244.18    2 u  244 1024  377   58.708    0.520 1884815
 
Old 07-02-2010, 06:39 PM   #29
tennis_slacker
Member
 
Registered: Apr 2008
Location: Idaho
Distribution: Slackware
Posts: 92

Original Poster
Rep: Reputation: 17
And ... the system is down:

Code:
# ps -ef | grep ntpd | grep -v grep
#
# ntpq -p
ntpq: read: Connection refused
I've looked in the logs: debug, messages, and syslog but don't see anything since 8am this morning related to ntpd.
 
Old 07-02-2010, 06:49 PM   #30
tennis_slacker
Member
 
Registered: Apr 2008
Location: Idaho
Distribution: Slackware
Posts: 92

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by catkin View Post
According to http://www.eecis.udel.edu/~mills/ntp...ulticastclient there must be an address after multicastclient.
I've tried commenting out the multicastclient line, but the system still went down. I could try again.

Quote:
Originally Posted by catkin View Post
On my Slackware 13.1 system, the as-installed /etc/ntp.conf has the same line (multicastclient # listen on default 224.0.1.1) but it is on line 24 ???
Mine is on line 31 because I've inserted the server x.x.x lines into the config file.

I'm thinking of reinstalling or trying to install all the package groups. When I installed I excluded some package groups like [kde] and [x] because I was installing a server not a desktop. Maybe I missed some package that something needs.

I don't know ... I'm just throwing out wild guesses at this point. I've never seen anything like this.

Last edited by tennis_slacker; 07-02-2010 at 06:50 PM. Reason: mistyped line 31 not 21
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NTP time sync with windows 2000 AD time csghosh Linux - Enterprise 7 02-24-2012 03:46 PM
NTP sync time issue... smartyshan Linux - Server 5 06-23-2009 02:37 AM
NTP sync up time sidra Linux - Networking 1 09-27-2007 09:07 PM
Sync KDE/System Time w/ NTP carlosinfl Linux - General 6 03-15-2006 03:37 PM
ntp time sync eyewittness Linux - Networking 2 08-11-2004 09:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration