-   Slackware (
-   -   Slackware Samba/SWAT inadequacy/bug (

dchmelik 01-20-2013 12:39 AM

Slackware Samba/SWAT inadequacy/bug
I would like all general and Slackware questions to be answered first: my question below is not very important to me. I guess SWAT is part of Slackware, and though I do not want to bother Slackware developers about it, I wanted to point out and perhaps discuss this.

A couple years ago I asked here how to set up shared 'guest' folders with Samba and lately retried SWAT, despite that it forces password usage, which I hate. I also did on OpenBSD, which worked immediately. I used the exact same type of configuration (only the path was different,) which I redid and checked many times, on Slackware, and it never worked (despite that the path was '/home/u,' owned by 'u,' and had permissions 777... it was even a user-owned folder within one owned by root that I shared on OpenBSD) Many solutions are described on the 'net, and the simplest may be to add 'guest only = Yes' under in a smb.conf share configuration. That worked, so I marked the original thread solved. However, it seems SWAT (for Samba 3.6.6) on OpenBSD 5.2, etc., works to set up guest folders, and but SWAT (for Samba 3.6.8) on Slackware 14 (and likely earlier) does not. Is there any way to do this in Slackware with SWAT or if I ever do a clean installation?

ponce 01-20-2013 03:26 AM

you can try this.

dchmelik 01-20-2013 03:36 AM

Perhaps my question was ambiguous--though 'this' would arguably refer to the last idea, which was using SWAT--so I restated above. I am sure the thread you mentioned has useful info, but as I explained, I solved my problem with a one-line addition rather than any long solution maybe like in that thread.

allend 01-20-2013 06:35 AM

I once used SWAT on Samba but SWAT swatted mysmb.conf and all my carefully crafted comments. So I swatted SWAT and that bug has never reoccurred.

dchmelik 01-31-2013 12:20 AM

That is unfortunate, allend... I have never seen it remove my additions, and I do not do complicated things or comments with it, so it is good enough for me.

All times are GMT -5. The time now is 07:13 AM.