-   Slackware (
-   -   slackware + postfix + cyrus-sasl (not using system users) (

zux 03-05-2009 07:08 AM

slackware + postfix + cyrus-sasl (not using system users)
so i compiled postfix with cyrus-sasl support, everything seems t0 be working from the postfix side (i'm now only talking about relaying mail)
here's the part from

smtpd_sasl_auth_enable = yes
smtpd_recipient_restrictions =
broken_sasl_auth_clients = yes

smtpd_sasl_path = smtpd

and this is how /usr/lib/sasl2/smtpd.conf looks like:

pwcheck_metod: auxprop
mech_list: PLAIN LOGIN

i also have links to that file from /etc/postfix/sasl2 and /etc/sasl2/ (made those while looking for answers)

an i ran saslauthd like this:

saslauthd -a shadow
but i get these errors in /var/log/maillog:

postfix/smtpd[18617]: warning: SASL authentication failure: Could not open /etc/sasldb2: gdbm_errno=3
my guess is that potfix isn't even looking at that /usr/lib/sasl2/smtpd.conf file, therefor using some defaults.
i have also tried putting the full path in this option:
smtpd_sasl_path = smtpd
but that didn't help.
i'm stuck :(

zux 03-06-2009 02:50 AM

if someone has any ideas please post. I can give more info if it's no t enough here

mRgOBLIN 03-06-2009 06:35 AM

I think the directories are set at build-time for postfix


(for Cyrus SASL version 2.1.x):

    % make tidy # if you have left-over files from a previous build
    % make makefiles CCARGS="-DUSE_SASL_AUTH -DUSE_CYRUS_SASL \
        -I/usr/include/sasl" AUXLIBS="-L/usr/lib -lsasl2"

zux 03-06-2009 08:39 AM

well i compiled pstfix with exactly these options:

make makefiles CCARGS="-DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl" AUXLIBS="-L/usr/lib -lsasl2"
followed that same manual.
thought that it might be specific to slackware implementation of cyrus-sasl, also i don't see how.

All times are GMT -5. The time now is 06:55 PM.