LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Slackware on a netbook? (https://www.linuxquestions.org/questions/slackware-14/slackware-on-a-netbook-727527/)

Unr3a164 05-25-2009 06:34 PM

Quote:

Originally Posted by kadeck (Post 3550842)
Hi Unr3a164,

is the internal microphone works on your s10 with slackware?, since it's the only problem i have under ubuntu


I will definitely let you know once I get it installed. I have gotten my internal mic working under Ubuntu. What version of Ubuntu are you on?

kadeck 05-26-2009 01:30 AM

I am using Jaunty Jack now (2.6.28-11-generic).
Finally I'am able to make the internal mic works. What I did was upgrade alsa using the script here.
http://ubuntuforums.org/showthread.p...10#post6589810

seems to work on kernel 2.6.27 as well (tried on Linux-Mint felicia). I think it should work on slackware too.

enine 06-04-2009 08:18 AM

I installed slackware 12.2 on an ASUS eeePC 900HA. Wireless works, video was detected fine but fonts were all set to 16 point so I was able to shring all but one down, the one I can't seem to control is the main system font used for dialog boxes and non kde apps like firefox so the menus and text are really big in those.
Sound works but the mixer doesn't seem to allow muting nor will it save the volume between sessions, always defaults to max.
My printer won't install either but thats not related to it being a netbook, seems to be a slackware specific issue.

enine 06-04-2009 09:38 AM

hmm, startx -- -100dpi fixes it for one session, wonder where I set that to make it the default

happybear 06-04-2009 11:26 PM

Quote:

Originally Posted by enine (Post 3562922)
hmm, startx -- -100dpi fixes it for one session, wonder where I set that to make it the default

try creating an alias and put it in your .bashrc, alias startx='startx -- -100dpi' ?

enine 06-04-2009 11:28 PM

I should have been more specific, I have it start at init 4 so I'm never typing startx, where can I set that dpi so x always uses it,I found a couple web sites listing config files and tried them but it didn't work?

atters 07-27-2009 09:11 PM

Slackware 12.2 runs beautifully on my Acer Aspire One AOA150.

Installation was a breeze, as always, and configuration is easy easy easy.

mscole 07-27-2009 10:18 PM

I just bought an Acer Aspire One that came with XP pre-installed. I shrank the XP partition and installed Slack 12.2 as a dual boot system. I see that two or three people posting to this thread are running Slack on the aao. How did you get wifi working? This is my first attempt at using wifi so I am somewhat in the dark. I have searched the threads here and read a number of things on the Web about Slackware, wifi, and the aao, but I don't have a clear idea where to start. Also, lspci does not list any wireless device. Mike.

atters 07-27-2009 11:01 PM

Quote:

Originally Posted by mscole (Post 3622389)
Also, lspci does not list any wireless device.

Mike,
Which model AAO do you have? For my AOA150, lspci (when run as root) shows the following entry:

03:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

mscole 07-28-2009 04:40 PM

My mistake, lspci shows that same controller in mine (Ahteros AR242x). The "ethernet controller" description threw me off. I don't see a model number on the computer's case.

atters 07-28-2009 05:27 PM

No problem, here are the next steps:

Verify that ath5k appears when you run 'lsmod'. (if not do 'modprobe ath5k' to load it)
Verify that wlan0 appears when you run 'iwconfig' (as root).

WPA2 wireless connection:
1 - Download, compile and install wpa_supplicant
2 - Edit your 'wpa_supplicant.conf' file to match your network environment
3 - Do a 'chmod +x /etc/rc.d/rc.wireless' to enable the script to execute during boot
4 - Edit '/etc/rc.d/rc.inet1.conf' starting at line 50, Uncomment at least "IFNAME" and "WLAN_WPA". (Uncomment the "DHCP" line if you need it)
5 - (optional) Edit '/etc/rc.d/rc.wireless' and comment out lines 190-196 to disable the Set Nickname operation error.
6 - Reboot and enjoy.

If you use KDE, you might consider KWiFiManager to keep an eye on the connection. Run it as root to use all it's features or to view all networks the card can pick up.

mscole 07-28-2009 11:39 PM

atters, I tried the steps you described, and I think I am close, but when I boot I get the following error message from the kernel:
Failed to connect to wpa_supplicant -- wpa_ctrl_open: No such file or directory
I could not find a reference to this file in wpa_supplicant.conf or rc.wireless or rc.inet1.conf, so I don't know where the problem is. Mike.

mscole 07-29-2009 12:07 AM

I forgot to mention, I used the version of wpa_supplicant that came with the slackware 12.2 installation (0.5.10-i486-1). Do I need to download a newer version?

slackissme 07-29-2009 04:00 AM

slackware-current
 
TOSHIBA Satellite L510-S401 TOSHIBA Satellite L510-S401 - slackware - current , working

trainee 08-10-2009 09:29 PM

I am considering buying one netbook cause my laptop is dying (overheating easily). So I read around. I was considering an Acer Aspire and I read this review on newegg

http://www.newegg.com/Product/Produc...82E16834115584

http://www.newegg.com/Product/Produc...82E16834115584

The review says that it won't be able to display flash video like youtube or hulu.com properly.

Since the laptop is my only source of entertainment so it does concern me a lot.

Does any of you have the same problem?

Thanks in advance,

And by the way, I saw that almost all review about Slackware on a Netbook are positive, but any head-up about the problems will be very appreciated.


All times are GMT -5. The time now is 03:58 AM.