LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-09-2013, 09:02 AM   #1
Indra777
LQ Newbie
 
Registered: Jul 2013
Posts: 17

Rep: Reputation: Disabled
Slackware not booting


Hello,

I have just installed Slackware Linux and I encounter this problem:

While booting the system hangs while trying to load udev daemon. I have repeated the install a second time and the problem persists.
There was no any issue during the install, but at the and of the install the system was not rebooting with CTRL+ALT+DEL and not even with $shutdown -r now
Otherwise the install went absolutely smooth.
 
Old 07-09-2013, 09:11 AM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,828

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Quote:
$shutdown -r now
You need root privileges for this command to work on a normal install. You can use 'su -' and enter the root password, or set up sudo, which is not set up by a normal install to do anything.

What desktop are you using? CRTL+ALT+DEL affect on the system may vary depending on the desktop and how the hot key combinations are mapped. On my Slack 14, 64 bit system, running XFCE, that combination just locks my keyboard.
 
Old 07-09-2013, 09:17 AM   #3
Indra777
LQ Newbie
 
Registered: Jul 2013
Posts: 17

Original Poster
Rep: Reputation: Disabled
Yes I tried sudo but it did not work, so i had to press the reset button. Anyways, the system is not booting because of some issue with udev daemon even if the install was clean.

Thanks.
 
Old 07-09-2013, 09:27 AM   #4
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,828

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Post the error messages you get, possibly then we can help.

Sudo will not do anything until you configure it. You have to give the regular user the ability to use restricted commands.

You have to edit the sudoers file with the command 'visudo' as root user. If you search the forum you will find examples of various ways you can set this up.

Last edited by camorri; 07-09-2013 at 09:32 AM.
 
Old 07-09-2013, 10:00 AM   #5
Indra777
LQ Newbie
 
Registered: Jul 2013
Posts: 17

Original Poster
Rep: Reputation: Disabled
There is no error messages. It just hangs while booting:

----------------------------------
starting udevd /sbin/udevd --daemon
5.433665 udev[1931]: starting version 182
Trigger udev events: /sbin/udevadm trigger --adm=add
--------------------------------------------------

here it stops and nothing else happens.
 
Old 07-09-2013, 10:19 AM   #6
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,828

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Can you post the version of Slack you are using? 32 bit or 64 bit.

Did you do a full install?

What hardware are you running this on? Make model please.

This is probably going to take the expertise of someone with more experience than I. Never had a problem like a hang on the boot process, with no errors. Just one thought, if you have any extra hardware plugged in, unplug it, and give it another boot try, and see if that helps, or changes the symptoms.
 
Old 07-09-2013, 10:29 AM   #7
Indra777
LQ Newbie
 
Registered: Jul 2013
Posts: 17

Original Poster
Rep: Reputation: Disabled
Yes of course, and thank you for your interest:

I have installed Slackware 14.0 64 bits.
My computer is an assembled one. The hardware is basically:

32Gb Corsair Vengeance RAM (in 4 slots)
MotherBoard: ASUS P9X79 PRO
CPU: intel six core i7 3930k
Graphic Card: GeForce GTX 550Ti
+
Western digital hd 1TB
2*SSD (256+64)

No problem at all running linux Mint. The only additional hardware plugged are screen, keyboard and mouse.
 
Old 07-09-2013, 10:40 AM   #8
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,119

Rep: Reputation: 518Reputation: 518Reputation: 518Reputation: 518Reputation: 518Reputation: 518
Forgive this foolish question. Did you install lilo to the MBR?
 
Old 07-09-2013, 10:44 AM   #9
Indra777
LQ Newbie
 
Registered: Jul 2013
Posts: 17

Original Poster
Rep: Reputation: Disabled
hitest,
Is not a foolish question. I did not install it because I'm booting from GRUB 2 which is installed in another drive. After Installing Slackware without LILO i runned $sudo update-grub in Mint so I got an entry for slackware on the GRUB 2 menu.
Is anything wrong with that? Just today I asked in another thread how to install Slackware along Mint and that is the answer I got.
 
Old 07-09-2013, 10:50 AM   #10
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: Slackware, Slackware64
Posts: 1,489

Rep: Reputation: 662Reputation: 662Reputation: 662Reputation: 662Reputation: 662Reputation: 662
I know there's some "déjà vu" to it, but this hardware looks like it needs an initrd and a generic kernel to boot correctly. Which means chroot into the freshly installed Slackware system before the initial reboot. Am I the only one with this problem on Intel-based hardware?
 
Old 07-09-2013, 10:54 AM   #11
Indra777
LQ Newbie
 
Registered: Jul 2013
Posts: 17

Original Poster
Rep: Reputation: Disabled
Kickinovak,
What you are telling me is to install again and run chroot command before rebooting?
 
Old 07-09-2013, 12:35 PM   #12
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,828

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
What kernel are you using? Huge, or generic? Huge does not need an initrd on most systems, generic does.
 
Old 07-09-2013, 01:10 PM   #13
Indra777
LQ Newbie
 
Registered: Jul 2013
Posts: 17

Original Poster
Rep: Reputation: Disabled
During the installation process I did not choose any kernel.
How can I know that?
 
Old 07-09-2013, 01:19 PM   #14
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,828

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Open a command prompt, change directory to /boot. Do a 'ls' and look for the entry vmlinuz. It is a symlink, pointing to your kernel. So if you do a 'ls -l vmlinuz' the output will point to the kernel.

If you have not changed lilo, then this is the kernel that is trying to boot. if you have edited lilo, could you post the /etc/lilo.conf file and we can tell from there what kernel you are trying to boot.
 
Old 07-09-2013, 01:21 PM   #15
Indra777
LQ Newbie
 
Registered: Jul 2013
Posts: 17

Original Poster
Rep: Reputation: Disabled
Ok, perfect.

It's huge: vmlinuz -> vmlinuz-huge-3.2.29
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual Booting Slackware, best Slackware based Distro, and Partitioning...? Novatian Slackware 6 06-07-2010 08:09 PM
Booting Slackware 12.0 n3m0k54 Slackware 4 07-18-2008 03:52 PM
Booting Slackware k2skier Slackware - Installation 3 12-30-2004 01:49 AM
Booting up slackware hylke Linux - Newbie 4 09-30-2004 10:09 AM
Booting into slackware 9.1 looneytunes Linux - Newbie 4 04-18-2004 04:48 PM


All times are GMT -5. The time now is 08:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration