LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-27-2004, 01:56 PM   #1
TCasp77
LQ Newbie
 
Registered: Oct 2003
Posts: 13

Rep: Reputation: 0
Slackware Network prob...Close to solving


OK, I think I am close, but I am not sure what the final ingredient is:

I just installed Slack 9.1, and I am trying to configure my network. I have an HP Pavillion Laptop, with a National Semiconductor card, connectied to a router to a cable modem. Slack recognizes my card at boot, reading, eth0: link up. When I run lsmod, the card is on there, and when I run ifconfig eth0 up, it lists my eth0 setup BUT, it doesn't appear to be assigning me an ip address. Here is the output of ifconfig eth0:

Code:
LinK encap: Ethernet HWaddr 00:0D:9D:C9:94:0E
BROADCAST MULTICAST MTU: 1500 Metric: 1
RX packets:9 errors:0 dropped:0 overruns:0 frame:0
TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
collision:0 txqueuelen:100
RX bytes:1017 (1017.0 b) TX bytes:8260 (8.0 Kb)
Interrupt:11 Base address:0xc000


I have tried to run netconfig and dhcpcd, but it hasn't helped. When I run ifconfig eth0 up, my eth0 gets displayed, but then if I run dhcpcd eth0, afterwards, ifconfig then displays only LO again. Any suggestions? Thanks a lot!! Also, when I boot, it brings up the eth0 interface and says link up: remaining active for wake-on LAN.
 
Old 02-27-2004, 02:45 PM   #2
bnice
Member
 
Registered: Feb 2004
Location: Sacramento, CA
Distribution: Slack 9.1, slackware-current
Posts: 284

Rep: Reputation: 30
This will probably help.
 
Old 02-27-2004, 03:17 PM   #3
TCasp77
LQ Newbie
 
Registered: Oct 2003
Posts: 13

Original Poster
Rep: Reputation: 0
Well, it sounds like I have the exact same problem as that guy did, but that still didn't work. AAAAAHHHHHHHHHHHHHHHHHHH!!!!!!!!
 
Old 02-27-2004, 07:26 PM   #4
jarib
Member
 
Registered: Jun 2003
Location: British Columbia
Distribution: Slackware
Posts: 112

Rep: Reputation: 15
Since you're using a router you might have better luck assigning a static ip
 
Old 02-27-2004, 07:48 PM   #5
SailingGypsy
Member
 
Registered: Jan 2004
Location: Florida, USA
Distribution: Slackware, SuSE
Posts: 42

Rep: Reputation: 15
Like jarib says, give yourself a staic IP and is less headaches than DHCP.

Assign the machines an IP address of your choice from the private range (102.168.xxx.xxx) and set the router as your default Gateway. For the Gateway, look in the router's documentation and look for its default IP address and use that. (should be something along the lines of 198.162.0.1 or 192.168.1.1, etc. Each brand uses a diff default) If you have no default in the manual/docs, just assign 198.168.0.1 to the router and tell Slack to use that as the Gateway. After that you're set.

HTH
Best regards...
 
Old 02-27-2004, 07:55 PM   #6
bnice
Member
 
Registered: Feb 2004
Location: Sacramento, CA
Distribution: Slack 9.1, slackware-current
Posts: 284

Rep: Reputation: 30
Quote:
Assign the machines an IP address of your choice from the private range (102.168.xxx.xxx)

err. typo? S/B 192.168.xxx.xxx

actually, to put yourself on the same subnet as router s/b 192.168.0.xxx
 
Old 02-27-2004, 07:59 PM   #7
SailingGypsy
Member
 
Registered: Jan 2004
Location: Florida, USA
Distribution: Slackware, SuSE
Posts: 42

Rep: Reputation: 15
Definitely a TYPO!!!!! LOL thanks for the catch . Fatter fingers than usual this evening

Regards...
 
Old 02-27-2004, 08:06 PM   #8
TCasp77
LQ Newbie
 
Registered: Oct 2003
Posts: 13

Original Poster
Rep: Reputation: 0
Thanks for the reply's. I will attempt your advice and check back here. Also, is it possible there is a problem because I have both pcmcia and the regular network both installed? Should I get rid of the pcmcia stuff? Thanks.
 
Old 02-27-2004, 08:27 PM   #9
TCasp77
LQ Newbie
 
Registered: Oct 2003
Posts: 13

Original Poster
Rep: Reputation: 0
AWSOME!! Thanks for the help. A few quick points/questions though:

- I think what threw me off was the fact that the first time I connected the computer to the router,, I was installing Gentoo, and the connection worked without a hitch, via DHCP. A few days later, due to some problems, I had to do a re-install, and since then, the ethernet connection has not worked until now(with the Static IP) That's basically the reason I didn't try it with Static, although now, I guess that was foolish. Well, I restarted and all is still good, so hopefully I will be good from here.

- Immediately after I changed the settings, I noticed on my Desktop, where I am using this forum, running WinXP, it suddenly said there is no connection, and I got worried, but after closing IE and reopening it, it works now. Any ideas why this is? Did my settings in Slack affect my router, which in turn affected my connection on my desktop?

Anyways, thanks a lot for the help. It is very much appreciated!! Now, do I dare say that I am about to try and configure wireless??? Here we go.....
 
Old 02-27-2004, 08:41 PM   #10
jarib
Member
 
Registered: Jun 2003
Location: British Columbia
Distribution: Slackware
Posts: 112

Rep: Reputation: 15
You might have used the ip assigned to xp. You could assign a static ip to xp through network connections and tcp/ip properties just to prevent xp from grabbing the ip assigned to slack.
 
Old 02-27-2004, 09:06 PM   #11
TCasp77
LQ Newbie
 
Registered: Oct 2003
Posts: 13

Original Poster
Rep: Reputation: 0
I thought that might have something to do with it, but I specifically took the next ip, so my Win machine is ....101, and my slack, I assigned ....102. Could this be a problem?
 
Old 02-27-2004, 09:36 PM   #12
jarib
Member
 
Registered: Jun 2003
Location: British Columbia
Distribution: Slackware
Posts: 112

Rep: Reputation: 15
I don't think it should be

disclaimer, I'm not a network admin by any stretch so can't say for sure.
 
Old 02-27-2004, 09:37 PM   #13
bnice
Member
 
Registered: Feb 2004
Location: Sacramento, CA
Distribution: Slack 9.1, slackware-current
Posts: 284

Rep: Reputation: 30
Quote:
Originally posted by TCasp77


- Immediately after I changed the settings, I noticed on my Desktop, where I am using this forum, running WinXP, it suddenly said there is no connection, and I got worried, but after closing IE and reopening it, it works now. Any ideas why this is? Did my settings in Slack affect my router, which in turn affected my connection on my desktop?
I use a DLink DI 604 & had a similar problem.
Linux is a bit, shall we say aggressive in it's use of TCP/IP
It would occasionally force a reboot in the router, the only indication was a popup on a windows machine across the room saying no connection... A firmware upgrade on the router fixed it & now there's no problem
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
network prob. saosurya Red Hat 1 08-03-2005 09:37 AM
Slackware, I installed it but now I have deeper problems. I was so close! Mr. Hill Linux - Newbie 17 02-16-2005 06:24 PM
open and close network port abd_bela Linux - Security 5 08-19-2004 03:40 PM
network prob vhs Linux - Networking 1 11-21-2002 12:20 AM
Network prob. Druaga Slackware 3 09-23-2002 02:24 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration