-   Slackware (
-   -   Slackware installation - Unable to install LILO (

csvke 01-17-2005 09:57 PM

Slackware installation - Unable to install LILO
After installing the packages, I found that LILO wasn't able to install. Should I choose to install LILO to MBR or just hda? I chose the latter and fail.

Would it be the case that I ran out of HDD space? I found that the installation is somehow crap and did not check selected packages against available disk space...

coolfrog 01-17-2005 10:33 PM

I faced the same problem during installation.In my case LILO wasn't getting installed on either MBR or HDA. I recommend that you install LILO onto MBR.
But anyways I had to install it manually. After booting from Disc-1 mount your installed Slack onto /mnt/ folder. Then you can exec /sbin/lilo within it to install LILO. You may also want to edit LILO config at /etc/lilo.conf.
Thats how i did it and it worked. Hope it does the same for you.

csvke 01-17-2005 10:56 PM

sounds promising.
as far as memory servers me, installing lilo can be as simple as running /sbin/lilo and follow the instructions.

Shall try it tonight coz i am in office in hk.

Sader 01-17-2005 11:02 PM

As another option you can use the boot floppy(which I hope you've created during installation process) to boot machine first time. After successfull booting do the following:

then make sure youre /etc/lilo.conf is right & run "lilo"

this worked for me.


csvke 01-18-2005 01:05 AM

i havn't reset my laptop yet so i can quit the setup and install LILO

csvke 01-18-2005 09:59 AM

unfortunately i didn't create a floopy boot disk so i use the setup boot disk to boot my laptop up, mount my hda in /temphda

not sure what to do but i ran this

# /temphda/sbin/lilo -C /temphda/etc/lilo.conf -a /dev/hda

then the output was:


I don't think i have done installing LILO properly, but what should i do?

egag 01-18-2005 11:00 AM a " #chroot /temphda "
then run " #/sbin/lilo "

think that will work....


Sader 01-18-2005 10:18 PM

pls note, that boot floppy can be created by subsection in "pkgtool" menu.

csvke 01-19-2005 01:24 AM

instead, i used the original boot floppy for installation, boot with root mounted as /dev/hda1

run /etc/liloconf

install lilo in MBR


Now i need to sort out my 3Com 11M OfficeConnect card, firefox and fluxbox...

Thanks a lot guys!


All times are GMT -5. The time now is 07:08 PM.