-   Slackware (
-   -   Slackware Installation Problems :( (

SML 12-27-2002 04:24 PM

Slackware Installation Problems :(
I am trying to install Slackware for the first time on a IBM x22 notebook with an external TDK8824 cd connected via USB. (RedHat, Mandrake, SuSE all install with no problems).

So the 8.1 Slackware disc is sitting in the cdrom. I use the BIOS and boot to the CDROM. It loads the kernel, I run the setup program, select the keyboard, select the partitions ..... then the source is where the problems begin. It does not recognise the source media in the cdrom.

So I select the option to install via CDROM.
When I try the automatic detect option, the CD is not picked up.
When I try the manual detection:
.... (a) Which device should I select. Usually it has been either /dev/scd0 but this does not work, or /dev/cdrom but this is not an option in the list to select.
.... (b) Or I can try to a manual install ... should I type in /dev/cdrom? That does not work either.

There was a thread below that appeared to be a similar problem where somebody had to type in at the boot: bare.i ide=nodma. This did not seem to work either.

Hope someone can help. I would love to try slack.

Tinkster 12-27-2002 04:53 PM

look what google found! :D


Mephisto 12-27-2002 05:04 PM

Is the CDRom an actual SCSI CDROM (unlikely especially on a laptop) or is it just using SCSI emulation for CD-burning?

Try /dev/hdb or /dev/hdc.

Edit: Never mind, I am an idiot. I did not catch that it was a USB CD-ROM, sorry.

Excalibur 12-27-2002 05:46 PM

I would think you need a different boot kernel when booting the CD. At the boot prompt try loading the /kernels/usb.i/bzImage kernel. Once the kernel boots review the kernel messages to check if the kernel detected the cdrom drive and assigned a device. Use the [shft][pgup]/[pgdn] keys if I recall correctly to scroll the screen back so you can read the messages.

There are three other usb enabled kernels on the CD but I think they are primarily different in scsi controller support and not on the usb part. But not real sure.

The key here is that kernel has to detect the cdrom drive to provide the support.

SML 12-28-2002 03:09 AM

Thanks for the ideas ...

I tried booting slackware up with about 7 out of the 10 different kernels on the installation disc. I tried the following:
- usb.i
- bare.i
- usb.s
- usb2.s
- scsi.s
- scsi2.s
- usbaha.s
- ibmmca.s

The only kernel that loads and makes it through to the setup window is the standard bare.i kernel. All of the other kernels fail during the kernel load-up. "Kernel panic ... init .... etc etc".

Excalibur 12-28-2002 05:48 AM

What was the last operation of the kernel just prior to the panic?

Mephisto 12-28-2002 12:40 PM

Does usb.i have the usb filesystem comiled into it? For that matter was it available in 2.4.18?

It is detecting the drive in some form since you are able to boot from it. I did a little looking around and could not find anything conclusive. I have an external DVD at the office, if you haven't figured it out by Monday I will bring it home and see what it connects as? Not sure if it will help since none of my installs are running a stock kernel but it is worth a try.

SML 12-28-2002 03:33 PM

It looks like the problem is that the driver for my TDK external CDR/RW is not with the kernel.

I started the boot-up installation with the following:
boot: usb.i root=/dev/sdc0
and I also tried:
boot: usb.i root=/dev/cdrom

With RH, Mandrake, SuSE the cd has always been a scsi emulation on scd0.

The kernel loaded through to the setup program but I noted the following message whilst the kernel was loading:

"USB device 2 (vend/prod 0x4bf/0x130) is not claimed by any active driver."

That is definately my TDK external slim cdr-rw.

Looks like I may have to learn how to setup a new module for the kernel with the driver :( (How do I do that? Guess that has been asked many times before. I'll do some google research.).

I thought that if it worked with say a RedHat 2.4.18 kernel, then the driver should also be in the Slackware 2.4.18 kernel. .... or do RedHat add extra modules to the kernel for extra hardware functionality?

SML 12-28-2002 03:59 PM

Had a google around and this does not look that simple.

Is there any chance that it may work with the "mknod cd-rom device" function in the custom source media selection in the setup program?

It asks for the path (assume /dev/scd0), then asks for the major and minor numbers (whatever they are?). Is this likely to work without the driver for the cd? I tried guessing the major and minor numbers and nothing happened.

When is Slackware 8.2 coming out? :(

Mephisto 12-28-2002 07:31 PM

As just a guess I would say Slackware does not have USB Mass Storage support compiled in. Slackware tends to go the minimalist approach putting only what is necessary to get the box up in any given image, assuming the user will tweak the kernel after the fact if he needs something not included. Redhat, Suse, et al. go the other route making everything conceivable available, either already compiled in or as a module.

So maybe if you can load the mass storage module it will be recognized? Of course it may be a patch that is not in the stock kernel but I don't think it likely.

As far as 8.2 (9) goes I would not expect it till lat March April at a guess. The speed of the updates on the current tree have slowed down dramatically (last one Dec 13) so that is a hopeful sign that I could be wrong.

Excalibur 12-28-2002 09:51 PM

In regard to the kernel support. Slackware boot kernels for installation I do not think supports any modules. At least that I am aware of because of the limited space available for the root file system in ram disk. I cannot speak for RedHat, but SuSE 8.1 uses the 2.4.19 kernel and the USB and IEEE1394 support was enhanced greatly over 2.4.18 that Slack uses. If you know that other distros will install using the 2.4.19 kernel, then perhaps if you have the resources to build a 2.4.19 kernel from source configured as a Slack kernel to provide the support for your CD drive, then the install should be able to proceed. (By using the .config file from the usb.i kernel against 2.4.19 sources.)

If you do not have the resources then email me. I have the kernel sources and everything available. We can discuss how best to deliver.

SML 12-28-2002 11:49 PM

Thanks - it is starting to sound even more time consuming, so I tried a new approach with some success - although it took me the whole day t work it out ...

I tried the following:
1. reformatted my hard-drive and removed RedHat 8.1 beta.
2. re-arranged all the partitions to allow me to install Mandrake or RedHat and have spare partitions afterwards.
3. copy the Slack 8.1 iso to a new partition in Mandrake.
4. reboot and install from one partition to another spare partition.
5. complete Slack 8.1 installation!

Slack seems to boot up without probs although I assume that the cd is not working. Maybe I can copy the module from RH and link it up to my kernel. I will worry about that one later .. the problem now is .....

It didn't boot up into Xwindows and KDE/Gnome?

I did the full 2Gb install and watched KDE and Gnome as they were installed. How do I now boot up the graphics from just a bash shell? I have looked through the X11 folders without much success. I am logged into "darkstar" as root.

SML 12-29-2002 12:03 AM

I tried the xwmconfig .... it came up with the blue screen and asked for the default setting with KDE already selected. I selected OK, then it switched back to the bash shell.

Tried xfree86setup and startx with no luck either.

Would appreciate any advice again. Thanks.

Jen 12-29-2002 12:46 AM

By default, Slackware does not automatically run X at bootup.

Try 'startx' and if that doesn't work (ie., you get an error like "no screens found") run 'xf86config' or 'xf86cfg' and set up your video card, monitor, and other things, then run startx.

If you want X to automatically start, login as root, then edit /etc/inittab and find the line that reads:


and change it to:


pbhj 05-17-2003 05:09 AM

When you say "tried xfree86setup and startx with no success" do you mean the screen went blank and then you had a load of nonsense like stuff (from startx) or do you mean nothing at all happened (except maybe a command line error like file not found)?

If the former usually the messages returned by X have some clued look for lines that say (EE) errors and see what it says. Also there's a file in /var/logs somewhere called XFree86.log (use slocate to find it?) which has all the error info.

If the later, did you install the X series of packages?

All times are GMT -5. The time now is 03:45 PM.