-   Slackware (
-   -   Slackware installation on dell xps m140 (

bijit1709 04-20-2007 11:02 PM

Slackware installation on dell xps m140
I tried installing slackware 11 on my laptop dell xps m140 i tried using huge26.s kernel. After installation was over and said "rebooting....". it never passed from there. So i outed off by pressing the power button. And when i wanted to boot again the it said someting like checking bios something and then went on a black screen. And it never booted. Does anyone know what could possibly cause that problem?

sreyesp 04-21-2007 04:50 AM

Try to boot, from the CD, into your new installation, by typing
"huge26.s root=/dev/hda1 noinitrd ro"
at the CD "boot:" prompt. Remember to change "/dev/hda1" for the actual partition you choosed, maybe "/dev/sda1" if you have a SCSI or SATA drive.
Then check the man page for lilo.conf to study the different options, and reinstall lilo.

bijit1709 04-22-2007 10:21 AM

I have tried that and it still doesn't work. I think the solution is slackware-current.

bijit1709 05-17-2007 12:36 AM

Urgent Help
Could anyone please give me their opinions in what to try so I can do, so slackware installs on my laptop...Any suggestions are welcomed...

ak-87 05-17-2007 01:40 AM

Well try with test26.s kernel. Also, when you boot your installation boot with noieee1394 parameter, i.e.


huge26.s noieee1394
I have problems with udev on my Toshiba, so at the end of installation turn off rc.hotplug service.

bijit1709 05-17-2007 11:28 PM

I have tried that also. But it still at boot time or reboot after installtion its doesn't reboot as it should. Do you think it can be lilo or the kernel?

ak-87 05-18-2007 03:19 AM

Not sure, I don't know exact configuration of your machine. Did you check Linux on laptops site? Maybe there is something specific for your laptop family... Check this link

Also, did you install lilo in MBR?

bijit1709 05-18-2007 03:12 PM

Yes I Did install Lilo on the MBR. When I use sata, bareacpi It installs great but some hardware doesn't work I have tried building my own kernel but it still doesn't work I must be doing some stuff bad.

ak-87 05-19-2007 03:01 AM

Try to download generic kernel from Slackware-current, just to check if it works. I think you should use 2.6.21-smp. Then later if everything is OK, you can use it's config, recompile it etc.

bijit1709 06-08-2007 04:37 PM

I have found the error. The error for the 2.6.# is that the vga doesn't work. In order to see the booting process i have to give vga=normal. But I still have problems When give command:


# startx
Its gives some error and says it doesn't support my screen depth. Any screen depth I put. And when I do:


# shutdown -r 0
it says rebooting . and it doesn't do anything after and it doesn't reboot. Do you think its the same problem with the vga?

All times are GMT -5. The time now is 08:32 PM.