-   Slackware (
-   -   Slackware Install -probable Grub problem- boot OK from Flashdrive (

mrmarria 03-23-2013 11:29 PM

Slackware Install -probable Grub problem- boot OK from Flashdrive
Thought I'd give Slackware a try, Ubuntu is causing me samba problems.

Install went easily, using Grub to multi-boot,
however, when I boot from flash drive Slackware install created, everything OK. When I boot from HD, after initial decompression, screen black out.
I believe that the boot continues to Login.

I can login, and issue startx, which gets a lot of drive activity but no display still. I can also login blind, and shutdown the system.

Been reading up on grub2, not sure where to look for config problem - guessing something like vga settings?

The files on the flashdrive are so simple compared to what grub apparently does, I am lost.

Any help?

Erik_FL 03-24-2013 03:12 PM

When you first boot Slackware after installing, it stays in text console mode. I think the problem you have is the frame buffer graphics mode is not compatible with your video card.

You can try adding these kernel parameters in the grub menu entry for Slackware on the line that has "/boot/vmlinuz".


vga=normal video=640x480
Edit the "/boot/grub/grub.cfg" file in the Ubuntu partition (or whatever partition has GRUB installed).

The menu entry for Slackware will look similar to this. Your GRUB 2 menu entry may look different and there may be a few more options on the line with "/boot/vmlinuz". Add the "vga" and "video" options to the end of that line. If the "vga" or "video" option is already there, then change the existing options.


menuentry "Slackware" {
    insmod ext2
    set root=(hd0,msdos2)
    linux    /boot/vmlinuz root=/dev/sda2 ro vga=normal video=640x480

If you still do not see a display, you may have to black-list the Noveau graphics driver.

Create a text file in the Slackware partition named "/etc/modprobe.d/disable-nouveau.conf". The file should contain this to disable Noveau.


blacklist nouveau
options nouveau modeset=0

For example, if you mounted the Slackware partition under "/mnt" then you need to create a file called "/mnt/etc/modprobe.d/disable-nouveau.conf". The directory "etc/modprobe.d" should already exist in the Slackware partition.

If that does not solve the problem, please post information about your graphics card. Use this command on a version of Linux that does boot and post the results here.


If you know the manufacturer and model of your graphics card or chip, post that as well.

mrmarria 03-24-2013 05:54 PM

blacklist worked, why?
Thank you Erik_FL.

Blacklisting was the immediate solution, the other things did not succeed.

The card reports as: nVidia Corporation g98 [GeForce 8400 GS] (rev a1)

it is a PNY GeForce 8400 GS pci-e card

So with nouveau disabled, I get low res from flashdrive boot and / or HD boot.

With nouveau enabled. I only can see a a display after nouveau goes active from the flashdrive.
(I see it start in the flashdrive boot) as the text goes hi-res.

What is happening differently to this "driver"?

Obviously, a lot more is going on with grub than with the flash drive boot....
I tried mkinitrd from running slackware boot, but that did not succeed.

Thank you.

Erik_FL 03-24-2013 09:54 PM

I don't know a lot about GRUB 2 but there is a way to set the graphics resolution before booting Linux.

In the Slackware menu entry add this line to set the graphics resolution.


set gfxpayload=640x480


set gfxpayload=text
You can also use other resolutions if your graphics card supports those. For example, "1024x768" or "1024x768x24".

To make sure that GRUB can tell the kernel the correct video resolution, you should have these modules loaded at the beginning of your "grub.cfg" file.

For a computer with a BIOS.


insmod vbe
For a computer with UEFI.


insmod efi_gop
insmod efi_uga

All times are GMT -5. The time now is 06:28 PM.