-   Slackware (
-   -   Slackware + HPLIP (

ons 08-11-2006 02:22 PM

Slackware + HPLIP

I recently purchased a HP Deskjet 5440 which works properly with cups and foomatic. However, I want to use hplip so I can use the tools to maintain the printer. I installed hplip according to other Slackware users and the instructions of the drivers website. There seems to be a problem for hplip to detect the printer. When I use hp-setup to setup the printer, the output is:

HP Linux Imaging and Printing System (ver. 1.6.7)
Printer/Fax Setup Utility ver. 2.1

Copyright (c) 2003-6 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: No devices found.
error: Error occured during interactive mode. Exiting.

Cups detects the printer with the usb backend, however for hplip I have to use the hp backend (the cups browser interface lists only "hp no_device_found"). I also tried to set the printers URI manually to hp:/usb/...., with no success. The problem does not seem to be related to the installation of hplip, but rather to an usb issue. For example lsusb gives:

Bus 002 Device 002: ID 03f0:8604 Hewlett-Packard
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 002: ID 045e:0084 Microsoft Corp.
Bus 001 Device 001: ID 0000:0000

Now hp-makeuri 002:002 should output the printers URI, but instead: error: Device not found

I installed the newest versions of cups, ghostscript and usblib, but the problem remains the same.

I use Slackware 10.2 and Kernel
Does anyone know how to fix this?

etrumbo 08-12-2006 06:30 AM

Hi ons,

Welcome to Linuxquestions!

I had a problem with HPLIP at first, and it turned out to be a conflict with the kernel and udev detecting the printer and assigning it to a usblp device, effectively blocking it from HPLIP detection. You could comment out the usblp definitions from udev.rules, or as in my case just recompile the kernel without USB printer support.

etrumbo 08-12-2006 06:44 AM

Hi ons,

I'm sorry, please disregard my post above. I just double checked my config and that's not at all what solved it. I do have usblp0 active on my system. I'll look into it and see if I can remember how I got HPLIP going.

ons 08-12-2006 03:09 PM

Thanks, etrumbo. After reinstalling cups, foomatic and hplip cleanly I can finally use the hp backend. However, two small problems remain: I have to restart hplip and cups after booting, otherwise hp-toolbox lists the printer as inactive. And hp-toolbox wont print a test-page or a page after the maintenance operations have finished. Printing from kde applications or firefox works properly.

dracolich 08-12-2006 05:31 PM

To solve the problem of restartig the services after reboot I added a couple lines to my /etc/rc.d/rc.local

#Start the HPLIP service
/etc/init.d/hplip restart
/etc/rc.d/rc.cups restart

Hope this helps.

All times are GMT -5. The time now is 08:10 AM.