-   Slackware (
-   -   Slackware from Vmware Workstation 6.0 - ethernet connection (

ReVeR 05-19-2007 11:41 AM

Slackware from Vmware Workstation 6.0 - ethernet connection
I recently set up a VMWare Workstation 6.0 on my windows box, and installed slackware onto a vm. Well the installation went fine, but now i am having trouble connecting to the internet. Essentially I will need to use the same internet connection as my windows box, since i am running from within the vm, but how the hell do i set that up?
Thx Alot in advance. Note i am running on a slighly old slackware 9.0 :D

I am using NAT option in VMWare.

bsdunix 05-19-2007 12:24 PM


I am using NAT option in VMWare.
Using NAT in VMware has it's own DHCP server and subnet settings. Set the guest OS to use DHCP. The easyist way to set up DHCP in Slackware is to use command netconfig as root and follow the prompts.

# netconfig
"The preferred way of setting up your network connection is through the use of the netconfig program."

ReVeR 05-19-2007 12:41 PM

Hey, thx alot.
I did the configuration, a but that still doesn't allow me to access anything over the network.
When the virtual machine tries to access the net, does it use the MAC addy of my windows box, or the one that is in slack?
I got a correct ip addy from DHCP, however any attemps to do something like ping google or something fail.

bsdunix 05-19-2007 01:33 PM

The guest NIC will get a MAC address, the NAT connection will use the host's MAC/IP/port number for the actual live network connection.

Check the VMware Virtual Network Settings and make sure DHCP and NAT servces are started; the NAT tab will show what virtual gateway and subnet is being used. As an example, the gateway will be

Verify your guest OS has an IP address, gateway, and nameserver based on the virtual subnet. Example below.

# ifconfig eth0 | grep inet
IP address should be in 192.168.31.X range
# route -n
Look under the Gateway column, should be
# cat /etc/resolv.conf | grep nameserver
should show

All times are GMT -5. The time now is 06:16 PM.