LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-18-2006, 04:06 PM   #1
.nu
Member
 
Registered: Mar 2006
Distribution: Slackware 10.2
Posts: 60

Rep: Reputation: 15
Slackware finds my USB board but not mouse


When it loads up, it says something like:
/dev/mouse not found (or something very similar to 'not found')

But the keyboard loads up fine, because i am able to type commands.


Does anyone know how to fix this? If so, please let me know
 
Old 03-18-2006, 06:34 PM   #2
veritas
Member
 
Registered: Aug 2003
Location: Dallas,TX
Distribution: Ubuntu Server, Slackware, Red Hat 6.1
Posts: 241

Rep: Reputation: 30
Did you select USB mouse with the 'mouseconfig' tool?
 
Old 03-18-2006, 06:51 PM   #3
.nu
Member
 
Registered: Mar 2006
Distribution: Slackware 10.2
Posts: 60

Original Poster
Rep: Reputation: 15
Yes.

When i select USB Mouse, it doesn't load up the mouse.
When i select PS/2 mouse, the mouse works, but improperly. It skips all over the screen, etc.
 
Old 03-18-2006, 06:59 PM   #4
stormtracknole
Member
 
Registered: Aug 2005
Location: The Big Easy
Distribution: Slackware, RHEL
Posts: 969

Rep: Reputation: 125Reputation: 125
In your xorg.conf file, edit the section that has /dev/mouse to /dev/input/mice . Also, you can change the PS/2 to IMPS/2. I'm not sure if the last is necessary.
 
Old 03-18-2006, 07:03 PM   #5
.nu
Member
 
Registered: Mar 2006
Distribution: Slackware 10.2
Posts: 60

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by stormtracknole
In your xorg.conf file, edit the section that has /dev/mouse to /dev/input/mice . Also, you can change the PS/2 to IMPS/2. I'm not sure if the last is necessary.
Thanks. Ill go try it out now.

But when you say "you can change the PS/2 to IMPS/2", where do i change that? in the xorg.conf file? because the mouseconfig doesn't let me input any paremeters, just gives me a list of options
 
Old 03-18-2006, 07:24 PM   #6
.nu
Member
 
Registered: Mar 2006
Distribution: Slackware 10.2
Posts: 60

Original Poster
Rep: Reputation: 15
back.
changing it to /dev/input/mice didn't do the trick, and im not sure where to change ps/2 to IMPS/2, do i didn't do that yet
 
Old 03-18-2006, 08:08 PM   #7
stormtracknole
Member
 
Registered: Aug 2005
Location: The Big Easy
Distribution: Slackware, RHEL
Posts: 969

Rep: Reputation: 125Reputation: 125
Quote:
Originally Posted by .nu
back.
changing it to /dev/input/mice didn't do the trick, and im not sure where to change ps/2 to IMPS/2, do i didn't do that yet
Change it on the xorg file. Another question, are you using the 2.4 kernel provided by Slackware?
 
Old 03-18-2006, 08:26 PM   #8
.nu
Member
 
Registered: Mar 2006
Distribution: Slackware 10.2
Posts: 60

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by stormtracknole
Change it on the xorg file. Another question, are you using the 2.4 kernel provided by Slackware?
i'm using the SATA.I kernel, that did come on the slackware CD. (slackware 10.2)

Ok. i was in the xorg conf file.

it had
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "Microsoft"
Option "Device" "/dev/mouse"

I changed 'microsoft' to PS/2 and IMPS/2, but no luck.

Last edited by .nu; 03-18-2006 at 08:29 PM.
 
Old 03-18-2006, 08:30 PM   #9
stormtracknole
Member
 
Registered: Aug 2005
Location: The Big Easy
Distribution: Slackware, RHEL
Posts: 969

Rep: Reputation: 125Reputation: 125
Quote:
Originally Posted by .nu
i'm using the SATA.I kernel, that did come on the slackware CD. (slackware 10.2)

Ok. i was in the xorg conf file.

it had

Option "Protocol" "Microsoft". I changed microsoft to PS/2 and IMPS/2, but no luck.
Hmmm...boy, I'm stumped. I had the same problem that you had, but changing the device section to /dev/input/mice did the trick. If I think of anything else I'll post it, but right now I don't know what else to try.
 
Old 03-18-2006, 08:31 PM   #10
stormtracknole
Member
 
Registered: Aug 2005
Location: The Big Easy
Distribution: Slackware, RHEL
Posts: 969

Rep: Reputation: 125Reputation: 125
Quote:
Originally Posted by .nu
i'm using the SATA.I kernel, that did come on the slackware CD. (slackware 10.2)

Ok. i was in the xorg conf file.

it had
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "Microsoft"
Option "Device" "/dev/mouse" (Did you change this to "/dev/input/mice" ?)

I changed 'microsoft' to PS/2 and IMPS/2, but no luck.
Post your current xorg.conf file, just for the heck of it.
 
Old 03-18-2006, 08:36 PM   #11
.nu
Member
 
Registered: Mar 2006
Distribution: Slackware 10.2
Posts: 60

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by stormtracknole
Post your current xorg.conf file, just for the heck of it.

lol.
If you're willing to tell me how to save it into a USB thumbdrive (dont have a floppy one), i'll be more than happy to do do
 
Old 03-18-2006, 09:09 PM   #12
stormtracknole
Member
 
Registered: Aug 2005
Location: The Big Easy
Distribution: Slackware, RHEL
Posts: 969

Rep: Reputation: 125Reputation: 125
Did you change this:
Option "Device" "/dev/mouse"

to this:

Option "Device" "/dev/input/mice"

That is the only thing that I can think of.
 
Old 03-18-2006, 09:32 PM   #13
.nu
Member
 
Registered: Mar 2006
Distribution: Slackware 10.2
Posts: 60

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by stormtracknole
Did you change this:
Option "Device" "/dev/mouse"

to this:

Option "Device" "/dev/input/mice"

That is the only thing that I can think of.
I had tried that.

But i managed to make it work, ill post here how i did it in case someone has the same problem in the future.

I ran the xorgconfig again. It gives you a bunch of mouse options to select from. I remember PS/2 was an option, and Microsoft was another option. But before all the options, was Auto.

I had selected Microsoft before, as my mouse is by Microsoft.

So this time, i selected Auto, and went through the rest of the installation, and it worked


Just another question:
How do make thumb/flash drives work?


ps: thanks to everyone that has helped me so far!
 
Old 03-18-2006, 09:41 PM   #14
stormtracknole
Member
 
Registered: Aug 2005
Location: The Big Easy
Distribution: Slackware, RHEL
Posts: 969

Rep: Reputation: 125Reputation: 125
Glad to hear that you got it to work. As far as your usb drive, you may want to do a search because it has been discussed here before.
 
Old 03-18-2006, 09:55 PM   #15
.nu
Member
 
Registered: Mar 2006
Distribution: Slackware 10.2
Posts: 60

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by stormtracknole
Glad to hear that you got it to work. As far as your usb drive, you may want to do a search because it has been discussed here before.
Alright will do.
Thanks again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
USB mouse not working on the ARM board. manjunathk Linux - Hardware 1 07-12-2005 06:06 PM
YUM finds 4 updates while up2date finds 29? guest Linux - Newbie 3 03-15-2005 10:01 PM
slackware 9.1 USB mouse and other usb devices not working jimMC Linux - Hardware 11 01-24-2004 11:58 AM
Gaim 0.71: pkg-config finds 2.2.3, ./configure finds 2.2.1 GreenPenInc Linux - Software 3 10-23-2003 09:00 PM
There's 2 partitions on HDA, but slackware only finds 1 of them. Seph64 Slackware 4 05-01-2003 04:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration