-   Slackware (
-   -   slackware darkstar login ID (

gatliffe 11-16-2003 01:52 PM

slackware darkstar login ID
I just install slackware now when it boot up it ask for darkstar login ID I didn't see anything like this in setup I only setup a root past word how can I fix this

rotvogel 11-16-2003 01:56 PM

Try root :)

When succesfully logged in you can create users using the adduser command.

php 11-16-2003 02:18 PM

darkstar is the hostname of the computer. Has nothing to do with users on the system. If you want to change this you can use netconfig or a simple hostname -v 'changme'

gatliffe 11-16-2003 03:13 PM

I didn't give a hostname I was thinking that was for a network anything I can do now

whansard 11-16-2003 03:46 PM

i didn't think slackware was still using that name.
that really brings back memories. slackware '96 and
you can try to edit /etc/HOSTNAME
but there may be scripts that create that file at boot.

Kjetil4455 11-16-2003 06:59 PM

mate, write "root" and then your root password. and you may enter tghe GUI by doing the "startx" command.

Lagg 11-16-2003 10:24 PM


Originally posted by Kjetil4455
mate, write "root" and then your root password. and you may enter tghe GUI by doing the "startx" command.


Don't wig out and loose it if the GUI doesn't start up pefectly. It may take some tweeking. There are plenty of guides around here on getting that to work (or there used to be...hope the still are around)

gatliffe 11-16-2003 11:41 PM

thanks I try that tomorrow I reinstall it 3or 4 time but can't get past darkstar

kadaver 11-17-2003 06:13 AM

All you have to do to change your hostname is to run netconfig again...
Just login as usual and type 'netconfig' at command prompt

root@darkstar# netconfig

This program will set up your network, the first thing it asks for is your hostname, just type whatever you want and PRESTO! You have a new hostname...

gatliffe 11-17-2003 10:05 AM

typeing root then the password get me in but only to a command prompt how do I get a desktop like KDE to come up?

jeramy 11-17-2003 12:55 PM

That would be where "startx" comes into play.

That should bring you into X.

For starting up with a graphical login, you need to edit your /etc/inittab and the first uncommented line in there should look like this:


gatliffe 11-17-2003 05:13 PM

Thanks I will try that but why is it like this in the setup it ask what you want I want at start up KDE or some thing other I been trying other linux none been anything like this I hear slackware the best maybe but sure is alot of work to setup I am new to linux and have alot to leard

h3pc4t 11-17-2003 05:49 PM

The setup simply configures the default windowmanager (/etc/X11/xinit/xinitrc). You still need to log in and type 'startx'.

gatliffe 11-17-2003 07:36 PM

thanks I got it going but now my internet cable modem won't work I do a new post on this

pkinnon 11-18-2003 04:45 AM

'nuvver 'noobee (to linux)

Had the same problem getting past the Darkstar logon bit but thanks to the various posts on this managed to through to the acount set up and can now logon with my selected username (pk) and password.

Now stuck again, however as the prompt pk@darkstar still doesn't recognise the command 'startx'
tried to access /etc/inittab but get "permission denied"

Any help much appreciated.


All times are GMT -5. The time now is 06:40 PM.