LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-06-2019, 04:04 PM   #1
luvr
Member
 
Registered: May 2005
Location: Boom - The Home Town of Tomorrowland, Belgium
Distribution: Slackware, Debian, Xubuntu
Posts: 258
Blog Entries: 1

Rep: Reputation: 91
Slackware-current XFCE issue: Icon for mounted volume incorrectly displayed on desktop.


My laptop has three Slackware systems installed: Slackware64 14.2, Slackware64 Current, and Slackware32 14.2. The issue I’m reporting here shows up only under the ‘Current’ system.

The harddisk has the following partitions:
Code:
/dev/sda1: PARTLABEL="BIOS boot partition" PARTUUID="3e22819f-7030-4d68-b325-7f9fa8ce6b6b"
/dev/sda2: LABEL="GRUB Boot Loader" UUID="feaba671-d648-4b16-b6c5-ba42f39f2312" TYPE="ext4" PARTLABEL="Linux filesystem" PARTUUID="416e21b4-911a-4733-8866-2924b6da7df0"
/dev/sda3: LABEL="Spare-A3" UUID="a0d7f96a-182e-40ea-abe6-a20fa363773b" TYPE="ext4" PARTLABEL="Linux filesystem" PARTUUID="45ffc653-3a8f-4698-812f-9c655c4644fb"
/dev/sda4: LABEL="Spare-A4" UUID="965406c1-60d9-49b0-833f-1e82df7d2411" TYPE="ext4" PARTLABEL="Linux filesystem" PARTUUID="88a0ee43-e276-4400-8eaa-7fbf1c193913"
/dev/sda5: LABEL="Spare-A5" UUID="6cfdacdf-7cee-47e3-8a5c-04c5aaf50f19" TYPE="ext4" PARTLABEL="Linux filesystem" PARTUUID="82077b47-1461-4118-be1a-7800708f79c4"
/dev/sda6: LABEL="Debian" UUID="28d5d695-b919-4de6-aaa9-33a528b52f65" TYPE="ext4" PTTYPE="dos" PARTLABEL="Linux filesystem" PARTUUID="fe4be94d-464a-4a5f-8219-07b63b16ee5c"
/dev/sda7: LABEL="Slackware32" UUID="fac3d1bf-dd7a-4a9d-8815-738d4bff4a81" TYPE="ext4" PTTYPE="dos" PARTLABEL="Linux filesystem" PARTUUID="498c6467-04ea-4485-9105-b3b5a5f4a120"
/dev/sda8: LABEL="SlackwareCurrent" UUID="f9f286a7-0ed3-4d01-bfa7-895fb4535697" TYPE="ext4" PTTYPE="dos" PARTLABEL="Linux filesystem" PARTUUID="e3982dcb-b7ea-45ba-b1a9-865f0702ecab"
/dev/sda9: LABEL="Slackware" UUID="40a9febf-0ce6-45de-bfbb-d40368f08088" TYPE="ext4" PTTYPE="dos" PARTLABEL="Linux filesystem" PARTUUID="e11b8594-8804-42fb-9471-f3eb52511f7c"
/dev/sda10: LABEL="Data" UUID="52cf1552-d8f5-45af-9f62-9e259e01a283" TYPE="ext4" PARTLABEL="Linux filesystem" PARTUUID="d95fc468-5cb1-48b7-94c4-f367dcaf74ce"
The “Data” partition (i.e., “/dev/sda10”) is mounted (by fstab) on mount point ‘/mnt/local/Data’ (which I created on each of the three Slackware partitions). Under Slackware Current, the two Slackware 14.2 system partitions are mounted on ‘/mnt/local/Slackware’ and ‘/mnt/local/Slackware32’, respectively (with similar mounts under both of the 14.2 systems). In addition, the ‘/home’ directory is a mount point that is “bind-mounted” to a directory on the “Data” partition.

Yesterday, I decided that I wanted my ‘Documents’ folder to be shared between the three Slackware systems, so I “bind-mounted” my ‘/home/luvr/Documents’ folder (on each of these systems) to yet another directory on the “Data” partition (and similarly for a few other of the ‘/home’ subdirectories).

To make a long story short (sic), my ‘/etc/fstab’ under Slackware-current now looks like this:
Code:
#
#*******************************************************************************************************************************
#*                                                                                                                             *
#* Mountpoint . . . . : /                                                                                                      *
#* Device Node  . . . : /dev/sda8                                                                                              *
#* Device Label . . . : SlackwareCurrent                                                                                       *
#*                                                                                                                             *
#*******************************************************************************************************************************
UUID=f9f286a7-0ed3-4d01-bfa7-895fb4535697    /                             ext4        defaults         1   1
#
#*******************************************************************************************************************************
#*                                                                                                                             *
#* Mountpoint . . . . : /mnt/local/Slackware                                                                                   *
#* Device Node  . . . : /dev/sda9                                                                                              *
#* Device Label . . . : Slackware                                                                                              *
#*                                                                                                                             *
#*******************************************************************************************************************************
UUID=40a9febf-0ce6-45de-bfbb-d40368f08088    /mnt/local/Slackware          ext4        defaults         0   0
#
#*******************************************************************************************************************************
#*                                                                                                                             *
#* Mountpoint . . . . : /mnt/local/Slackware32                                                                                 *
#* Device Node  . . . : /dev/sda7                                                                                              *
#* Device Label . . . : Slackware32                                                                                            *
#*                                                                                                                             *
#*******************************************************************************************************************************
UUID=fac3d1bf-dd7a-4a9d-8815-738d4bff4a81    /mnt/local/Slackware32        ext4        defaults         0   0
#
#*******************************************************************************************************************************
#*                                                                                                                             *
#* Mountpoint . . . . : /mnt/local/Data                                                                                        *
#* Device Node  . . . : /dev/sda10                                                                                             *
#* Device Label . . . : Data                                                                                                   *
#*                                                                                                                             *
#*******************************************************************************************************************************
UUID=52cf1552-d8f5-45af-9f62-9e259e01a283    /mnt/local/Data               ext4        defaults         0   0
#
#*******************************************************************************************************************************
#*                                                                                                                             *
#* Bind-Mounts.                                                                                                                *
#*                                                                                                                             *
#*******************************************************************************************************************************
#
/mnt/local/Data/SlackwareCurrent/home        /home                         none        bind
/mnt/local/Data/Common/home/luvr/Documents   /home/luvr/Documents          none        bind
/mnt/local/Data/Common/home/luvr/Downloads   /home/luvr/Downloads          none        bind
/mnt/local/Data/Common/home/luvr/Music       /home/luvr/Music              none        bind
/mnt/local/Data/Common/home/luvr/Pictures    /home/luvr/Pictures           none        bind
/mnt/local/Data/Common/home/luvr/Videos      /home/luvr/Videos             none        bind
/mnt/local/Data/SlackwareCurrent/opt         /opt                          none        bind
#
/mnt/local/Data/Slackware/home               /mnt/local/Slackware/home     none        bind
/mnt/local/Data/Slackware/opt                /mnt/local/Slackware/opt      none        bind
#
/mnt/local/Data/Slackware32/home             /mnt/local/Slackware32/home   none        bind
/mnt/local/Data/Slackware32/opt              /mnt/local/Slackware32/opt    none        bind
#
#*******************************************************************************************************************************
#*                                                                                                                             *
#* Virtual Filesystem Mounts.                                                                                                  *
#*                                                                                                                             *
#*******************************************************************************************************************************
#
devpts                                       /dev/pts                      devpts      gid=5,mode=620   0   0
proc                                         /proc                         proc        defaults         0   0
tmpfs                                        /dev/shm                      tmpfs       defaults         0   0
#
#*******************************************************************************************************************************
#*                                                                                                                             *
#* OBSOLETE ENTRIES:  CD-ROM and Floppy Disk Drive.                                                                            *
#*    o  CD-ROM / DVD-ROM / etc.:  Need no longer be set up in the '/etc/fstab' file.                                          *
#*    o  Floppy Disk Drive:        Just a historical relic.  Surely no modern computer comes with this type of device anymore? *
#*                                                                                                                             *
#*******************************************************************************************************************************
#*                                                                                                                             *
#*   /dev/cdrom   /mnt/cdrom    auto   noauto,owner,ro,comment=x-gvfs-show   0   0                                             *
#*   /dev/fd0     /mnt/floppy   auto   noauto,owner                          0   0                                             *
#*                                                                                                                             *
#*******************************************************************************************************************************
#
(and similarly under the two 14.2 systems).

This setup works fine, except for one little detail, in that, under the Slackware Current system only, an icon for the “Data” partition now appears on my desktop, as an unmounted volume. (Under either of the 14.2 systems, the icon for the partition is no longer shown—as expected; the icons for the other two Slackware system partitions do not appear either—again, as expected). If I attempt to open (or mount) the “Data” partition (by double-clicking its icon), I get an error, because the partition is already mounted (which is true)—see attached picture.

The icon for the “Data” partition disappears from my desktop (as it should, according to my expectations) as soon as I unmount all of the “bind-mounts” to the ‘/home/luvr’ subdirectories. It immediately re-appears (as a seemingly unmounted volume) when I reinstate any of these “bind-mounts”.

EXPECTED BEHAVIOUR:
I expect the icon for the “Data” partition to remain hidden (just like the other two partitions that get mounted by fstab), whether or not the “bind-mounts” to the subdirectories are active. This is, in fact, the behaviour that I see under both of the 14.2 systems.
Attached Thumbnails
Click image for larger version

Name:	MountFailed.png
Views:	11
Size:	28.6 KB
ID:	30710  
 
Old 06-07-2019, 09:10 AM   #2
luvr
Member
 
Registered: May 2005
Location: Boom - The Home Town of Tomorrowland, Belgium
Distribution: Slackware, Debian, Xubuntu
Posts: 258

Original Poster
Blog Entries: 1

Rep: Reputation: 91
A quick test to verify the issue.

Initial Setup.
  • On my XFCE desktop, an icon is shown for an unmounted ext4 volume—say, ‘Spare-A3’—that sits on the ‘/dev/sda3’ disk partition.

    If I double-click the icon, then it gets mounted, and a file manager window opens for it. Its icon changes to indicate the ‘mounted’ state. In addition to the ‘lost+found’ directory, the file system contains just one directory—say, ‘misc’—of which my user account is the owner:
    Code:
    luvr@lappie:/run/media/luvr/Spare-A3$ ls -l
    total 20
    drwx------ 2 root root 16384 Sep 30  2016 lost+found/
    drwxr-xr-x 2 luvr luvr  4096 Jun  7 14:20 misc/
    If I close the file-manager window, then I can right-click the icon and select the ‘Unmount Volume’ option from its context menu. The icon then returns to its ‘unmounted’ state.
  • My home directory includes a ‘testdir’ subdirectory:
    Code:
    luvr@lappie:~$ ls -ld testdir
    drwxr-xr-x 2 luvr luvr 4096 Jun  7 14:39 testdir/
During the following experiment, I will “bind-mount” the ‘misc’ directory (on the ‘/dev/sda3’ disk partition) onto this ‘testdir’.

The Test.

As root, I now mount the ‘/dev/sda3’ disk partition onto the ‘/mnt/tmp’ directory:
Code:
root@lappie:~# mount /dev/sda3 /mnt/tmp
At this point, the icon for the hitherto unmounted volume (i.e., ‘Spare-A3’) disappears from my desktop.

Next, I “bind-mount” the ‘/mnt/tmp/misc’ directory onto the ‘testdir’ mount point under my home location:
Code:
root@lappie:~# mount -o bind /mnt/tmp/misc /home/luvr/testdir
Expected Results.

I expect the ‘Spare-A3’ icon to remain hidden from my desktop.

Actual Results.
  • Under Slackware Current (64-bit), the ‘Spare-A3’ icon reappears on the desktop, but in its unmounted state. If I subsequently double-click the icon, then I get an error, saying that the volume is already mounted.
    If I unmount the ‘/mnt/tmp/misc’ directory again, the icon disappears from the desktop again.
  • Under Slackware 14.2 (64-bit), the icon remains hidden—as it should be.
  • Under Slackware 14.2 (32-bit), the icon also remains hidden—as it should be.
  • Since there’s also Debian Testing (64-bit) system installed on this laptop, I ran the same test with it. Again, the icon remains hidden—as it should.
So, it looks like something, somewhere is acting up when running XFCE under Slackware Current.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Used and Free Swap are Displayed Incorrectly in free and top rudytblr Linux - General 2 08-27-2015 04:17 PM
[SOLVED] X Window problem: windows are displayed incorrectly. FeyFre Slackware 3 12-20-2010 02:34 PM
Time displayed incorrectly after win7 duel boot setup chas Debian 3 09-30-2010 12:38 AM
ID3 Tag Displayed Incorrectly in xmms alkos333 Slackware 3 02-13-2007 09:55 PM
Accented letters displayed incorrectly in amsn on Ubuntu eBopBob Linux - Newbie 1 02-04-2006 04:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration