-   Slackware (
-   -   Slackware-current x86_64: kwin crashes with radeon, no window decorations or panel (

pdags 02-25-2012 03:08 PM

Slackware-current x86_64: kwin crashes with radeon, no window decorations or panel

I have a Radeon HD 6870. Since upgrading to slackware-current with kernel 3.2.2 I've been unable to get KDE to start correctly. XFCE works just fine. I'm pretty sure everything was working properly with the kernel, but I honestly can't remember if that's the version I was on before updating.

When I run startx, KDE appears to start, but then no panel is displayed and any applications I start are missing the window decorations and cannot be moved. Starting an alternative window manager (like xfwm4) or switching compositing to XRender lets me use KDE, but I'd still like to know what's actually wrong.

I've tried compiling newer kernels (up to 3.3.0-rc4) and no love. I tried recompiling the 3.2.2 kernel with the missing firmware for evergreen cards referenced on but still no luck. I don't think I'm getting that far anyway.

Here's the output from trying to run kwin in a console:


kwin(14747) KWin::CompositingPrefs::detectDriverAndVersion: GL vendor is "Advanced Micro Devices, Inc."
kwin(14747) KWin::CompositingPrefs::detectDriverAndVersion: GL renderer is "Mesa DRI R600 (BARTS 6738) 20090101  TCL DRI2"
kwin(14747) KWin::CompositingPrefs::detectDriverAndVersion: GL version is "2.1 Mesa 7.10.2"
kwin(14747) KWin::CompositingPrefs::detectDriverAndVersion: Detected driver "radeon" , version "20090101"
drmRadeonCmdBuffer: -22. Kernel failed to parse or rejected command stream. See dmesg for more info.

I'm assuming this is related from dmesg:

[  615.527078] [drm:evergreen_cs_packet_next_reloc] *ERROR* No packet3 for relocation for packet at 275.
[  615.527082] radeon 0000:08:00.0: bad SET_CONTEXT_REG 0x28C74
[  615.527084] [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !

I'm hoping I've missed something obvious, so all suggestions are greatly appreciated!


sberthelot 02-26-2012 03:57 AM


I have the same problem with a Radeon HD 6450 (R600).
For now I have switched kde from OpenGL to Xrender and it works (though it should use less to no hardware acceleration)

kwin sends packets with less parameters than expected to the kernel, I wonder whether it actually uses libdrm or something similar for that.
What version of kde are you using ?

If you can get a shell you may switch settings using :

kcmshell4 kwincompositing
Launching kwin again made it work for me. Maybe you can get more debug attaching it to gdb or similar. The backtrace may show what lib is involved if not kwin directly (I suspect libdrm 2.4.25 to be too old for kernel 3.2.x)

If I have some time soon I'll try Unofficial Mesa 7.11 slackbuild for Slackware with Gallium3D activated for R600

I'm interested in feedback if you find the component involved (apart from the kernel :) )

sberthelot 02-26-2012 06:05 AM

Ok I managed to get it to work (and also get better performance it seems) using Mesa 7.11.2 and the slackbuild on the link above.
Note that I had to build/install llvm also (as stated in the post)

OpenGL is working for me on Caicos (R600 - Radeon HD6450) using Gallium 0.4 (Mesa 7.11.2).
I hope Pat is going to integrate the new version of Mesa, at least in "testing" on -current soon ...

pdags 02-26-2012 09:32 AM

That seems to have solved it for me too. Thanks!

All times are GMT -5. The time now is 03:43 AM.