-   Slackware (
-   -   Slackware -current w/ kernel + VMware-server 1.0.7 (

niels.horn 11-09-2008 09:09 AM

Slackware -current w/ kernel + VMware-server 1.0.7
As regular readers of this forum know, I'm a user of VMware-server, and also an adventurer who uses the -current branch of Slackware.

After the huge update that was released last Friday, including a jump to the kernel, VMware-server (as expected) stopped working.

But Google is our friend, so I found a patch made by a guy called Kang here and it worked flawlessly.

Just download the patch, untar, and run the script.

For those interested in technical details, it seems the problem is caused by the removal of the "kernel_thread" feature from 2.6.27 which was marked for removal since August, 2006 but finally dropped in this kernel.
See /usr/src/linux/Documentation/feature-removal-schedule.txt
I read that the newer VMware-server 2.x doesn't use this but haven't tried it to confirm the information.

All times are GMT -5. The time now is 04:34 PM.