LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-23-2017, 12:31 PM   #1
pataphysician
Member
 
Registered: Oct 2012
Posts: 76

Rep: Reputation: Disabled
slackware current, typo in new rc.inet1, also is gtk3 now required for firefox?


There is a typo in the new rc.inet1 script the changelog say that it was updated to dhcp timeout of 15 seconds, but it seems to only have changed the echo statement for the logger, the actual timeout is still 10 seconds.

Also its seems that firefox is now built with gtk3, is this because it has to be? or is this for xfce integration?
 
Old 05-23-2017, 12:53 PM   #2
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,703

Rep: Reputation: 665Reputation: 665Reputation: 665Reputation: 665Reputation: 665Reputation: 665
you have right for firefox it's compiled (--enable-default-toolkit=cairo-gtk3) option in the Pat SlackBuild, it need probably gtk+3

Last edited by gmgf; 05-23-2017 at 12:55 PM.
 
Old 05-23-2017, 12:59 PM   #3
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,703

Rep: Reputation: 665Reputation: 665Reputation: 665Reputation: 665Reputation: 665Reputation: 665
(15 seconds should be a reasonable default DHCP timeout) in the rc.inet1
 
Old 05-23-2017, 01:07 PM   #4
pataphysician
Member
 
Registered: Oct 2012
Posts: 76

Original Poster
Rep: Reputation: Disabled
The compile line for firefox is actually correct as cairo-gtk3, that is not my problem. This is the first time Patrick has used gtk3 instead of gtk2, both options have been available for awhile in firefox, and I was wondering if now firefox is only going to allow being built with gtk3, or if this was a decision by Patrick to maybe fit better with changes in xfce switch to gtk3?

Yes 15 seconds is fine, I was just reporting that it actually wasn't changed like Patrick wanted, because he only changed it in the echo for the logger and not in the line that actually executes the timeout, which is still at 10 seconds.
 
Old 05-23-2017, 01:12 PM   #5
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,839

Rep: Reputation: Disabled
Quote:
Originally Posted by pataphysician View Post
The compile line for firefox is actually correct as cairo-gtk3, that is not my problem. This is the first time Patrick has used gtk3 instead of gtk2, both options have been available for awhile in firefox, and I was wondering if now firefox is only going to allow being built with gtk3, or if this was a decision by Patrick to maybe fit better with changes in xfce switch to gtk3?
firefox from version 53.x won't support gtk+2 anymore: I guess this is a test as the next versions will forcibly use gtk+3 so it's better to check if it's all ok with the switch.
 
3 members found this post helpful.
Old 05-23-2017, 01:35 PM   #6
cgorac
Member
 
Registered: Oct 2009
Posts: 146

Rep: Reputation: 85
Any pointers on how to tune the Gtk3 look? In particular, I'd like to switch back to "normal" scroll bar instead of this new thin one, and also my fonts in Firefox menus etc. are tiny now.
 
1 members found this post helpful.
Old 05-23-2017, 01:43 PM   #7
pataphysician
Member
 
Registered: Oct 2012
Posts: 76

Original Poster
Rep: Reputation: Disabled
Well that sucks, but save me from bothering with recompiling, I guess theme breakage here we come. It seems at least firefox menus still show mnemonic underline without first hitting ALT, even though gtk3 made this impossible.

As far as font change for gtk3
you can edit .config/gtk-3.0/settings.ini

and change

gtk-font-name=

to whatever font and point size you want, I use Plasma 5 so not sure how that works with XFCE or KDE4

For scroll bars you will need to change your theme, if you have a theme that has stuff for both gtk2 and gtk3 they should have similar scroll bars, but if your theme is gtk2 only you will get Adwaita for gtk3, you can override this with

gtk-theme-name=

in the same settings.ini

the name will have to be of a gtk3 theme though, also theme that aren't Adwaita have a tendency to break with each new gtk3 version, though gtk are now claiming this won't happen, I'll believe it when I see it.

Last edited by pataphysician; 05-23-2017 at 01:51 PM.
 
Old 05-23-2017, 01:51 PM   #8
cgorac
Member
 
Registered: Oct 2009
Posts: 146

Rep: Reputation: 85
Thanks for the quick reply. Indeed, I fixed the font and changed the theme the way you suggested. It seems that Slackware-current has five Gtk3 themes: Default, Emacs, HighContrast, Adwaita and Adwaita-dark, but none of them seem to have "regular" toolbar with arrows, so I guess I'll have to live with the new one for while.
 
Old 05-23-2017, 01:52 PM   #9
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,703

Rep: Reputation: 665Reputation: 665Reputation: 665Reputation: 665Reputation: 665Reputation: 665
and with TIMEOUT 15, at this ligne, that's correct.

/sbin/dhcpcd -L -t ${DHCP_TIMEOUT[$i]:-10} ${DHCP_OPTIONS} ${1}
 
Old 05-23-2017, 02:17 PM   #10
pataphysician
Member
 
Registered: Oct 2012
Posts: 76

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by gmgf View Post
and with TIMEOUT 15, at this ligne, that's correct.

/sbin/dhcpcd -L -t ${DHCP_TIMEOUT[$i]:-10} ${DHCP_OPTIONS} ${1}
yes that's the line
 
Old 05-23-2017, 02:27 PM   #11
pataphysician
Member
 
Registered: Oct 2012
Posts: 76

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by cgorac View Post
Thanks for the quick reply. Indeed, I fixed the font and changed the theme the way you suggested. It seems that Slackware-current has five Gtk3 themes: Default, Emacs, HighContrast, Adwaita and Adwaita-dark, but none of them seem to have "regular" toolbar with arrows, so I guess I'll have to live with the new one for while.
There are some gtk3 themes up on slackbuild.org, Xfce is slowly moving to gtk3, so I assume at some point there will be more gtk3 themes in current.
 
Old 05-23-2017, 02:42 PM   #12
speck
Member
 
Registered: Nov 2001
Location: US
Distribution: Slackware 14.2
Posts: 361

Rep: Reputation: 104Reputation: 104
GTK3 has been in the Firefox release channel for about a year and had to put the following in my ~/.config/gtk-3.0/settings.ini file to make the scrollbar function more normally.

Code:
[Settings]
gtk-theme-name = "Adwaita"
gtk-primary-button-warps-slider = false
Setting gtk-primary-button-warps-slider to false returns the normal one screen up/one screen down click behavior to the scroll bar (instead of jumping to the spot on the screen where the mouse click occurs).

Last edited by speck; 05-23-2017 at 02:43 PM.
 
2 members found this post helpful.
Old 05-23-2017, 02:43 PM   #13
pataphysician
Member
 
Registered: Oct 2012
Posts: 76

Original Poster
Rep: Reputation: Disabled
Also to fix scrollbars to have arrows you can make a gtk.css in
~/.config/gtk-3.0/

in it have

*{

-GtkScrollbar-has-backward-stepper: 1;
-GtkScrollbar-has-forward-stepper: 1;

}
 
2 members found this post helpful.
Old 05-23-2017, 02:50 PM   #14
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 1,706

Rep: Reputation: 5309Reputation: 5309Reputation: 5309Reputation: 5309Reputation: 5309Reputation: 5309Reputation: 5309Reputation: 5309Reputation: 5309Reputation: 5309Reputation: 5309
Quote:
Originally Posted by speck View Post
Setting gtk-primary-button-warps-slider to false returns the normal one screen up/one screen down click behavior to the scroll bar (instead of jumping to the spot on the screen where the mouse click occurs).
I patched this in the Firefox all.js so that the scrollbar behavior is the same as it was with GTK+ v2. Sorry, I meant to mention that in the ChangeLog.
 
5 members found this post helpful.
Old 05-23-2017, 02:51 PM   #15
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,839

Rep: Reputation: Disabled
Quote:
Originally Posted by speck View Post
GTK3 has been in the Firefox release channel for about a year and had to put the following in my ~/.config/gtk-3.0/settings.ini file to make the scrollbar function more normally.

Code:
[Settings]
gtk-theme-name = "Adwaita"
gtk-primary-button-warps-slider = false
Setting gtk-primary-button-warps-slider to false returns the normal one screen up/one screen down click behavior to the scroll bar (instead of jumping to the spot on the screen where the mouse click occurs).
for that looks like Pat opted to directly patch the default behaviour in the build script
Code:
--- ./modules/libpref/init/all.js.orig	2017-04-10 21:13:21.000000000 -0500
+++ ./modules/libpref/init/all.js	2017-05-21 15:29:42.803757223 -0500
@@ -235,6 +235,9 @@
 // If true, all popups won't hide automatically on blur
 pref("ui.popup.disable_autohide", false);
 
+// Default to GTK+ v2 type scrolling:
+pref("ui.scrollToClick", 0);
+
 pref("browser.display.use_document_fonts",  1);  // 0 = never, 1 = quick, 2 = always
 // 0 = default: always, except in high contrast mode
 // 1 = always
EDIT: oops, beaten!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Slackware-Based Zenwalk Linux Gets New ISO Snapshot with GTK3 Build of Firefox LXer Syndicated Linux News 0 02-26-2017 01:40 AM
Minor typo in Slackware -current /etc/rc.d/rc.6 Linux.tar.gz Slackware 18 03-28-2016 06:44 AM
[SOLVED] Need oxygen-gtk3-1.4.1, but it was vanished from current denydias Slackware 4 09-04-2015 04:08 AM
fluxbox.SlackBuild in -current typo? wadsworth Slackware 9 11-13-2008 01:59 PM
Typo in slackware-current/source/a/lilo/liloconfig drumz Slackware 7 02-22-2008 12:53 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration