LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   slackware current, typo in new rc.inet1, also is gtk3 now required for firefox? (https://www.linuxquestions.org/questions/slackware-14/slackware-current-typo-in-new-rc-inet1-also-is-gtk3-now-required-for-firefox-4175606521/)

pataphysician 05-23-2017 12:31 PM

slackware current, typo in new rc.inet1, also is gtk3 now required for firefox?
 
There is a typo in the new rc.inet1 script the changelog say that it was updated to dhcp timeout of 15 seconds, but it seems to only have changed the echo statement for the logger, the actual timeout is still 10 seconds.

Also its seems that firefox is now built with gtk3, is this because it has to be? or is this for xfce integration?

gmgf 05-23-2017 12:53 PM

you have right for firefox it's compiled (--enable-default-toolkit=cairo-gtk3) option in the Pat SlackBuild, it need probably gtk+3 ;)

gmgf 05-23-2017 12:59 PM

(15 seconds should be a reasonable default DHCP timeout) in the rc.inet1 ;)

pataphysician 05-23-2017 01:07 PM

The compile line for firefox is actually correct as cairo-gtk3, that is not my problem. This is the first time Patrick has used gtk3 instead of gtk2, both options have been available for awhile in firefox, and I was wondering if now firefox is only going to allow being built with gtk3, or if this was a decision by Patrick to maybe fit better with changes in xfce switch to gtk3?

Yes 15 seconds is fine, I was just reporting that it actually wasn't changed like Patrick wanted, because he only changed it in the echo for the logger and not in the line that actually executes the timeout, which is still at 10 seconds.

ponce 05-23-2017 01:12 PM

Quote:

Originally Posted by pataphysician (Post 5714316)
The compile line for firefox is actually correct as cairo-gtk3, that is not my problem. This is the first time Patrick has used gtk3 instead of gtk2, both options have been available for awhile in firefox, and I was wondering if now firefox is only going to allow being built with gtk3, or if this was a decision by Patrick to maybe fit better with changes in xfce switch to gtk3?

firefox from version 53.x won't support gtk+2 anymore: I guess this is a test as the next versions will forcibly use gtk+3 so it's better to check if it's all ok with the switch.

cgorac 05-23-2017 01:35 PM

Any pointers on how to tune the Gtk3 look? In particular, I'd like to switch back to "normal" scroll bar instead of this new thin one, and also my fonts in Firefox menus etc. are tiny now.

pataphysician 05-23-2017 01:43 PM

Well that sucks, but save me from bothering with recompiling, I guess theme breakage here we come;). It seems at least firefox menus still show mnemonic underline without first hitting ALT, even though gtk3 made this impossible.

As far as font change for gtk3
you can edit .config/gtk-3.0/settings.ini

and change

gtk-font-name=

to whatever font and point size you want, I use Plasma 5 so not sure how that works with XFCE or KDE4

For scroll bars you will need to change your theme, if you have a theme that has stuff for both gtk2 and gtk3 they should have similar scroll bars, but if your theme is gtk2 only you will get Adwaita for gtk3, you can override this with

gtk-theme-name=

in the same settings.ini

the name will have to be of a gtk3 theme though, also theme that aren't Adwaita have a tendency to break with each new gtk3 version, though gtk are now claiming this won't happen, I'll believe it when I see it.

cgorac 05-23-2017 01:51 PM

Thanks for the quick reply. Indeed, I fixed the font and changed the theme the way you suggested. It seems that Slackware-current has five Gtk3 themes: Default, Emacs, HighContrast, Adwaita and Adwaita-dark, but none of them seem to have "regular" toolbar with arrows, so I guess I'll have to live with the new one for while.

gmgf 05-23-2017 01:52 PM

and with TIMEOUT 15, at this ligne, that's correct.

/sbin/dhcpcd -L -t ${DHCP_TIMEOUT[$i]:-10} ${DHCP_OPTIONS} ${1}

pataphysician 05-23-2017 02:17 PM

Quote:

Originally Posted by gmgf (Post 5714341)
and with TIMEOUT 15, at this ligne, that's correct.

/sbin/dhcpcd -L -t ${DHCP_TIMEOUT[$i]:-10} ${DHCP_OPTIONS} ${1}

yes that's the line

pataphysician 05-23-2017 02:27 PM

Quote:

Originally Posted by cgorac (Post 5714340)
Thanks for the quick reply. Indeed, I fixed the font and changed the theme the way you suggested. It seems that Slackware-current has five Gtk3 themes: Default, Emacs, HighContrast, Adwaita and Adwaita-dark, but none of them seem to have "regular" toolbar with arrows, so I guess I'll have to live with the new one for while.

There are some gtk3 themes up on slackbuild.org, Xfce is slowly moving to gtk3, so I assume at some point there will be more gtk3 themes in current.

speck 05-23-2017 02:42 PM

GTK3 has been in the Firefox release channel for about a year and had to put the following in my ~/.config/gtk-3.0/settings.ini file to make the scrollbar function more normally.

Code:

[Settings]
gtk-theme-name = "Adwaita"
gtk-primary-button-warps-slider = false

Setting gtk-primary-button-warps-slider to false returns the normal one screen up/one screen down click behavior to the scroll bar (instead of jumping to the spot on the screen where the mouse click occurs).

pataphysician 05-23-2017 02:43 PM

Also to fix scrollbars to have arrows you can make a gtk.css in
~/.config/gtk-3.0/

in it have

*{

-GtkScrollbar-has-backward-stepper: 1;
-GtkScrollbar-has-forward-stepper: 1;

}

volkerdi 05-23-2017 02:50 PM

Quote:

Originally Posted by speck (Post 5714363)
Setting gtk-primary-button-warps-slider to false returns the normal one screen up/one screen down click behavior to the scroll bar (instead of jumping to the spot on the screen where the mouse click occurs).

I patched this in the Firefox all.js so that the scrollbar behavior is the same as it was with GTK+ v2. Sorry, I meant to mention that in the ChangeLog.

ponce 05-23-2017 02:51 PM

Quote:

Originally Posted by speck (Post 5714363)
GTK3 has been in the Firefox release channel for about a year and had to put the following in my ~/.config/gtk-3.0/settings.ini file to make the scrollbar function more normally.

Code:

[Settings]
gtk-theme-name = "Adwaita"
gtk-primary-button-warps-slider = false

Setting gtk-primary-button-warps-slider to false returns the normal one screen up/one screen down click behavior to the scroll bar (instead of jumping to the spot on the screen where the mouse click occurs).

for that looks like Pat opted to directly patch the default behaviour in the build script
Code:

--- ./modules/libpref/init/all.js.orig        2017-04-10 21:13:21.000000000 -0500
+++ ./modules/libpref/init/all.js        2017-05-21 15:29:42.803757223 -0500
@@ -235,6 +235,9 @@
 // If true, all popups won't hide automatically on blur
 pref("ui.popup.disable_autohide", false);
 
+// Default to GTK+ v2 type scrolling:
+pref("ui.scrollToClick", 0);
+
 pref("browser.display.use_document_fonts",  1);  // 0 = never, 1 = quick, 2 = always
 // 0 = default: always, except in high contrast mode
 // 1 = always

EDIT: oops, beaten! :D


All times are GMT -5. The time now is 06:29 AM.