-   Slackware (
-   -   Slackware current multilib (

diwljina 07-18-2012 06:20 AM

Slackware current multilib

I just installed my first 64 bit Slackware and since version 14 is very near, I went with current, which will very soon be stable (I hope). Since I have to use Skype at work, I have to install Alien's multilib packages. I've seen that there are packages for currnet but since there was big update recently, will they work? They are about month old and lot of important stuff changed.

Cultist 07-18-2012 06:41 AM

they'll work. The updates to -current did not change the package versions installed with alienBOB's multilib setup. You can use pkgtool to verify your versions, if you're still not sure.

Bazzaah 07-18-2012 07:13 AM

I added the multilib packages over current/14 earlier today and all seems well. 32 bit wine works fine on my 64 bit system.

Just follow AlienBob's guide;

marrowsuck 07-18-2012 07:19 AM

Since libffi is removed from gcc-java in current and multilib-current,
you also need a libffi-compat32 package for skype.

diwljina 07-18-2012 04:06 PM

Thanks, guys, I'll try it tomorrow at work.

diwljina 07-19-2012 04:07 AM

Since I only needed skupe, I just installed zerouno's package and it worked. :hattip:

lanir 07-21-2012 08:31 PM

I'm also using the multilib packages on slackware64-current. They seem to work just fine and the distro packages they replace haven't had new versions come out.

The one complication I ran into was the nvidia driver and it's 32bit compatibility libs. I ended up reinstalling the driver along with the 32bit nvidia libs to get them to work. I wasn't specifically testing for that but that's the sequence I recall doing things in and what got some of my wine programs to work, for example.

All times are GMT -5. The time now is 03:58 AM.