-   Slackware (
-   -   Slackware current + gcc issue (

vexer 08-11-2003 11:57 AM

Slackware current + gcc issue
I installed slackware current and gcc -V option doesn't work. This is a problem because I believe it is the source of the following error:

bash-2.05b# ./configure
checking for a BSD-compatible install... /usr/bin/ginstall -c
checking whether build environment is sane... yes
/usr/src/gaim-0.66/missing: Unknown `--run' option
Try `/usr/src/gaim-0.66/missing --help' for more information
configure: WARNING: `missing' script is too old or missing
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for sed... /usr/bin/sed
checking for gcc... gcc
checking for C compiler default output... configure: error: C compiler cannot create executables
See `config.log' for more details.

I tried configuring 3 different programs to see if maybe it was an isolated error: gaim-0.66, fluxbox 0.1.14 and openbox 2.2.3

This an error on my behalf, or does the slackware team need to rebuilt a gcc package?


vexer 08-11-2003 11:59 AM

config.log clipping.

configure:2217: checking for C compiler version
configure:2220: gcc --version </dev/null >&5
gcc (GCC) 3.2.3
Copyright (C) 2002 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO

configure:2223: $? = 0
configure:2225: gcc -v </dev/null >&5
Reading specs from /usr/lib/gcc-lib/i486-slackware-linux/3.2.3/specs
Configured with: ../gcc-3.2.3/configure --prefix=/usr --enable-shared --enable-threads=posix --enable$
Thread model: posix
gcc version 3.2.3
configure:2228: $? = 0
configure:2230: gcc -V </dev/null >&5
gcc: argument to `-V' is missing
configure:2233: $? = 1
configure:2257: checking for C compiler default output
configure:2260: gcc -march=athlon-xp -mcpu=athlon-xp -02 -w -fomit-pointer conftest.c >&5
gcc: unrecognized option `-02'
cc1: unrecognized option `-fomit-pointer'
configure:2263: $? = 1
configure: failed program was:
| #line 2236 "configure"
| /* confdefs.h. */

vexer 08-11-2003 12:05 PM

Ok, I realised the error, turns out if was a non-gcc package related error, /etc/profile had some flags that were unrecognised (which I noticed in the above)

-fomit-pointer = -fomit-frame-pointer
-02 = -O2 (letter not number)

problem solved :/

All times are GMT -5. The time now is 05:36 AM.