LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-04-2018, 07:20 AM   #1
chrisVV
Member
 
Registered: Aug 2010
Posts: 322

Rep: Reputation: 139Reputation: 139
slackware-current breakage - imagemagick


The upgrade to imagemagick-6.9.9_42 in slackware-current and slackware64-current has an unannounced so bump. This breaks amongst other things emacs (probably some other things as well, dunno).

Note also the ChangeLog.txt for slackware-current (but not slackware64-current) incorrectly stated that gexiv2, json-c and json-glib were "upgraded". In fact, they were added.
 
Old 05-04-2018, 07:59 AM   #2
GazL
Senior Member
 
Registered: May 2008
Posts: 4,782
Blog Entries: 14

Rep: Reputation: Disabled
Can confirm:
Code:
emacs: error while loading shared libraries: libMagickWand-6.Q16HDRI.so.5: cannot open shared object file: No such file or directory
Thanks for the heads-up chris.

Right... off to rebuild it (which I do anyway as I prefer it with the lucid toolkit).
 
Old 05-04-2018, 10:44 AM   #3
RandomTroll
Senior Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 1,010

Rep: Reputation: 164Reputation: 164
Linking current imageMagick libraries to names emacs expects works.
 
Old 05-04-2018, 11:08 AM   #4
allend
LQ 5k Club
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 5,037

Rep: Reputation: 1762Reputation: 1762Reputation: 1762Reputation: 1762Reputation: 1762Reputation: 1762Reputation: 1762Reputation: 1762Reputation: 1762Reputation: 1762Reputation: 1762
Quote:
Note also the ChangeLog.txt for slackware-current (but not slackware64-current) incorrectly stated that gexiv2, json-c and json-glib were "upgraded". In fact, they were added.
Good catch!
It also applies to libmypaint and mypaint-brushes.

PS - I was wondering why I was not seeing those updates on my 32bit system.

Last edited by allend; 05-04-2018 at 11:16 AM. Reason: Added PS
 
Old 05-06-2018, 11:15 AM   #5
allend
LQ 5k Club
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 5,037

Rep: Reputation: 1762Reputation: 1762Reputation: 1762Reputation: 1762Reputation: 1762Reputation: 1762Reputation: 1762Reputation: 1762Reputation: 1762Reputation: 1762Reputation: 1762
@BDFL - Thanks very much for the changes. I think I am on-piste again.
 
Old 06-29-2018, 07:57 AM   #6
zentara
LQ Newbie
 
Registered: Jul 2011
Posts: 12

Rep: Reputation: Disabled
mouse pointer breakage in X also related to ImageMagick and Slackware

Hi, this was a little similar bug I found and drove me crazy for a few hours. I installed the latest Slackware-current, dated 6-25-2018, commonly known as Slackware 15. It comes with ImageMagick 6.9.10-3 Q16 x86_64. I wanted the latest ImageMagick7, and downloaded and installed the latest source in /usr/local, not removing the original IM6 in /usr/bin. What happened is my mouse pointer disappeared when starting X. As best I could tell, the pointer changed to an almost invisible text cursor, which for all intents and purposes left me without a mouse in X. I've repeated the process a few times, and am certain installing IM7 breaks the mouse pointer in X. It also broke the program xlock, and possible other things. Otherwise Slackware15 works like a charm.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
icu4c package upgrade in -current mpv breakage & fix 1337_powerslacker Slackware 4 12-08-2017 10:39 AM
[SOLVED] [Slackware 14.1] su -c, tty hijacking, and some breakage mancha Slackware 9 02-20-2014 08:09 PM
[SOLVED] 32Bit-current: imagemagick problem marrowsuck Slackware 2 03-30-2012 06:08 AM
Slackware current--imagemagick won`t work. AlanL Slackware 1 05-09-2006 01:46 AM
Slackware-current Imagemagick bug fix wastelander42 Slackware 2 02-03-2006 11:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration