-   Slackware (
-   -   Slackware Current 8139too upload speed issue (

Lucifer4o 03-19-2014 11:52 AM

Slackware Current 8139too upload speed issue
Hello guys ...

A strange issue started after upgrading to last slackware:

I have a end point device (router/server/firewall).

So 2 LAN Cards.

One of them is using the e1000 driver. It's intel based onboard chip.

The other one is using the 8139too driver (Realteck based) ...

And now the fun part begins - the trafick from the network to the card is slow. And I mean slow. The e1000 card keeps download speed of about 50 to 80 MBit/s ... same test performed with the 8139too card yealds 100 kbit/s speed. The problem is allways with the trafick facing the card (as I host few sites, I've seted the fast one to the outside world).

Things I've tried:

Loading the 8139cp drive - it is not supported.
Changing cables - no efect (hey - it could have worked).

Now as I write this post - there is a small chance the problem is with the PCI slot ... but this can be tested when I recieve the new hardware (as I managed to burn out my mainboard).

So ... does someone have some ideas ... how adn why this could have happened and - HOW CAN I FIX IT?

Paulo2 03-20-2014 10:14 PM

Hello Lucifer4o , with hardware you already changed cables and will change nic and slot.
With software, this driver is old and I think it doesn't require extra configuration,
but I can be wrong about that.
Maybe you have some firewall or qos rule active that is cutting traffic down.
Sorry for my vague ideas :D

Lucifer4o 03-21-2014 04:57 AM

Nope ...

No QOS - when I switched NIC the speed jumped to normal. So no QOS there ... and this is the second NIC(with 8139too driver) I have this problem on.

In few days I'll get a new mainboard and if the problem persist ... i don't know what to do.

Paulo2 03-21-2014 09:31 AM

If with two nics you have same problem, or you have no luck with these realtek nics :D
or this is a driver problem. Maybe something got corrupted when you did the upgrade,
or maybe some configuration was lost.

Is this the same driver (8139too) that you was using before the upgrade?
Realtek nics sometimes have clones that work with different drivers.

If you can, do a test with livecd (ubuntu, fedora, puppylinux) and see which driver
is loaded and if the problem remains.

Lucifer4o 03-21-2014 01:23 PM

8139too is the default linux driver for this Raltek Chip. There are 2 drivers - 8139cp and 8139too (the 8139cp is the older and buggier driver).

When I do "lspci -vv" as supported drivers for the NIC are both 8139too and 8139cp. Tried to modprobe 8139cp and rmmod 8139too but the NIC refuses to be found by the system ... I could always reinstall kernel part of the Slackware (this includes drivers), but I really don't think this will do it.

I'll try the live distro ...

jtsn 03-21-2014 03:11 PM

8139cp only supports 8139C+, the little FastEth brother of the 8169. It doesn't appear on regular PCI cards, because it was one dollar more expensive than the 8139B/D did go out of production long ago. So 8139too is the correct driver.

First thing to do, if some kernel driver breaks due to an upgrade, is to downgrade the kernel again. If that helps then you go to and file a bug reportt. That's it.

Lucifer4o 03-21-2014 04:14 PM

Sorry, but how to downgrade the kernel? Is there archive for Slackware packages?


OK ... New 20 as they say in my part of the world - all fine!

This is trough 100Mbit switch from the internel ...


And that was 10 minute of euphorie ... it's bad again. I'm a bit confused!

Lucifer4o 03-22-2014 05:18 AM

So ... a little bit more development from today. As the speed raised and was good for few hours. This morning I was greeted with:


Mar 22 11:04:51 gate kernel: [230330.938097] NMI: PCI system error (SERR) for reason a1 on CPU 0.
Mar 22 11:04:51 gate kernel: [230330.939007] Dazed and confused, but trying to continue
Mar 22 11:05:00 gate kernel: [230339.712018] ------------[ cut here ]------------
Mar 22 11:05:00 gate kernel: [230339.712042] WARNING: at net/sched/sch_generic.c:255 dev_watchdog+0x248/0x260()
Mar 22 11:05:00 gate kernel: [230339.712057] Modules linked in: ipv6 tun xt_nat iptable_mangle xt_DSCP xt_tcpudp ipt_MASQUERADE xt_conntrack iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_filter ip_tables x_tables lp ppdev parport_pc parport fuse usb_storage i2c_dev coretemp i915 mei_me ehci_pci uhci_hcd mei drm_kms_helper drm e1000e i2c_algo_bit i2c_core acpi_cpufreq ptp mperf pps_core video processor thermal_sys 8139too psmouse tpm_infineon gpio_ich ehci_hcd lpc_ich serio_raw intel_agp evdev mii freq_table hwmon hp_wmi button tpm_tis intel_gtt tpm agpgart tpm_bios sparse_keymap snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_page_alloc rfkill wmi snd_timer snd soundcore kvm microcode loop
Mar 22 11:05:00 gate kernel: [230339.712159] CPU: 0 PID: 0 Comm: swapper/0 Not tainted 3.10.30 #2
Mar 22 11:05:00 gate kernel: [230339.712160] Hardware name: Hewlett-Packard HP Compaq 6000 Pro SFF PC/3048h, BIOS 786G2 v01.09 08/25/2009

All times are GMT -5. The time now is 12:58 PM.