-   Slackware (
-   -   Slackware - can't get KDE to run after install (

mandrakewanta 05-01-2005 04:15 PM

Slackware - can't get KDE to run after install
I just switch from MDK to Slackware. I got the OS installed. I ran from root the configuration for my monitor, video card etc. I run startx, startkde and get command not found. I would like to get KDE running. I'm thinking about going back to Mandrake. Any sugestions for getting KDE going in slackware?


masand 05-01-2005 04:20 PM

i see no reason that u do not have this comand if u have installed kde packages
so are u sure about that kde packges

or mount ur 2nd Slack cd go to kde dir. and do

upgradepkg --install-new *.tgz


mandrakewanta 05-01-2005 04:50 PM

Yes I'm sure that KDE is installed. I did a slocate for kde and many rows were returned. What else should i look at. Thanks for the response.

mandrakewanta 05-01-2005 04:52 PM

I did create a partition for /opt which is where all the KDE stuff is. Should I point a config file to the partition? Maybe that is the issue?

mandrakewanta 05-01-2005 05:01 PM


Also I'm just a newbie that reads alot of forums. Please keep it simple for me.



# $Xorg: startx.cpp,v 1.3 2000/08/17 19:54:29 cpqbld Exp $
# This is just a sample implementation of a slightly less primitive
# interface than xinit. It looks for user .xinitrc and .xserverrc
# files, then system xinitrc and xserverrc files, else lets xinit choose
# its default. The system xinitrc should probably do things like check
# for .Xresources files and merge them in, startup up a window manager,
# and pop a clock and serveral xterms.
# Site administrators are STRONGLY urged to write nicer versions.
# $XFree86: xc/programs/xinit/startx.cpp,v 3.16tsi Exp $


+++++++++++++++++++++++++++++++++ more to file but i stop here +++++++++++++++++++++

Here Vi xinitrc

/etc/X11/xinit# vi xinitrc

# $XConsortium: xinitrc.cpp,v 1.4 91/08/22 11:41:34 rws Exp $


# merge in defaults and keymaps

if [ -f $sysresources ]; then
xrdb -merge $sysresources

if [ -f $sysmodmap ]; then
xmodmap $sysmodmap

if [ -f $userresources ]; then
xrdb -merge $userresources

if [ -f $usermodmap ]; then
xmodmap $usermodmap

# Start the window manager:

speel 05-01-2005 05:03 PM

if you wanna make sure if its installed login as root then type pkgtool then choose view

mandrakewanta 05-01-2005 05:06 PM

When I ran xorgconfig I did so from SSH from my laptop to the slackware machine. I had two ssh windows open. I types startx in the other remot window and got this error. I also heard my monitor make that cring sound

This program will create a basic xorg.conf file, based on menu selections you

The xorg.conf file usually resides in /usr/X11R6/etc/X11 or /etc/X11. A sample
xorg.conf file is supplied with Xorg; it is configured for a standard
VGA card and monitor with 640x480 resolution. This program will ask for a
pathname when it is ready to write the file.

You can either take the sample xorg.conf as a base and edit it for your
configuration, or let this program produce a base xorg.conf file for your
configuration and fine-tune it.

Before continuing with this program, make sure you know what video card
you have, and preferably also the chipset it uses and the amount of video
memory on your video card. SuperProbe may be able to help with this.

Press enter to continue, or ctrl-c to abort.
root@slackware:/usr/X11R6/lib/X11/xinit# startx
xauth: creating new authority file /root/.Xauthority
xauth: creating new authority file /root/.Xauthority

_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/slackware:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X Window System Version 6.8.1
Release Date: 17 September 2004
X Protocol Version 11, Revision 0, Release 6.8.1
Build Operating System: Linux 2.4.29 i686 [ELF]
Current Operating System: Linux slackware 2.4.29 #6 Thu Jan 20 16:30:37 PST 2005 i686
Build Date: 23 January 2005
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun May 1 22:03:22 2005
(==) Using config file: "/etc/X11/xorg.conf"
(EE) xf86OpenSerial: Cannot open device /dev/mouse
No such device.

(EE) Mouse1: cannot open input device
(EE) PreInit failed for input device "Mouse1"
No core pointer

Fatal server error:
failed to initialize core devices

Please consult the The X.Org Foundation support
at http://wiki.X.Org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

*** If unresolved symbols were reported above, they might not
*** be the reason for the server aborting.

FatalError re-entered, aborting
Caught signal 11. Server aborting

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.

mandrakewanta 05-01-2005 05:19 PM

Looks like my mouse is not being found. I selected GDB on install. I have a microsoft USB laser mouse the standard white one connected to the box. Some other issues might be going on also.

mandrakewanta 05-01-2005 05:24 PM

I also get this when I run startkde now. This is a fresh install of the os.

root@slackware:~# startkde
xsetroot: unable to open display ''
xset: unable to open display ""
xset: unable to open display ""
xset: unable to open display ""
xsetroot: unable to open display ''
startkde: Starting up...
startkde: Running kpersonalizer...
/usr/X11R6/bin/iceauth: creating new authority file /root/.ICEauthority
kwin: cannot connect to X server
kpersonalizer: cannot connect to X server
kpersonalizer: cannot connect to X server
kpersonalizer: cannot connect to X server

Poetics 05-01-2005 05:49 PM

Edit: Nevermind, didn't fully read first post

gbonvehi 05-01-2005 06:37 PM

Try changing your mouse device file in /etc/X11/xorg.conf to /dev/misc/psaux or /dev/input/mice or /dev/input/mouse0

mrcheeks 05-01-2005 07:02 PM



startx /usr/X11R6/bin/startkde --:0
or put this line in your ~/.xsession

exec startkde

AgtSkippy 06-09-2005 12:45 AM

hey, I had this similar problem, and the #startx /usr/X11RC/bin/startkde --:0 command worked for me. but how can I make "0" be the default display?

masand 06-09-2005 01:01 AM

by default "0" is the default display
u get to different one if u are running more that one GUI


Namaseit 06-09-2005 11:03 AM

You can't just run "startkde" and have it come up.

You run type this "startx startkde". You're starting up X and then having it run KDE. The only problem with this is that it starts up an xterm that if you close it, it closes X and KDE. So I would say just run kdm or set your default runlevel to 4 in /etc/inittab.

Good Day.

All times are GMT -5. The time now is 04:07 AM.